PDA

View Full Version : apache 2.4?



maikcat
25-Nov-2013, 14:12
greetings all,

does anyone knows if apache 2.4.2 is (or will) be added to package update list in SLES 11 SP3?

thank you in advance

Michael.

smflood
25-Nov-2013, 15:33
On 25/11/2013 13:14, maikcat wrote:

> does anyone knows if apache 2.4.2 is (or will) be added to package
> update list in SLES 11 SP3?

SLES11 SP3 includes Apache version 2.2.12 (though will include some
fixes backported from later versions).

I wouldn't expect SLES11 SP3 to switch to Apache 2.4.x but for it to be
included with SLES11 SP4 and/or SLES12.

What particular feature(s) are you looking for from Apache 2.4.x?

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

erictwendell
26-Nov-2013, 07:01
Well the other web servers expose configuration options that allows user to increase the DH strength, but Apache does not. But, if you go through the hassle of installing Apache from source code, there's an easy fix for this problem. It has a bug #49559 that contains a patch that introduces a new configuration directive, called SSLDHParametersFile, that adds the missing functionality to Apache httpd 2.4.x.

---------------------------------------------------------------------------------------------
Solution Provider (http://www.ariestco.com/solutiondevelopment)

smflood
28-Nov-2013, 18:31
On 26/11/2013 06:04, erictwendell wrote:

> Well the other web servers expose configuration options that allows user
> to increase the DH strength, but Apache does not. But, if you go through
> the hassle of installing Apache from source code, there's an easy fix
> for this problem. It has a bug #49559 that contains a patch that
> introduces a new configuration directive, called SSLDHParametersFile,
> that adds the missing functionality to Apache httpd 2.4.x.

So according to https://issues.apache.org/bugzilla/show_bug.cgi?id=49559
the fix is either in 2.4.2 or 2.4.7 but there's no reply to requests for
it to be backported to 2.2.x.

Let me ask SUSE what there plans are regarding Apache 2.4.x for SLES.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------