PDA

View Full Version : LUN detected but not mounted and detect as raw disk



duderage
04-Dec-2013, 12:29
Hi,
We have 2 server that connected to SAN using Fibre channel and have a problem of LUN detected but not mounted and detect as raw disk after a reboot. Meanwhile the other servers able to mount it.

the PROBLEMATIC servers:
-----------------------------------
regndbrepo01:/dev/mapper # ls -l
total 0
brw-r----- 1 root disk 253, 0 Dec 4 16:46 360050768028082bde800000000000003
brw-rw---- 1 root disk 253, 1 Dec 4 16:46 360050768028082bde800000000000003_part1
brw-r----- 1 root disk 253, 3 Dec 4 16:46 360050768028082bde800000000000013
brw-r----- 1 root disk 253, 2 Dec 4 16:46 360050768028082bde80000000000001a
lrwxrwxrwx 1 root root 16 Dec 4 13:19 control -> ../device-mapper

the 2 disk that i have highlighted above doesnt contain the _part1. it detects as a raw disk.

the NORMAL servers:
---------------------------
eedb01:/dev/mapper # ls -l
total 0
brw-r----- 1 root disk 253, 0 Aug 1 11:23 360050768028082bde800000000000013
brw-rw---- 1 root disk 253, 1 Aug 1 11:23 360050768028082bde800000000000013_part1
brw-r----- 1 root disk 253, 2 Aug 1 11:23 360050768028082bde80000000000001b
brw-rw---- 1 root disk 253, 3 Aug 1 11:23 360050768028082bde80000000000001b_part1
lrwxrwxrwx 1 root root 16 Aug 1 11:23 control -> ../device-mapper

the one 1 highlight is the SAME LUN as the problematic one above. At this server it can be detected and have the "_part1"


We already rescan the disk in order to get the LUN mounted normal but FAIL.

Have anyone experience such this issue? Appreciate you can share and guide for the resolution.

jmozdzen
04-Dec-2013, 13:11
Hi duderage,

what does "fdisk -l /dev/mapper/360050768028082bde800000000000013" report (that command lists the partition table of the disk, without changing it)?

What messages are in syslog when detecting the disk device, concerning i.e. partition discovery and/or errors when accessing the device?

If fdisk doesn't report an error or the expected partitioning, you might want to dump i.e. the first MB of the device on both nodes and compare them (i.e. "dd if=/dev/mapper/360050768028082bde800000000000013 of=/tmp/test.dmp bs=1M count=1; md5sum /tmp/test.dmp").

Do you see any messages in your SAN's log concering the first server's access to the LUN?

As you can see, I'd like to verify that the LUN is seem identically by both servers. If not, you'd need to check your SAN setup. If both LUNs are identical, then if'd be something on your server that prevents creation of the per-partition devices.

Regards,
Jens