PDA

View Full Version : lxdm at boot



sacarde
08-Dec-2013, 09:06
hi,
I build an appliance with lxde (cloned)
- including package "lxdm"
- selected runlevel 5 graphical

but when start it stop at login no-graphical

and I dont view service lxdm




how can I start lxdm at boot?




thank you


--
sacarde
------------------------------------------------------------------------
sacarde's Profile: http://forums.opensuse.org/member.php?userid=78470
View this thread: http://forums.opensuse.org/showthread.php?t=493143

DocB
16-Dec-2013, 13:26
Hm...not sure if here or on the Suse-Studio Forum is less traffic.

Anyway, I face the same problem. For whatever reason it does not find
lxdm and starts with xfce as windowmanager. although
/etc/sysconfig/displaymanager is properly maintained....

Seems that the pattern lxde is broken - otherwise it should boot....


--
DocB
------------------------------------------------------------------------
DocB's Profile: http://forums.opensuse.org/member.php?userid=574
View this thread: http://forums.opensuse.org/showthread.php?t=493143

sacarde
17-Dec-2013, 11:56
I try removing lxdm and installing lightdmand I put in
script:DISPLAYMANAGER="lightdm"but when start (graphics) i have:'Libero
- Community - I siti personali'
(http://digilander.libero.it/sacarde/np/suse5.jpgdo) you solve?thank you


--
sacarde
------------------------------------------------------------------------
sacarde's Profile: http://forums.opensuse.org/member.php?userid=78470
View this thread: http://forums.opensuse.org/showthread.php?t=493143

sacarde
02-Jan-2014, 11:36
I solve by heizi suggestion I add to start-script:> #set lxde as default wmsed 's/^DEFAULT_WM *=.*/DEFAULT_WM="lxde" /g' -i
> /etc/sysconfig/windowmanager#enable lxdmcat >
> /usr/lib/systemd/system/lxdm.service[Unit]Description=LXDM (Lightweight
> X11 Display
> Manager)#Documentation=man:lxdm(8)Conflicts=getty@ tty1.serviceAfter=systemd-user-sessions.service
> getty@tty1.service plymouth-quit.service
> livesys-late.service#Conflicts=plymouth-quit.service[Service]ExecStart=/usr/bin/lxdmRestart=alwaysIgnoreSIGPIPE=no#BusName=org.fre edesktop.lxdm[Install]Alias=display-manager.serviceEOFsystemctl
> enable lxdm thanks


--
sacarde
------------------------------------------------------------------------
sacarde's Profile: http://forums.opensuse.org/member.php?userid=78470
View this thread: http://forums.opensuse.org/showthread.php?t=493143