PDA

View Full Version : failed dependency : compat-32bit >= 9-200407011229



lobret
16-Jan-2014, 17:15
Hello,

running an rpm package to check dependencies for installing a specific application RPM on SUSE 11 SP2 X86_64, I have the following error:
warning: /depot/hpse/APPQcime-Requires-9.6.1-83.i386.rpm: Header V3 DSA signature: NOKEY, key ID 2689b887
error: Failed dependencies:
compat >= 2004.7.1-1.2 is needed by APPQcime-Requires-9.6.1-83.i386

Which rpm package should I install in order to get rid of this error?

Thanks.

LB

mikewillis
16-Jan-2014, 18:02
Hello,

running an rpm package to check dependencies for installing a specific application RPM on SUSE 11 SP2 X86_64, I have the following error:
warning: /depot/hpse/APPQcime-Requires-9.6.1-83.i386.rpm: Header V3 DSA signature: NOKEY, key ID 2689b887
error: Failed dependencies:
compat >= 2004.7.1-1.2 is needed by APPQcime-Requires-9.6.1-83.i386

Which rpm package should I install in order to get rid of this error?


Try:

$ zypper in /depot/hpse/APPQcime-Requires-9.6.1-83.i386.rpm


From 'man zypper'


Zypper is also able to install plain RPM files while trying to satisfy their dependencies using packages from defined repositories. You can install a plain RPM file by specifying its location in the install command arguments either as a local path or an URI. E.g.:

$ zypper install ~/rpms/foo.rpm http://some.site/bar.rpm



Incidentally, your post says you're using SUSE 11 SP2 X86_64 which is ambiguous. There's SLED 11 SP2 (Desktop) and SLES 11 SP2 (Server). I would guess you're using SLES 11 SP2 since you've posted in the SLES forum. I raise it because I can see different packages with compat in their name in SLES repos compared to SLED repos.