PDA

View Full Version : No keyboard input when logging into SLES 11



MangoRunner
25-Jan-2014, 22:36
Hello everyone! I'm new to the world of linux and I need help with this issue that I am having.

I'm running Suse 11 SP2 x64 and for some reason my PS2 keyboard does not work at all in the login screen. I get no input whatsoever and the numpad/capslock/scrolllock lights only switch on when I connect the keyboard to the computer. It works fine when I go to into failsafe mode with every key working just as it would previously before this issue came up.

I've searched for quite a bit regarding this issue but nothing worked for me. Some places had recommendations like changing things in files in places like

/etc/X11/xorg.conf.d/

but I don't even have that folder in the X11 directory. I only have the xorg.conf folder.

Another place recommended something like this:



Code:
# This is here to serve as a note to myself, and future developers.
#
# Any Display manager (gdm,kdm,xdm) has the following problem: if
# it is started before any getty, and no vt is specified, it will
# usually run on vt2. When the getty on vt2 then starts, and the
# DM is already started, the getty will take control of the keyboard,
# leaving us with a "dead" keyboard.
#
# Resolution: add the following line to /etc/inittab
#
# x:a:once:/etc/X11/startDM.sh
#
# and have /etc/X11/startDM.sh start the DM in daemon mode if
# a lock is present (with the info of what DM should be started),
# else just fall through.
#
# How this basically works, is the "a" runlevel is a additional
# runlevel that you can use to fork processes with init, but the
# runlevel never gets changed to this runlevel. Along with the "a"
# runlevel, the "once" key word means that startDM.sh will only be
# run when we specify it to run, thus eliminating respawning
# startDM.sh when "xdm" is not added to the default runlevel, as was
# done previously.
#
# This script then just calls "telinit a", and init will run
# /etc/X11/startDM.sh after the current runlevel completes (this
# script should only be added to the actual runlevel the user is
# using).


I looked at a couple other things but I don't have the startDM.sh stuff either.

I'm running Suse 11 with SP2 on an HP Proliant DL380 G5.

Thanks in advance!

MangoRunner

malcolmlewis
25-Jan-2014, 23:37
On Sat 25 Jan 2014 09:44:02 PM CST, MangoRunner wrote:


Hello everyone! I'm new to the world of linux and I need help with this
issue that I am having.

I'm running Suse 11 SP2 x64 and for some reason my PS2 keyboard does not
work at all in the login screen. I get no input whatsoever and the
numpad/capslock/scrolllock lights only switch on when I connect the
keyboard to the computer. It works fine when I go to into failsafe mode
with every key working just as it would previously before this issue
came up.

I've searched for quite a bit regarding this issue but nothing worked
for me. Some places had recommendations like changing things in files in
places like

/etc/X11/xorg.conf.d/

but I don't even have that folder in the X11 directory. I only have the
xorg.conf folder.

Another place recommended something like this:


Code:
--------------------

Code:
# This is here to serve as a note to myself, and future developers.
#
# Any Display manager (gdm,kdm,xdm) has the following problem: if
# it is started before any getty, and no vt is specified, it will
# usually run on vt2. When the getty on vt2 then starts, and the
# DM is already started, the getty will take control of the keyboard,
# leaving us with a "dead" keyboard.
#
# Resolution: add the following line to /etc/inittab
#
# x:a:once:/etc/X11/startDM.sh
#
# and have /etc/X11/startDM.sh start the DM in daemon mode if
# a lock is present (with the info of what DM should be started),
# else just fall through.
#
# How this basically works, is the "a" runlevel is a additional
# runlevel that you can use to fork processes with init, but the
# runlevel never gets changed to this runlevel. Along with the "a"
# runlevel, the "once" key word means that startDM.sh will only be
# run when we specify it to run, thus eliminating respawning
# startDM.sh when "xdm" is not added to the default runlevel, as was
# done previously.
#
# This script then just calls "telinit a", and init will run
# /etc/X11/startDM.sh after the current runlevel completes (this
# script should only be added to the actual runlevel the user is
# using).
--------------------



I looked at a couple other things but I don't have the startDM.sh stuff
either.

I'm running Suse 11 with SP2 on an HP Proliant DL380 G5.

Thanks in advance!

MangoRunner




Hi
So in the BIOS options can you change the settings for a PS/2 keyboard?

Else, at the boot options where you select to boot into SUSE, does it
work here, I'm assuming yes, since you can select failsafe?

If so enter the number 3 and press enter to boot the system at runlevel
3, then login as root user and run the command;


sax2 -r

configure as required, save and exit, then back at the command prompt
run;


init 5 && exit


--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.2 Kernel 3.11.6-4-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

MangoRunner
26-Jan-2014, 04:46
Hi
So in the BIOS options can you change the settings for a PS/2 keyboard?

Else, at the boot options where you select to boot into SUSE, does it
work here, I'm assuming yes, since you can select failsafe?

If so enter the number 3 and press enter to boot the system at runlevel
3, then login as root user and run the command;


sax2 -r

configure as required, save and exit, then back at the command prompt
run;


init 5 && exit


--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.2 Kernel 3.11.6-4-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

The PS2 keyboard worked in failsafe. I don't understand why it wouldn't work in the regular one. If it was off in the BIOS it wouldn't work even in failsafe. But after going through Sax2 'wizard' the keyboard finally worked.

Thanks a bunch!

MangoRunner