PDA

View Full Version : Adding 2nd processor to existing SuSE10 VmWare server



jlewter
28-Jan-2014, 00:05
Have a server that we haven't upgraded yet, but plan to do so soon. It is current SuSE10 with one processor, and we need to add an extra processor. It is running on ESX VM host 4.1. Is it as simple as downing the vm, adding the second processor and booting back up or is there something else that will need to be done to SuSE OS?

jlewter
28-Jan-2014, 00:10
I read something about installing the kernel-smp module to the server to make it work. So would proper step be to add module, down the vm and add the second processor and boot back up, or down the vm, add the second processor, boot back up and install the kernel-smp module and reboot? If that is what needs to be done.

ab
28-Jan-2014, 00:42
On 01/27/2014 04:14 PM, jlewter wrote:
>
> I read something about installing the kernel-smp module to the server to
> make it work. So would proper step be to add module, down the vm and add
> the second processor and boot back up, or down the vm, add the second
> processor, boot back up and install the kernel-smp module and reboot? If
> that is what needs to be done.

For some reason I thought the SLES 10 kernels automatically supported smp,
at least for a couple/few processors. Based on that I'd just stop the VM,
add the processor, restart the VM and see if you get multiple processors
showing up in /proc/cpuinfo (or several other places).

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...