PDA

View Full Version : All mirrors dissaperared in SMT!



imoore
03-Feb-2014, 04:55
I checked the emails from our SMT server this morning and found the following:

WARNING: The following repositories cannot be mirrored.
Maybe you have not enough permissions to download these repositories?

* OES2-SP2-Updates sles-10-x86_64
* SLES10-SP2-Updates sles-10-x86_64
* SLES10-SP3-Online sles-10-x86_64
* SLES11-SP2-Updates sle-11-x86_64
* SLE11-SP1-SMT-Updates sle-11-x86_64
* SLES11-SP3-Updates sle-11-i586
* OES11-SP1-Updates sle-11-x86_64
* Mobility-1.2-Updates sle-11-x86_64
* SLES11-SP1-Updates sle-11-x86_64
* SLE11-HAE-SP1-Updates sle-11-x86_64
* SLES10-SP4-Updates sles-10-x86_64
* OES11-SP2-Updates sle-11-x86_64
* SLES10-SP3-Updates sles-10-x86_64
* SLED11-SP3-Updates sle-11-x86_64
* OES2-SP3-Pool sles-10-x86_64
* OES2-SP3-Updates sles-10-x86_64
* SLES10-SP4-Online sles-10-x86_64
* SLES11-SP2-Updates sle-11-i586

Our subscriptions are current and the Customer centre lists all our products correctly.
Running smt-catalogs -o on the server gives:

.------------------------------------------------------------------------------------------------------------------------------------.
| Mirror? | ID | Type | Name | Target | Description | Can be Mirrored | Staging |
+---------+----+------+-----------------------+----------------+-----------------------------------------+-----------------+---------+
| Yes | 1 | nu | Mobility-1.2-Updates | sle-11-x86_64 | Mobility-1.2-Updates for sle-11-x86_64 | No | No |
| Yes | 2 | nu | OES11-SP1-Updates | sle-11-x86_64 | OES11-SP1-Updates for sle-11-x86_64 | No | No |
| Yes | 3 | nu | OES11-SP2-Updates | sle-11-x86_64 | OES11-SP2-Updates for sle-11-x86_64 | No | No |
| Yes | 4 | nu | OES2-SP2-Updates | sles-10-x86_64 | OES2-SP2-Updates for sles-10-x86_64 | No | No |
| Yes | 5 | nu | OES2-SP3-Pool | sles-10-x86_64 | OES2-SP3-Pool for sles-10-x86_64 | No | No |
| Yes | 6 | nu | OES2-SP3-Updates | sles-10-x86_64 | OES2-SP3-Updates for sles-10-x86_64 | No | No |
| Yes | 7 | nu | SLE11-HAE-SP1-Updates | sle-11-x86_64 | SLE11-HAE-SP1-Updates for sle-11-x86_64 | No | No |
| Yes | 8 | nu | SLE11-SP1-SMT-Updates | sle-11-x86_64 | SLE11-SP1-SMT-Updates for sle-11-x86_64 | No | No |
| Yes | 9 | nu | SLED11-SP3-Updates | sle-11-x86_64 | SLED11-SP3-Updates for sle-11-x86_64 | No | No |
| Yes | 10 | nu | SLES10-SP2-Updates | sles-10-x86_64 | SLES10-SP2-Updates for sles-10-x86_64 | No | No |
| Yes | 11 | nu | SLES10-SP3-Online | sles-10-x86_64 | SLES10-SP3-Online for sles-10-x86_64 | No | No |
| Yes | 12 | nu | SLES10-SP3-Updates | sles-10-x86_64 | SLES10-SP3-Updates for sles-10-x86_64 | No | No |
| Yes | 13 | nu | SLES10-SP4-Online | sles-10-x86_64 | SLES10-SP4-Online for sles-10-x86_64 | No | No |
| Yes | 14 | nu | SLES10-SP4-Updates | sles-10-x86_64 | SLES10-SP4-Updates for sles-10-x86_64 | No | No |
| Yes | 15 | nu | SLES11-SP1-Updates | sle-11-x86_64 | SLES11-SP1-Updates for sle-11-x86_64 | No | No |
| Yes | 16 | nu | SLES11-SP2-Updates | sle-11-i586 | SLES11-SP2-Updates for sle-11-i586 | No | No |
| Yes | 17 | nu | SLES11-SP2-Updates | sle-11-x86_64 | SLES11-SP2-Updates for sle-11-x86_64 | No | No |
| Yes | 18 | nu | SLES11-SP3-Updates | sle-11-i586 | SLES11-SP3-Updates for sle-11-i586 | No | No |
'---------+----+------+-----------------------+----------------+-----------------------------------------+-----------------+---------'


I ran YaST2 smt-server on the server and checked the CC details there and clicked the Test button which returns Success, so our login is working.
When I run YaST2 smt I only see the Opensuse & graphics card driver repos listed.

mikewillis
03-Feb-2014, 10:00
I very occasionally see SMT decide it can't mirror some repos only to decide it can mirror them again a few hours later. No problems last night though. What happens if you run

$ smt-ncc-sync
If the problem persists check the credentials SMT is using against what's listed at
https://secure-www.novell.com/center/regadmin/jsps/mirrorcreds_app.jsp

When posting output of commands wrapping it in CODE tags helps keep it readable. Look for the # button in the toolbar when composing.

malcolmlewis
03-Feb-2014, 16:48
On Mon 03 Feb 2014 09:04:01 AM CST, mikewillis wrote:


I very occasionally see SMT decide it can't mirror some repos only to
decide it can mirror them again a few hours later. No problems last
night though. What happens if you run

Code:
--------------------
$ smt-ncc-sync
--------------------

If the problem persists check the credentials SMT is using against
what's listed at
https://secure-www.novell.com/center/regadmin/jsps/mirrorcreds_app.jsp

When posting output of commands wrapping it in CODE tags helps keep it
readable. Look for the # button in the toolbar when composing.




Hi
The other option I been told is to run;


suse_register -r

This should re-enable them.

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.2 Kernel 3.11.6-4-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

imoore
03-Feb-2014, 22:35
Thanks for the suggestions. As it happens, all the repos are all enabled again this morning so I guess it just fixed itself after a couple of days! Good to know that I'm not the only one and that I can try those commands if it happens again.

Cheers,
Ian