PDA

View Full Version : PHP5 Upgrade



wolfmann
28-Oct-2011, 23:06
Are there any installation repositories for upgrading PHP5 and other
components, or can I use the openSUSE sources with caveat?


--
wolfmann
------------------------------------------------------------------------
wolfmann's Profile: http://forums.novell.com/member.php?userid=118889
View this thread: http://forums.novell.com/showthread.php?t=447505

malcolmlewis
28-Oct-2011, 23:26
On Fri, 28 Oct 2011 22:06:02 GMT
wolfmann <wolfmann@no-mx.forums.novell.com> wrote:

>
> Are there any installation repositories for upgrading PHP5 and other
> components, or can I use the openSUSE sources with caveat?
>
>
Hi
This gets asked an numerous times, if it's security related then check
the changelogs as security fixes are backported. Features you can look
at using the Open Build Service here for SLE rpms (just select in the
drop down);
http://software.opensuse.org/search?

There may also be a later version on the SLE SDK, this and the Open
Build Services rpms aren't supported as such.

I wouldn't use openSUSE specific rpms as you will fall into all sorts
of conflicts.

If you want to share specifics on you end goal, there may be other
options.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
up 19:07, 3 users, load average: 0.05, 0.05, 0.05
GPU GeForce 8600 GTS Silent - Driver Version: 285.05.09

dirkmueller
04-Nov-2011, 10:16
Which SLES version do you run, and which PHP version do you look for?
depending on the answer to those questions there are several options.
Thanks a lot in advance.


--
dirkmueller
------------------------------------------------------------------------
dirkmueller's Profile: http://forums.novell.com/member.php?userid=21451
View this thread: http://forums.novell.com/showthread.php?t=447505

wolfmann
05-Nov-2011, 03:45
>
> This gets asked an numerous times, if it's security related then check
> the changelogs as security fixes are backported. Features you can look
> at using the Open Build Service here for SLE rpms (just select in the
> drop down);
> 'software.opensuse.org: Search Results'
> (http://software.opensuse.org/search?)
>

It was for a specific software requirement 5.3.x for a content
management
system provided by Perforce Software (Chronicle).

I was going to compile from source, but I wanted to avoid that as I
also want to avoid recomiling apache from source if I ran into issues.

It would be nice if there was a clear upgrade path.

I would appreciate any feedback, thank you!


--
wolfmann
------------------------------------------------------------------------
wolfmann's Profile: http://forums.novell.com/member.php?userid=118889
View this thread: http://forums.novell.com/showthread.php?t=447505

wolfmann
05-Nov-2011, 03:45
dirkmueller;2151318 Wrote:
> Which SLES version do you run, and which PHP version do you look for?
> depending on the answer to those questions there are several options.
> Thanks a lot in advance.

SLES 11.1 (whatever is available from Novell) and 5.3+. Appreciate any
feedback. Thank you.


--
wolfmann
------------------------------------------------------------------------
wolfmann's Profile: http://forums.novell.com/member.php?userid=118889
View this thread: http://forums.novell.com/showthread.php?t=447505

dirkmueller
09-Nov-2011, 19:46
In that case I have good news. PHP 5.3 is added in SLES11.2 and we will
perhaps also introduce it for SLES11.1 shortly.


--
dirkmueller
------------------------------------------------------------------------
dirkmueller's Profile: http://forums.novell.com/member.php?userid=21451
View this thread: http://forums.novell.com/showthread.php?t=447505

thsundel
09-Nov-2011, 21:06
dirkmueller;2152529 Wrote:
> In that case I have good news. PHP 5.3 is added in SLES11.2 and we will
> perhaps also introduce it for SLES11.1 shortly.

That is really great news since also Moodle 2.x requires PHP 5.3.2 or
newer.

Thanks,

Thomas


--
http://thsundel.blogspot.com/
------------------------------------------------------------------------
thsundel's Profile: http://forums.novell.com/member.php?userid=128
View this thread: http://forums.novell.com/showthread.php?t=447505

TelaurusComm
21-Nov-2011, 16:17
dirkmueller;2152529 Wrote:
> In that case I have good news. PHP 5.3 is added in SLES11.2 and we will
> perhaps also introduce it for SLES11.1 shortly.

I'm having the very same issue, any clarification on "Shortly?"


--
TelaurusComm
------------------------------------------------------------------------
TelaurusComm's Profile: http://forums.novell.com/member.php?userid=119750
View this thread: http://forums.novell.com/showthread.php?t=447505

TelaurusComm
22-Nov-2011, 14:36
apparently not...

I recieved this today from Novell Support.

"The version of PHP that is currently in the beta testing of SLES11 SP2
is php5-5.2.14-0.7.24.1. I don't anticipate any upgrades to 5.3 there,
or in SLES11 SP1.

Hope this helps. I will close the SR unless you need further assistance
on this. Please advise.

Thanks

Thank you,
Dean Ormsby
--
Technical Support Engineer
Novell Technical Services"


--
TelaurusComm
------------------------------------------------------------------------
TelaurusComm's Profile: http://forums.novell.com/member.php?userid=119750
View this thread: http://forums.novell.com/showthread.php?t=447505

AlexDudko
22-Nov-2011, 20:46
Compilation would be the best way out (if using SLE). I've compiled it
myself but for testing purpose. If it is a production server you may
consider using some other Linux distribution with PHP-5.3 included by
default. CentOS or Scientific Linux will do from the rpm based ones.
Debian or Ubuntu are good from deb based distributions.


--
AlexDudko
------------------------------------------------------------------------
AlexDudko's Profile: http://forums.novell.com/member.php?userid=100476
View this thread: http://forums.novell.com/showthread.php?t=447505