PDA

View Full Version : dhcp option 85



dmiller
12-Mar-2014, 14:25
what are the steps to set/add option 85 in suse11 to the dhcp server.

jmozdzen
12-Mar-2014, 14:58
Hi dmiller,


what are the steps to set/add option 85 in suse11 to the dhcp server.

which SP are you on? From SLES11SP1 "man dhcp-options":

option nds-servers ip-address [, ip-address... ];

The nds-servers option specifies a list of IP addresses of NDS servers.


It's likely that your dhcpd will already understand the option name "nds-servers", which is option 85 (per RFC 2241).

Regards,
Jens

smflood
12-Mar-2014, 14:59
On 12/03/2014 13:34, dmiller wrote:

> what are the steps to set/add option 85 in suse11 to the dhcp server.

What do you mean by "suse11"? Posting in this forum suggests SUSE Linux
Enterprise Server (SLES) 11 but it could also mean SUSE Linux Enterprise
Desktop (SLED) 11, openSUSE 11.x, or even Novell Open Enterprise Server
(OES) 11.

Whilst all are likely to be using ISC DHCP how they're configured
depends on which "suse11" you're using, particularly if it's OES11.

Please can you post the output from "cat /etc/*release".

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

dmiller
12-Mar-2014, 15:49
This is what it shows
"
SUSE Linux Enterprise Server 11 (x86_64)
Version = 11
PATCHLEVEL = 1
"

Thanks

dmiller
12-Mar-2014, 15:56
I ours is sp1
though yast I don't see a main dhcp-options

this is what is in the dhcpd.conf file

#############################################
option domain-name "asdfasdf";
option domain-name-servers x.x.71.206, x.x.2.1;
option routers x.x.16.68.250;
option ntp-servers x.x.71.253;
option lpr-servers x.x.71.253;
ddns-update-style none;
default-lease-time 14400;
subnet 172.16.68.0 netmask 255.255.252.0 {
range x.x.69.1 x.x.70.253;
default-lease-time 14400;
max-lease-time 172800;
}
############################################

I tired adding
option dns-server x.x.x.x;
but that did not work.


Thanks

jmozdzen
12-Mar-2014, 15:59
Hi,


I tired adding
option dns-server x.x.x.x;
but that did not work.

If that was no typo when composing the forum message: It is "nds-server", not "dns-server"... "Novell Directory Services".

Regards,
Jens

dmiller
12-Mar-2014, 16:12
sorry, what I posted was a typo.

This is the config file that I run.
################################################## ####
option domain-name "asdf";
option domain-name-servers x.x.71.206, x.x.2.1;
option routers x.x.68.250;
option ntp-servers x.x.71.253;
option lpr-servers x.x.71.253;
option nds-server x.x.71.253;
ddns-update-style none;
default-lease-time 14400;
subnet x.x.68.0 netmask 255.255.252.0 {
range x.x.69.1 x.x.70.253;
default-lease-time 14400;
max-lease-time 172800;
}
################################################## #####

this is the error I get.

################################################## ######
/etc/dhcpd.conf line 6: unknown option dhcp.nds-server
option nds-server 172.
^
Configuration file errors encountered -- exiting
################################################## #######

smflood
12-Mar-2014, 16:22
On 12/03/2014 15:04, jmozdzen wrote:

> If that was no typo when composing the forum message: It is
> "nds-server", not "dns-server"... "Novell Directory Services".

Another typo, it's "nds-servers" (plural) as you wrote in your first
reply ...

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

jmozdzen
12-Mar-2014, 16:24
Hi,

> option nds-server x.x.71.253;

Typo on my end, too - see "man dhcp-options":

option nds-servers ip-address [, ip-address... ];

The nds-servers option specifies a list of IP addresses of NDS servers.





Regards,
Jens

smflood
12-Mar-2014, 16:24
On 12/03/2014 15:14, dmiller wrote:

> sorry, what I posted was a typo.
>
> This is the config file that I run.
> ################################################## ####

> option nds-server x.x.71.253

> ################################################## #####
>
> this is the error I get.
>
> ################################################## ######
> /etc/dhcpd.conf line 6: unknown option dhcp.nds-server
> option nds-server 172.
> ^
> Configuration file errors encountered -- exiting
> ################################################## #######

Try "option nds-servers x.x.71.253".

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

dmiller
12-Mar-2014, 17:21
Thanks for your help.
I was typing nds-server not nds-servers.

Not it works
I was about to go insane.

Thanks !!!!!