PDA

View Full Version : Something is wrong with the YaST user interface



aabdelkhalek
13-Mar-2014, 06:03
Hi,

I was trying to update my glibc to 2.14 and I guess I overlooked some errors and now I'm not able to start yast or yast2 from the terminal.

I can start it through the GUI but when I type yast I get

Something is wrong with the YaST user interface.

And when I type yast2 I get:

Qt GUI wanted but not found, falling back to ncurses.
Something is wrong with the YaST user interface.

Searching on google there were suggestions to install yast*qt* but I found them installed so I forced their reinstallation but no difference!

Moreover I did zypper verify and no dependencies were found.

Eventually I did zypper dup and restarted and still have the same problem.

The idea is that when I try to install an rpm I get a similar error:

Qt GUI wanted but not found, falling back to ncurses.
Something is wrong with the YaST user interface.

Any help will be appreciated

Thanks
Ahmed

mikewillis
13-Mar-2014, 14:02
I was trying to update my glibc to 2.14

If you Google for info on upgrading glibc the advice you find can be summarised as "Don't". If you mess with glibc version you're pretty much asking for breakage.

Why where you trying to update glibc?

What exactly did you do to try and update glibc?

Can you post the output of the following commands:

$ cat /etc/*release*
$ uname -a
$ rpm -qa | grep glibc
When posting output it will help greatly with readability if you wrap it in CODE tags (look for the # button in the toolbar when composing the post.)

aabdelkhalek
13-Mar-2014, 18:04
If you Google for info on upgrading glibc the advice you find can be summarised as "Don't". If you mess with glibc version you're pretty much asking for breakage.

Why where you trying to update glibc?

What exactly did you do to try and update glibc?

Can you post the output of the following commands:

$ cat /etc/*release*
$ uname -a
$ rpm -qa | grep glibc
When posting output it will help greatly with readability if you wrap it in CODE tags (look for the # button in the toolbar when composing the post.)

I was having problems playing some MKV files with VLC and the advice I got on VLC forum was to first upgrade to the latest version 2.1.3 and then one thing lead to the other and found that I need to upgrade to glibc 2.14 as a dependency for one of the VLC packages.

At first, I installed the package and then the normal steps: configure, make and make install and then I was trying to install some file with 1-click installs when I discovered the yast problem!

Later, I actually continued updated it to glibc 2.17 using the openSuSE repo

Here you're the output of those commands:


linux-ahmed:/home/aabdelkhalek # cat /etc/*release*
LSB_VERSION="core-2.0-noarch:core-3.2-noarch:core-4.0-noarch:core-2.0-x86_64:core-3.2-x86_64:core-4.0-x86_64"
cat: /etc/lsb-release.d: Is a directory
SUSE Linux Enterprise Desktop 11 (x86_64)
VERSION = 11
PATCHLEVEL = 3
SUSE Linux Enterprise Desktop 11 (x86_64)
VERSION = 11
PATCHLEVEL = 3
linux-ahmed:/home/aabdelkhalek # uname -a
Linux linux-ahmed 3.0.76-0.11-default #1 SMP Fri Jun 14 08:21:43 UTC 2013 (ccab990) x86_64 x86_64 x86_64 GNU/Linux
linux-ahmed:/home/aabdelkhalek # rpm -qa| grep glibc
glibc-locale-2.17-4.7.1
glibc-extra-2.17-4.7.1
glibc-32bit-2.11.3-17.54.1
glibc-2.17-4.7.1
glibc-devel-2.17-4.7.1
glibc-i18ndata-2.11.3-17.54.1
glibc-locale-32bit-2.11.3-17.54.1
linux-ahmed:/home/aabdelkhalek #


Thanks

mikewillis
13-Mar-2014, 18:50
Your SLED version is 11 SP3, which is good because that's the current version. However your kernel version is 3.0.76 which is what SLED 11 SP3 shipped with and there have been several kernel updates since then. Current version is 3.0.101. That you are using 3.0.76 indicates you're not installing updates.

I honestly have no solid advice to offer on how to undo what you've done with glibc. Someone else may be able to offer better advice. My best guess would be remove whatever openSUSE repo you've added then run

$ zypper in 2.11.3-17.54.1
This will, in theory at least, get zypper to install that specific version of glibc from the SLED 11 SP3 repo. Whether zypper will uninstall the glibc-2.17 packages you've installed at the same time I don't know.Maybe you'll have to remove those manually which you can probably do with

$ zypper rm glibc-locale-2.17-4.7.1 glibc-extra-2.17-4.7.1 glibc-2.17-4.7.1 glibc-devel-2.17-4.7.1

There is a newer version of glibc than 2.11.3-17.54.1 available in the SLED 11 SP3 Updates repo but I've specified 2.11.3-17.54.1 above because I suspect you do not have the SLED 11 SP3 Updates repo set up. If you did I would expect you to not be still running kernel 3.0.76. If you do have the Updates repo set up then install updates!

I stress that I don't know if the above will work, you may want to wait and see if someone else offers something better. What I've suggested may break your system more, but you've already messed with glibc so maybe that's a risk you're willing to take ;)

You started the thread about a problem with YaST and now I'm going on about glibc, but if you've messed with glibc then you really should expect to find things that don't work properly afterwards and there may well be bigger problems than just this issue you're seeing with YaST.

When you're done messing with glibc you may find this guide on adding additional codec support to SLED 11 SP3 useful
https://www.suse.com/communities/conversations/additional-multimedia-codec-support-for-sled-11-sp3/

aabdelkhalek
14-Mar-2014, 03:26
Your SLED version is 11 SP3, which is good because that's the current version. However your kernel version is 3.0.76 which is what SLED 11 SP3 shipped with and there have been several kernel updates since then. Current version is 3.0.101. That you are using 3.0.76 indicates you're not installing updates.

I honestly have no solid advice to offer on how to undo what you've done with glibc. Someone else may be able to offer better advice. My best guess would be remove whatever openSUSE repo you've added then run

$ zypper in 2.11.3-17.54.1
This will, in theory at least, get zypper to install that specific version of glibc from the SLED 11 SP3 repo. Whether zypper will uninstall the glibc-2.17 packages you've installed at the same time I don't know.Maybe you'll have to remove those manually which you can probably do with

$ zypper rm glibc-locale-2.17-4.7.1 glibc-extra-2.17-4.7.1 glibc-2.17-4.7.1 glibc-devel-2.17-4.7.1

There is a newer version of glibc than 2.11.3-17.54.1 available in the SLED 11 SP3 Updates repo but I've specified 2.11.3-17.54.1 above because I suspect you do not have the SLED 11 SP3 Updates repo set up. If you did I would expect you to not be still running kernel 3.0.76. If you do have the Updates repo set up then install updates!

I stress that I don't know if the above will work, you may want to wait and see if someone else offers something better. What I've suggested may break your system more, but you've already messed with glibc so maybe that's a risk you're willing to take ;)

You started the thread about a problem with YaST and now I'm going on about glibc, but if you've messed with glibc then you really should expect to find things that don't work properly afterwards and there may well be bigger problems than just this issue you're seeing with YaST.

When you're done messing with glibc you may find this guide on adding additional codec support to SLED 11 SP3 useful
https://www.suse.com/communities/conversations/additional-multimedia-codec-support-for-sled-11-sp3/

When I forced the install of the old package of glibc things got worse and now I'm not able to start my machine (I'm using another one to post)

during the boot I get so many errors about /lib64/libc.so.6: version 'GLIBC_2.14' not found (required by .....)

and it stops at INIT: Id "1" respawning too fast: disabled for 5 minutes

So I guess I will need to start all over again but is there a way to restore my data from the HDD?

Thanks

aabdelkhalek
14-Mar-2014, 06:37
When I forced the install of the old package of glibc things got worse and now I'm not able to start my machine (I'm using another one to post)

during the boot I get so many errors about /lib64/libc.so.6: version 'GLIBC_2.14' not found (required by .....)

and it stops at INIT: Id "1" respawning too fast: disabled for 5 minutes

So I guess I will need to start all over again but is there a way to restore my data from the HDD?

Thanks

Just to let you know; I used ultimate boot CD to retrieve my data and then restored factory system which set me back to SLED-11 SP2 so will take it from there

And by the way, this of course has solved my bluetooth problem

Thanks

mikewillis
14-Mar-2014, 11:18
Just to let you know; I used ultimate boot CD to retrieve my data and then restored factory system which set me back to SLED-11 SP2 so will take it from there

A clean install is really the best option in that situation.

For reference, the SLED installer defaults to 'Propose Separate Home Partition' which mean you can re-install the OS later and keep your home directory, you just have to make sure the installer doesn't format the /home partition. You should still have a backup of your home directory before you do that of course, just in case.

aabdelkhalek
14-Mar-2014, 16:17
A clean install is really the best option in that situation.

For reference, the SLED installer defaults to 'Propose Separate Home Partition' which mean you can re-install the OS later and keep your home directory, you just have to make sure the installer doesn't format the /home partition. You should still have a backup of your home directory before you do that of course, just in case.

Hi again,

I was trying to upgrade from SP2 to SP3 and in the step of updating using zypper it listed the below 3 problems (I believe the 2nd problem is related to Bluetooth) so what solution should I choose? should I choose to keep the old kernel?


Refreshing service 'nu_novell_com'.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
3 Problems:
Problem: ati-fglrxG02-HP-kmp-default-8.982_3.0.13_0.27-1.1.x86_64 requires kernel(default:vmlinux) = 78ddd7e8714ce712, but this requirement cannot be provided
Problem: rt3290-kmp-default-3.9.2_3.0.13_0.27-0.1.1.x86_64 requires kernel(default:net_bluetooth_bluetooth) = c955a4deca6c1563, but this requirement cannot be provided
Problem: nothing provides kernel(trace:kernel_softirq) = 7eb84c8543fc95bc needed by ati-fglrxG02-HP-kmp-trace-8.954_3.0.13_0.27-2.1.x86_64

Problem: ati-fglrxG02-HP-kmp-default-8.982_3.0.13_0.27-1.1.x86_64 requires kernel(default:vmlinux) = 78ddd7e8714ce712, but this requirement cannot be provided
deleted providers: kernel-default-base-3.0.101-0.7.17.1.x86_64
Solution 1: deinstallation of ati-fglrxG02-HP-kmp-default-8.982_3.0.13_0.27-1.1.x86_64
Solution 2: keep obsolete kernel-default-base-3.0.101-0.7.17.1.x86_64
Solution 3: break ati-fglrxG02-HP-kmp-default-8.982_3.0.13_0.27-1.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c): 2

Problem: rt3290-kmp-default-3.9.2_3.0.13_0.27-0.1.1.x86_64 requires kernel(default:net_bluetooth_bluetooth) = c955a4deca6c1563, but this requirement cannot be provided
deleted providers: kernel-default-3.0.101-0.7.17.1.x86_64
Solution 1: deinstallation of rt3290-kmp-default-3.9.2_3.0.13_0.27-0.1.1.x86_64
Solution 2: keep obsolete kernel-default-3.0.101-0.7.17.1.x86_64
Solution 3: break rt3290-kmp-default-3.9.2_3.0.13_0.27-0.1.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c): 2

Problem: nothing provides kernel(trace:kernel_softirq) = 7eb84c8543fc95bc needed by ati-fglrxG02-HP-kmp-trace-8.954_3.0.13_0.27-2.1.x86_64
Solution 1: deinstallation of kernel-default-extra-3.0.101-0.7.17.1.x86_64
Solution 2: deinstallation of x11-video-fglrxG02-HP-8.982-1.1.x86_64
Solution 3: keep obsolete kernel-default-extra-3.0.101-0.7.17.1.x86_64
Solution 4: keep obsolete kernel-default-extra-3.0.101-0.7.17.1.x86_64
Solution 5: break ati-fglrxG02-HP-kmp-trace-8.954_3.0.13_0.27-2.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/5/s/r/c] (c):


Thanks

mikewillis
17-Mar-2014, 13:28
Ah, it's one of those SLED installs with HP repos added. Your best bet is to contact HP support about the process for updating such installs from SP2 to SP3.