PDA

View Full Version : SLE10-SP4-Debuginfo-Updates broken repository?



Franz Sirl
29-Nov-2011, 18:20
Hi,

can anyone currently install the latest glibc-debuginfo package? Like so
for example:

rug in glibc-debuginfo-2.4-31.95.1

Running this against our SMT server produces:

ERROR: 'glibc-debuginfo-2.4-31.95.1' is not available.

But I can see the package is there on the SMT server, but somehow rug
cannot see it. Though one thing is strange about the repositories
repodata directory, it contains these strangely named files:

401dc19bda88c82c403423fb835844d64345f7e95f5b983588 8189c03834cc93-filelists.xml.gz
4372c8f207c64d1837e706043fa0a3d439af7673ff71e08485 5634d5e641e47e-primary.xml.gz
6bf9672d0862e8ef8b8ff05a2fd0208a922b1f5978e6589d87 944c88259cb670-other.xml.gz

In all the other mirrored repositories these files have simple names
without the hex prefix.

Anyone knows more?

Franz

Automatic Reply
03-Dec-2011, 23:03
Franz,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit http://support.novell.com and search the knowledgebase and/or check all
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.novell.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team
http://forums.novell.com/

Simon Flood
05-Dec-2011, 23:55
On 29/11/2011 17:20, Franz Sirl wrote:

> can anyone currently install the latest glibc-debuginfo package? Like so for example:
>
> rug in glibc-debuginfo-2.4-31.95.1
>
> Running this against our SMT server produces:
>
> ERROR: 'glibc-debuginfo-2.4-31.95.1' is not available.
>
> But I can see the package is there on the SMT server, but somehow rug
> cannot see it. Though one thing is strange about the repositories
> repodata directory, it contains these strangely named files:
>
> 401dc19bda88c82c403423fb835844d64345f7e95f5b983588 8189c03834cc93-filelists.xml.gz
> 4372c8f207c64d1837e706043fa0a3d439af7673ff71e08485 5634d5e641e47e-primary.xml.gz
> 6bf9672d0862e8ef8b8ff05a2fd0208a922b1f5978e6589d87 944c88259cb670-other.xml.gz
>
> In all the other mirrored repositories these files have simple names
> without the hex prefix.
>
> Anyone knows more?

I'm not currently using SMT but checking my test OES2 SP3 (on SLES10 SP4)
server I had to subscribe to SLE10-SP4-Debuginfo-Pool in addition to
SLE10-SP4-Debuginfo-Updates to try and install glibc-Debuginfo-2.4-31.95.1.
I say "try" because I then got a "Dependency resolution failed" error due
to version mismatches.

HTH.
--
Simon
Novell Knowledge Partner (NKP)

Franz Sirl
06-Dec-2011, 10:48
Am 2011-12-05 23:55, schrieb Simon Flood:
> On 29/11/2011 17:20, Franz Sirl wrote:
>
>> can anyone currently install the latest glibc-debuginfo package? Like so for example:
>>
>> rug in glibc-debuginfo-2.4-31.95.1
>>
>> Running this against our SMT server produces:
>>
>> ERROR: 'glibc-debuginfo-2.4-31.95.1' is not available.
>>
>> But I can see the package is there on the SMT server, but somehow rug
>> cannot see it. Though one thing is strange about the repositories
>> repodata directory, it contains these strangely named files:
>>
>> 401dc19bda88c82c403423fb835844d64345f7e95f5b983588 8189c03834cc93-filelists.xml.gz
>> 4372c8f207c64d1837e706043fa0a3d439af7673ff71e08485 5634d5e641e47e-primary.xml.gz
>> 6bf9672d0862e8ef8b8ff05a2fd0208a922b1f5978e6589d87 944c88259cb670-other.xml.gz
>>
>> In all the other mirrored repositories these files have simple names
>> without the hex prefix.
>>
>> Anyone knows more?
>
> I'm not currently using SMT but checking my test OES2 SP3 (on SLES10 SP4)
> server I had to subscribe to SLE10-SP4-Debuginfo-Pool in addition to
> SLE10-SP4-Debuginfo-Updates to try and install glibc-Debuginfo-2.4-31.95.1.
> I say "try" because I then got a "Dependency resolution failed" error due
> to version mismatches.

Same here. My guess is that the 3 files above are erroneously empty.
Like the filelists.xml:

--->
<?xml version="1.0" encoding="UTF-8"?>
<filelists xmlns="http://linux.duke.edu/metadata/filelists" packages="0">
</filelists>
---<

That doesn't look right to me. Since you see the same symptoms it's
probably not related to the SMT setup here. I'll file an SR.

Franz.

Franz Sirl
16-Dec-2011, 10:30
After filing a SR, this issue has been resolved as of yesterday.

Franz

Am 2011-12-06 10:48, schrieb Franz Sirl:
> Am 2011-12-05 23:55, schrieb Simon Flood:
>> On 29/11/2011 17:20, Franz Sirl wrote:
>>
>>> can anyone currently install the latest glibc-debuginfo package? Like
>>> so for example:
>>>
>>> rug in glibc-debuginfo-2.4-31.95.1
>>>
>>> Running this against our SMT server produces:
>>>
>>> ERROR: 'glibc-debuginfo-2.4-31.95.1' is not available.
>>>
>>> But I can see the package is there on the SMT server, but somehow rug
>>> cannot see it. Though one thing is strange about the repositories
>>> repodata directory, it contains these strangely named files:
>>>
>>> 401dc19bda88c82c403423fb835844d64345f7e95f5b983588 8189c03834cc93-filelists.xml.gz
>>>
>>> 4372c8f207c64d1837e706043fa0a3d439af7673ff71e08485 5634d5e641e47e-primary.xml.gz
>>>
>>> 6bf9672d0862e8ef8b8ff05a2fd0208a922b1f5978e6589d87 944c88259cb670-other.xml.gz
>>>
>>>
>>> In all the other mirrored repositories these files have simple names
>>> without the hex prefix.
>>>
>>> Anyone knows more?
>>
>> I'm not currently using SMT but checking my test OES2 SP3 (on SLES10 SP4)
>> server I had to subscribe to SLE10-SP4-Debuginfo-Pool in addition to
>> SLE10-SP4-Debuginfo-Updates to try and install
>> glibc-Debuginfo-2.4-31.95.1.
>> I say "try" because I then got a "Dependency resolution failed" error due
>> to version mismatches.
>
> Same here. My guess is that the 3 files above are erroneously empty.
> Like the filelists.xml:
>
> --->
> <?xml version="1.0" encoding="UTF-8"?>
> <filelists xmlns="http://linux.duke.edu/metadata/filelists" packages="0">
> </filelists>
> ---<
>
> That doesn't look right to me. Since you see the same symptoms it's
> probably not related to the SMT setup here. I'll file an SR.
>
> Franz.
>
>