PDA

View Full Version : Patching Conflicts



bhnguyen
27-Dec-2011, 17:26
Hi, we are getting patching conflict errors when updating our SLES 11
(64-bit) server:
"nothing provides libpciaccess0=7.4_0.11.0 needed by
libpciaccess0-devel-7.4_0.11.0-0.4.6.1.x86_64"
"nothing provides libmysqlclient15=5.0.94 needed by
libmysqlclient-devel-5.0.94-0.2.2.1.x86_64"
"nothing provides libldap-2_4-2=2.4.26 needed by
openldap2-devel-2.4.26-0.12.1.x86_64"

The options are: 1) deinstallation of existing packages that conflict
with the patches; 2) do not install these patches; and 3) break open the
patches by ignoring some of its dependencies.

Since these are security patches that we need to apply to keep our
server up to date, we cannot choose option 2. Also, the current
packages are required for the server to function. If we choose option 1
(deinstall the conflicting packages), can we re-install the packages
that we deinstalled, after applying the patches? Also, what does option
3 mean, and what are the consequences of choosing it? Thanks in advance
for help that anyone can provide.


--
bhnguyen
------------------------------------------------------------------------
bhnguyen's Profile: http://forums.novell.com/member.php?userid=90807
View this thread: http://forums.novell.com/showthread.php?t=450038

malcolmlewis
27-Dec-2011, 17:48
On Tue, 27 Dec 2011 16:26:02 GMT
bhnguyen <bhnguyen@no-mx.forums.novell.com> wrote:

>
> Hi, we are getting patching conflict errors when updating our SLES 11
> (64-bit) server:
> "nothing provides libpciaccess0=7.4_0.11.0 needed by
> libpciaccess0-devel-7.4_0.11.0-0.4.6.1.x86_64"
> "nothing provides libmysqlclient15=5.0.94 needed by
> libmysqlclient-devel-5.0.94-0.2.2.1.x86_64"
> "nothing provides libldap-2_4-2=2.4.26 needed by
> openldap2-devel-2.4.26-0.12.1.x86_64"
>
> The options are: 1) deinstallation of existing packages that conflict
> with the patches; 2) do not install these patches; and 3) break open
> the patches by ignoring some of its dependencies.
>
> Since these are security patches that we need to apply to keep our
> server up to date, we cannot choose option 2. Also, the current
> packages are required for the server to function. If we choose
> option 1 (deinstall the conflicting packages), can we re-install the
> packages that we deinstalled, after applying the patches? Also, what
> does option 3 mean, and what are the consequences of choosing it?
> Thanks in advance for help that anyone can provide.
>

Hi
What repositories are active on the system?


zypper lr -d

Normally the development files come from the SLE SDK pool and update
repository, so are they active?

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.0-1.2-desktop
up 16:20, 3 users, load average: 0.00, 0.02, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

bhnguyen
28-Dec-2011, 17:46
Yes, both the pool and update are active, as shown by the command:

EPI-Nagios:~ # zypper lr -d
# | Alias | Name
| Enabled | Refresh |
Priority | Type | URI

| Service
---+-----------------------------------------------------------+-----------------------------------------------------------+---------+---------+----------+--------+------------------------------------------------------------------------------------------------------------------------------------------+--------------
1 | SLES-11-SP1-SDK | SUSE
Linux Enterprise Software Development Kit 11 SP1 | Yes | No
| 99 | yast2 |
iso:///?iso=SLES-11-SP1-SDK-DVD-x86_64-GM-DVD1.iso&url=nfs://medgwback.medicine.umaryland.edu/mnt/gwback/iso/sles11sp1_64/
|
2 | SUSE-Linux-Enterprise-Server-11-SP1-for-VMware 11.1.1-1.4 |
SUSE-Linux-Enterprise-Server-11-SP1-for-VMware 11.1.1-1.4 | No | No
| 99 | yast2 | cd:///?devices=/dev/sr0

|
3 | nu_novell_com:SLE11-SDK-SP1-Pool |
SLE11-SDK-SP1-Pool | Yes |
Yes | 99 | rpm-md |
https://nu.novell.com/repo/$RCE/SLE11-SDK-SP1-Pool/sle-11-x86_64?credentials=NCCcredentials
| nu_novell_com
4 | nu_novell_com:SLE11-SDK-SP1-Updates |
SLE11-SDK-SP1-Updates | Yes |
Yes | 99 | rpm-md |
https://nu.novell.com/repo/$RCE/SLE11-SDK-SP1-Updates/sle-11-x86_64?credentials=NCCcredentials
| nu_novell_com
5 | nu_novell_com:SLE11-SP1-Debuginfo-Pool |
SLE11-SP1-Debuginfo-Pool | Yes |
Yes | 99 | rpm-md |
https://nu.novell.com/repo/$RCE/SLE11-SP1-Debuginfo-Pool/sle-11-x86_64?credentials=NCCcredentials
| nu_novell_com
6 | nu_novell_com:SLE11-SP1-Debuginfo-Updates |
SLE11-SP1-Debuginfo-Updates | Yes |
Yes | 99 | rpm-md |
https://nu.novell.com/repo/$RCE/SLE11-SP1-Debuginfo-Updates/sle-11-x86_64?credentials=NCCcredentials
| nu_novell_com
7 | nu_novell_com:SLES11-Extras |
SLES11-Extras | Yes |
Yes | 99 | rpm-md |
https://nu.novell.com/repo/$RCE/SLES11-Extras/sle-11-x86_64?credentials=NCCcredentials
| nu_novell_com
8 | nu_novell_com:SLES11-SP1-VMware-Pool |
SLES11-SP1-VMware-Pool | Yes |
Yes | 99 | rpm-md |
https://nu.novell.com/repo/$RCE/SLES11-SP1-VMware-Pool/sle-11-x86_64?credentials=NCCcredentials
| nu_novell_com
9 | nu_novell_com:SLES11-SP1-VMware-Updates |
SLES11-SP1-VMware-Updates | Yes |
Yes | 99 | rpm-md |
https://nu.novell.com/repo/$RCE/SLES11-SP1-VMware-Updates/sle-11-x86_64?credentials=NCCcredentials
| nu_novell_com
10 | sles-11-sp1-vmware |
sles-11-sp1-vmware | Yes | No
| 99 | yast2 |
iso:///?iso=SLES-11-SP1-for-VMware-DVD-x86_64-GM-DVD1.iso&url=nfs://medgwback.medicine.umaryland.edu/mnt/gwback/iso/sles11sp1_64_vmware/
|

We have another nagios server that is very similar to this one, and it
got the same dependency conflicts.


--
bhnguyen
------------------------------------------------------------------------
bhnguyen's Profile: http://forums.novell.com/member.php?userid=90807
View this thread: http://forums.novell.com/showthread.php?t=450038

malcolmlewis
29-Dec-2011, 01:33
On Wed, 28 Dec 2011 16:46:02 GMT
bhnguyen <bhnguyen@no-mx.forums.novell.com> wrote:

>
> Yes, both the pool and update are active, as shown by the command:

Hi
OK, can you check which repository the files are installed from that
are conflicting;


zypper if libpciaccess
zypper if libmysqlclient15


--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.0-1.2-desktop
up 4:35, 3 users, load average: 0.01, 0.03, 0.11
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

dirkmueller
29-Dec-2011, 15:46
This repo list looks good. The packages you're missing should be
provided by SLES11-SP1-VMware-Updates, so my guess is that this
repository is not properly synced.

can you try "sudo zypper ref -f" ?


--
dirkmueller
------------------------------------------------------------------------
dirkmueller's Profile: http://forums.novell.com/member.php?userid=21451
View this thread: http://forums.novell.com/showthread.php?t=450038

bhnguyen
30-Dec-2011, 16:46
Thanks for the response. Below are the results from the repository
commands:

med-nagios:~ # zypper if libpciaccess
Refreshing service 'nu_novell_com'.
Loading repository data...
Reading installed packages...


package 'libpciaccess' not found.


med-nagios:~ # zypper if libmysqlclient15
Refreshing service 'nu_novell_com'.
Loading repository data...
Reading installed packages...


Information for package libmysqlclient15:

Repository: SLES11-SP1-VMware-Updates
Name: libmysqlclient15
Version: 5.0.94-0.2.2.1
Arch: x86_64
Vendor: SUSE LINUX Products GmbH, Nuernberg, Germany
Support Level: Additional Customer Contract Necessary
Installed: Yes
Status: out-of-date (version 5.0.67-13.26.1 installed)
Installed Size: 1.4 MiB
Summary: MySQL Shared Libraries
Description:
This package contains the shared libraries (.so) which certain
languages and applications need to dynamically load and use MySQL.

Thanks,
Bao Nguyen
Desktop Engineer
Department of Medicine
410-706-2577
'Department of Medicine Information Systems'
(http://www.medicine.umaryland.edu/is)


--
bhnguyen
------------------------------------------------------------------------
bhnguyen's Profile: http://forums.novell.com/member.php?userid=90807
View this thread: http://forums.novell.com/showthread.php?t=450038

bhnguyen
30-Dec-2011, 17:06
Thanks for the reply. I tried your command (see below) and then checked
updates, but I got the same conflicts which I also listed below:

med-nagios:~ # sudo zypper ref -f
Forcing raw metadata refresh
Retrieving repository 'SLES11-SP1-VMware-Pool' metadata [done]
Forcing building of repository cache
Building repository 'SLES11-SP1-VMware-Pool' cache [done]
Forcing raw metadata refresh
Retrieving repository 'SLES11-SP1-VMware-Updates' metadata [done]
Forcing building of repository cache
Building repository 'SLES11-SP1-VMware-Updates' cache [done]
Forcing raw metadata refresh
Retrieving repository 'sles-11-sp1-vmware' metadata [done]
Forcing building of repository cache
Building repository 'sles-11-sp1-vmware' cache [done]
All repositories have been refreshed.


#### YaST2 conflicts list - generated 2011-12-30 10:54:35 ####

libmysqlclient-devel-5.0.67-13.20.1.x86_64 requires libmysqlclient_r15
= 5.0.67, but this requirement cannot be provided
uninstallable providers:
libmysqlclient_r15-5.0.67-13.20.1.x86_64[nu_novell_com:SLES11-SP1-VMware-Pool]

libmysqlclient_r15-5.0.67-13.20.1.x86_64[sles-11-sp1-vmware]
[ ] break libmysqlclient-devel by ignoring some of its
dependencies

[ ] deinstallation of libmysqlclient-devel-5.0.67-13.20.1.x86_64

[ ] do not install patch:slessp1-libmysqlclient-devel-5285.noarch



openldap2-devel-32bit-2.4.20-0.4.29.x86_64 requires libldap-2_4-2-32bit
= 2.4.20, but this requirement cannot be provided
uninstallable providers:
libldap-2_4-2-32bit-2.4.20-0.4.29.x86_64[nu_novell_com:SLES11-SP1-VMware-Pool]

libldap-2_4-2-32bit-2.4.20-0.5.1.x86_64[nu_novell_com:SLES11-SP1-VMware-Updates]

libldap-2_4-2-32bit-2.4.20-0.4.29.x86_64[sles-11-sp1-vmware]
[ ] Following actions will be done:
deinstallation of openldap2-devel-32bit-2.4.20-0.4.29.x86_64
deinstallation of openldap2-devel-2.4.20-0.4.29.x86_64
[x] do not install patch:slessp1-openldap2-2426-5387.noarch

[ ] break openldap2-devel-32bit by ignoring some of its
dependencies

#### YaST2 conflicts list END ###


Bao Nguyen
Desktop Engineer
Department of Medicine
410-706-2577
'Department of Medicine Information Systems'
(http://www.medicine.umaryland.edu/is)


--
bhnguyen
------------------------------------------------------------------------
bhnguyen's Profile: http://forums.novell.com/member.php?userid=90807
View this thread: http://forums.novell.com/showthread.php?t=450038