PDA

View Full Version : Error in xorg-x11-server update



eloycastro
16-Jan-2012, 14:56
I get an error updating xorg-x11-server to the latest version
(7.4-27.40.56.1). If the required version of libpciaccess0 should be >=
7.4.0_0.11.0 then it should work with version 7.4-8.26.3.1 installed...
Anyone with the same problem? Could it be a problem with the name of
the package (See hyphen and underscore in the package name)? Or is 7.4.0
not the same as 7.4?


# rpm -qa |grep xorg-x11-server
xorg-x11-server-7.4-27.19.19


# rpm -qa |grep libpciaccess0
libpciaccess0-7.4-8.26.3.1


# rug bin -r -y SLES11-SP1-UPDATES-BUNDLE-RELEASED-20120113
The following bundles will be installed:
SLES11-SP1-UPDATES-BUNDLE-RELEASED-20120113 (version 2)

ERROR: RPM_NOTHING_PROVIDES_DEP: 'libpciaccess0 >= 7.4.0_0.11.0' needed
by xorg-x11-server-7.4-27.40.56.1.x86_64


# rug se xorg-x11-server
S | Catalog | Bundle
| Name | Version | Arch
--+---------------------------------+------------------------------------------------+-----------------------+----------------+-------
v | SLES11_SP1-UPDATES-PROD-CATALOG |
SLES11-SP1-UPDATES-BUNDLE-RELEASED-20120113 | xorg-x11-server |
7.4-27.40.56.1 | x86_64
i | SLES11-SP1-POOL | SLES11-SP1-Pool-bundle
| xorg-x11-server | 7.4-27.19.19 | x86_64


# rug se libpciaccess0
S | Catalog | Bundle
| Name | Version | Arch
--+---------------------------------+------------------------------------------------+---------------------+--------------+-------
i | SLES11_SP1-UPDATES-PROD-CATALOG |
SLES11-SP1-UPDATES-BUNDLE-RELEASED-20120113 | libpciaccess0 |
7.4-8.26.3.1 | x86_64
s | SLES11-SP1-POOL | SLES11-SP1-Pool-bundle
| libpciaccess0 | 7.4-8.24.2 | x86_64


--
eloycastro
------------------------------------------------------------------------
eloycastro's Profile: http://forums.novell.com/member.php?userid=87076
View this thread: http://forums.novell.com/showthread.php?t=450790

Automatic Reply
20-Jan-2012, 21:07
eloycastro,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit http://support.novell.com and search the knowledgebase and/or check all
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.novell.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team
http://forums.novell.com/

dirkmueller
23-Jan-2012, 13:36
eloycastro;2168074 Wrote:
> I get an error updating xorg-x11-server to the latest version
> (7.4-27.40.56.1). If the required version of libpciaccess0 should be >=
> 7.4.0_0.11.0 then it should work with version 7.4-8.26.3.1 installed...

No, _7.4-8.26.3.1__ is lower than _7.4.0_0.11.0_.

However, there was a release of libpciaccess0 _7.4_0.11.0-0.4.6.1_,
which should satisfy the dependency you see. Where did you get this
bundle from? it seems to be missing that package.


--
dirkmueller
------------------------------------------------------------------------
dirkmueller's Profile: http://forums.novell.com/member.php?userid=21451
View this thread: http://forums.novell.com/showthread.php?t=450790

eloycastro
30-Jan-2012, 14:46
Hi, thanks for your answer. I've downloaded the 7.4_0.11.0-0.4.6.1
version and installed it manually. Now the update of xorg-x11-server
works.
We're mirroring the SLES11 SP1 updates with ZLM directly from Novell...
and this update is missing. Perhaps our ZLM-Server or our mirroring
script has a problem, i'm going to check that.

Thank you and best regards from Switzerland.


--
eloycastro
------------------------------------------------------------------------
eloycastro's Profile: http://forums.novell.com/member.php?userid=87076
View this thread: http://forums.novell.com/showthread.php?t=450790