PDA

View Full Version : Unable to Create/Use Power Management Profiles



david20100
23-Apr-2014, 21:14
Hi Everybody,

I try to follow those steps https://www.suse.com/documentation/s...er.pm-profiler (11.5) and got some errors.

1-Create a directory in /etc/pm-profiler/ (called Performance)
2-create the configuration file for the new profile, copy the profile template to the newly created directory: cp /usr/share/doc/packages/pm-profiler/config.template \
/etc/pm-profiler/Performance/was called config.template but renamed to Performance
3-Edit the settings in /etc/pm-profiler/testprofile/config
So i modify some lines: (in bold)
# The profile name
#
NAME="Performance"

# Short description of the profile, what characteristics it has, etc...
#
DESCRIPTION="Pass from ondemand to Performance"

# Set the cpu frequency scaling governor
# Possible values are powersave, performance, ondemand and userspace
#
# Kernel documenatation: cpu-freq/user-guide.txt
#
# File: /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor
#
CPUFREQ_GOVERNOR="performance"

4- Edit /etc/pm-profiler.conf. The PM_PROFILER_PROFILE variable defines which profile will be activated on system start. If it has no value, the
default system or kernel settings will be used. To set the newly created profile: PM_PROFILER_PROFILE="Performance"
5-To activate the profile, run rcpm-profiler start
and it gives me : rcpm-profiler start
Activating power management profile Performancepm-profiler: the requested profile performance does not exist

thanks for the help

jmozdzen
24-Apr-2014, 12:33
Hi david20100,

unfortunately, you seem to have copied a shortened version of the link, so clicking it takes us to a 404 page ;)

Could you additionally please tell us which version of SLES you're using (you might want to paste the output of "cat /etc/SuSE-release" inside a [ CODE ]...[ / CODE ] (without the blanks) block)?

Oh, and I'm not sure it's a copy&paste problem or not, but in step 2 you're talking about a directory /etc/pm-profiler/Performance/, while in step 3 you're editing a file from /etc/pm-profiler/testprofile/. And shouldn't the target file in step 2 be named "/etc/pm-profiler/Performance/config"? You description imples you named it "/etc/pm-profiler/Performance/Performance"...

Regards,
Jens

david20100
24-Apr-2014, 13:23
Thanks for the answer
Here's the link http://doc.opensuse.org/products/draft/SLES/SLES-tuning_sd_draft/cha.tuning.power.html#sec.tuning.power.pm-profiler

Version: SUSE Linux Enterprise Server 11 (x86_64)
VERSION = 11
PATCHLEVEL = 2

And yes was a missed correction of the procedure vs my config
Step 3: Edit the settings in /etc/pm-profiler/testprofile/config should have been: /etc/pm-profiler/Performance/Performance

thanks

jmozdzen
24-Apr-2014, 13:36
Hi david20100,

Step 3: Edit the settings in /etc/pm-profiler/testprofile/config should have been: /etc/pm-profiler/Performance/Performance

I believe it has to be "/etc/pm-profiler/Performance/config".

Maybe that's the cause of your error message?

Regards,
Jens

david20100
24-Apr-2014, 13:56
I rename the file called performance to config and it works perfectly - thanks for the helps

david20100
24-Apr-2014, 14:34
Finally works = no more error, but profile is not activated after a reboot

jmozdzen
24-Apr-2014, 14:57
Hi david20100,


Finally works = no more error, but profile is not activated after a reboot

does "chkconfig pm-profiler" report "off"? Then you need to enable the service, i.e. via "insserv pm-profiler".

Does the file "/usr/lib/pm-profiler/enable-profile" exist? If not, the init script will abort.

What does "rcpm-profiler status" report? Can you start the service manually, via "rcpm-profiler start"?

Regards,
Jens

jmozdzen
24-Apr-2014, 15:01
> What does "rcpm-profiler status" report? Can you start the service manually, via "rcpm-profiler start"?

As you wrote that you don't see errors now, I'll assume that this was in response to manually starting the service via rcpm_profile - so I take back that question :)

Regards,
Jens

david20100
24-Apr-2014, 15:14
Before you replied i installed the yast2 power-management, activate the profile - reboot and cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor = performance for all cpus
chkconfig pm-profiler = on
/usr/lib/pm-profiler/enable-profile exists
and rcpm-profiler status is running

thanks again for your helps