PDA

View Full Version : Compiling a Varnish-Cache vmod - missing rst2man



cisaksen
05-May-2014, 17:05
I'm running varnish-cache 3.0.5 (compiled from source) and I'm trying to install/compile a vmod for it but I keeps giving me an error on the make.=> "You need rst2man installed to make dist"

From other posts I've read, I believe it is part of a package from python, python-docutil or something like this. Does anyone know if SUSE has a similar package ? I can't seem to find one or better yet can someone point me in the direction of where I can find rst2man.py ?

Thanks

malcolmlewis
05-May-2014, 17:19
Hi
You need python-docutils, grab the version from the devel:lanuages:python repository;
http://software.opensuse.org/package/python-docutils?search_term=python-docutils
You need to expand the 'show unstable pakages' link to see what it's built for.

Else you should be able to add a configure option not to create the man pages if they are not needed (./configure --help)?

cisaksen
05-May-2014, 18:03
Thanks - I was able to compile it with this package.