PDA

View Full Version : YaST display not correct



x0500hl
06-May-2014, 19:13
I am running 30+ servers at SLES 11 SP3 on System z. On most of the servers the lines that make up the boxes are now letters.


lqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqq qqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqq qqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqq qqqqqqqqqqqqk
x YaST2 Control Center x
mqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqq qqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqq qqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqq qqqqqqqqqqqqj


One of my servers displays the lines correctly.


┌───────────────────────────────────────────────── ────────────────────────────────────────────────── ────────────────────────────────────────────────── ────────────┐
│ YaST2 Control Center │
└───────────────────────────────────────────────── ────────────────────────────────────────────────── ────────────────────────────────────────────────── ────────────┘


If I ssh from this server to the server that displays the lines incorrectly and launch yast, yast displays the lines properly.

I found a thread that addressed a similar issue from Feb 2013 but it didn't have a resolution, it said to open an SR. I have issued "locale" on each of these servers and the display is the same.

How can I correct this? The problem makes the display hard to read with all of the extra alphabetic characters (as opposed to the line drawings).


Harley

jmozdzen
07-May-2014, 12:45
Hi Harley,

this might be a codepage issue on the client - interpreting the server's response (the individual characters) wrongly.

What client are you using to display the output?

Regards,
Jens

x0500hl
07-May-2014, 13:36
Hi Jens,

I'm using PuTTY.


Harley

jmozdzen
07-May-2014, 14:48
Hi Harley,

Hi Jens,

I'm using PuTTY.


Harley

and how are your code page settings, do they match?

Regards,
Jens

x0500hl
07-May-2014, 15:09
Jens,

Problem solved! The codepage for PuTTY sessions with the problem were set to UTF8. The session for the server that didn't have the problem was set to "ISO-8859-1:1998 (Latin-1, West Europe)". I chaneg the setting from UTF8 and YaST is now displaying properly.

Thank you!


Harley

jmozdzen
07-May-2014, 15:17
Hi Harley,


Jens,

Problem solved! The codepage for PuTTY sessions with the problem were set to UTF8. The session for the server that didn't have the problem was set to "ISO-8859-1:1998 (Latin-1, West Europe)". I chaneg the setting from UTF8 and YaST is now displaying properly.

Thank you!


Harley

...and I thank you for reporting back, this will for sure help others that run into the same situation!

Regards,
Jens