PDA

View Full Version : How to enable/disable Bluetooth?



cromarko
27-May-2014, 17:05
How do I enable and disable Bluetooth in Suse Enterprise Linux SP3?

mikewillis
27-May-2014, 17:45
How do I enable and disable Bluetooth in Suse Enterprise Linux SP3?

Are you asking because your machine has Bluetooth and it's not working, or because you have Bluetooth working but sometimes want to turn it off?

cromarko
27-May-2014, 18:03
Are you asking because your machine has Bluetooth and it's not working, or because you have Bluetooth working but sometimes want to turn it off?

The Bluetooth icon is sometimes showing and sometimes it's not. I just want to know how to turn it off, I don't see an option in the panel bar. I also want to know how to remove the icon. It seems there isn't an option to show up Bluetooth icon in the panel bar settings.

mikewillis
28-May-2014, 13:06
Assuming you're using GNOME (another post asked about installing KDE), if you click the Bluetooth icon there should be a Preferences option that opens a dialogue that includes an option 'Show bluetooth icon'. If you untick that option and close the window, you can get the preferences back again by running


$ bluetooth-properties

As for turning Bluetooth off, honestly not sure about that. My Bluetooth comes by way of a dongle plugged in to a USB port and I've never thought about turning it off. Now that I do I can't just see a way to do so. According to https://help.gnome.org/users/gnome-bluetooth/stable/gnome-bluetooth-applet.html.en there should be an option to turn off Bluetooth in the menu that appears when you click the icon, but I don't have that and presumably you don't either. That documentation unhelpfully doesn't make any reference to which version(s) of GNOME is applies to but from the screenshots it's evidently not GNOME 3 so I assume it's some version of GNOME 2. (SLED 11 SP3 has GNOME 2.28.)

I assume your Bluetooth is built in rather than via dongle plugged in to a USB port? Is there a keyboard hot key to enable/disable Bluetooth? It so it may be possible to get that to work. There's references in SLED 11 SP3 to such things (/usr/share/hal/fdi/information/10freedesktop/10-thinkpad-rfkill-switch-bluetooth.fdi /usr/share/hal/fdi/information/10freedesktop/10-dell-rfkill-switch-bluetooth.fdi)

cromarko
28-May-2014, 20:03
Assuming you're using GNOME (another post asked about installing KDE), if you click the Bluetooth icon there should be a Preferences option that opens a dialogue that includes an option 'Show bluetooth icon'. If you untick that option and close the window, you can get the preferences back again by running


$ bluetooth-properties

As for turning Bluetooth off, honestly not sure about that. My Bluetooth comes by way of a dongle plugged in to a USB port and I've never thought about turning it off. Now that I do I can't just see a way to do so. According to https://help.gnome.org/users/gnome-bluetooth/stable/gnome-bluetooth-applet.html.en there should be an option to turn off Bluetooth in the menu that appears when you click the icon, but I don't have that and presumably you don't either. That documentation unhelpfully doesn't make any reference to which version(s) of GNOME is applies to but from the screenshots it's evidently not GNOME 3 so I assume it's some version of GNOME 2. (SLED 11 SP3 has GNOME 2.28.)

I assume your Bluetooth is built in rather than via dongle plugged in to a USB port? Is there a keyboard hot key to enable/disable Bluetooth? It so it may be possible to get that to work. There's references in SLED 11 SP3 to such things (/usr/share/hal/fdi/information/10freedesktop/10-thinkpad-rfkill-switch-bluetooth.fdi /usr/share/hal/fdi/information/10freedesktop/10-dell-rfkill-switch-bluetooth.fdi)

Why does it randomly show Bluetooth icon sometimes? My computer came with Bluetooth by the way.

mikewillis
30-May-2014, 12:51
Why does it randomly show Bluetooth icon sometimes? My computer came with Bluetooth by the way.

I've no idea. My Bluetooth icon is always there. If you Bluetooth is built in, I'd guess maybe the device is being turned off for power saving, but this is entirely a guess. Is the Bluetooth device attached to the USB bus, or PCI?


$ /usr/bin/lsusb
$ /sbin/lspci -nnk

cromarko
04-Jun-2014, 18:49
I've no idea. My Bluetooth icon is always there. If you Bluetooth is built in, I'd guess maybe the device is being turned off for power saving, but this is entirely a guess. Is the Bluetooth device attached to the USB bus, or PCI?


$ /usr/bin/lsusb
$ /sbin/lspci -nnk

Thanks for your help, it seems Suse Enterprise Linux Desktop isn't for me. I found the problem with multimedia codecs also, I had to download a file that was around 3 GB big. I will switch to another operating system.

Thanks,

mikewillis
04-Jun-2014, 19:06
Thanks for your help, it seems Suse Enterprise Linux Desktop isn't for me.
Well it's not for everyone. The name is a clue as to its target market ;). Perhaps you'd do better with openSUSE?


I found the problem with multimedia codecs also, I had to download a file that was around 3 GB big.

That would be the iso for the SLE SDK, which the README states is required.