PDA

View Full Version : SLES 11 - linux32 confilicts with util-linux-2.19.1-6.48.12.



pwollenburg
30-Jun-2014, 17:48
I am performing an Oracle R12.2 Installation SLES 11 SP3 for VMWARE.
Oracle R12.2 requires linux32 to be installed but it confilicts with util-linux-2.19.1-6.48.12.x86_64

In the (Oracle Doc ID 1330701.1) the package linux32-1.0-475.14.x86_64.rpm must be installed.
When I try to install the package I find a conflict.
Is it okay to ignore the linux32 rpm? Does the util-linux package perform the same function as the linux32 rpm?

I tried to uninstall the util-linux packae but there are many dependicies.

Platinium2:/pwoll/Patches # rpm -ivh linux32-1.0-475.14.x86_64.rpm

Preparing... ########################################### [100%]

file /usr/bin/linux32 from install of linux32-1.0-475.14.x86_64 conflicts with file from package util-linux-2.19.1-6.48.12.x86_64
There are many dependencies associated with the util-linux rpm.
~/Desktop # rpm -e util-linux-2.19.1-6.48.12.x86_64 error: Failed dependencies:
util-linux(fake+no-canonicalize) is needed by (installed) fuse-2.8.7-0.9.12.x86_64
util-linux = 2.19.1 is needed by (installed) util-linux-lang-2.19.1-6.48.12.x86_64
util-linux is needed by (installed) pam_mount-0.47-13.16.1.x86_64
util-linux is needed by (installed) grub-0.97-162.168.25.x86_64
util-linux is needed by (installed) cups-1.3.9-8.46.46.1.x86_64
util-linux is needed by (installed) cryptsetup-1.0.5_SVNr46-58.37.3.x86_64
util-linux is needed by (installed) cryptconfig-0.3-68.8.17.x86_64
util-linux is needed by (installed) subscription-tools-1.0-0.21.1.noarch
util-linux is needed by (installed) mkinitrd-2.4.2-0.80.1.x86_64
util-linux is needed by (installed) suseRegister-1.4-1.29.12.noarch
util-linux >= 2.16 is needed by (installed) yast2-storage-2.17.142-0.7.1.x86_64
util-linux is needed by (installed) yast2-backup-2.17.14-0.5.1.noarch
/bin/logger is needed by (installed) lsb-4.0-2.4.21.x86_64
/bin/more is needed by (installed) lsb-4.0-2.4.21.x86_64
/bin/mount is needed by (installed) lsb-4.0-2.4.21.x86_64
/bin/umount is needed by (installed) lsb-4.0-2.4.21.x86_64
/usr/bin/col is needed by (installed) lsb-4.0-2.4.21.x86_64
/usr/bin/ipcrm is needed by (installed) lsb-4.0-2.4.21.x86_64
/usr/bin/ipcs is needed by (installed) lsb-4.0-2.4.21.x86_64
/usr/bin/renice is needed by (installed) lsb-4.0-2.4.21.x86_64
/usr/bin/time is needed by (installed) lsb-4.0-2.4.21.x86_64
/usr/bin/uuidgen is needed by (installed) libzypp-9.34.0-0.7.15.x86_64

Paul

malcolmlewis
30-Jun-2014, 18:23
On Mon 30 Jun 2014 04:54:01 PM CDT, pwollenburg wrote:


I am performing an Oracle R12.2 Installation SLES 11 SP3 for VMWARE.
Oracle R12.2 requires linux32 to be installed but it confilicts with
util-linux-2.19.1-6.48.12.x86_64

In the (Oracle Doc ID 1330701.1) the package
linux32-1.0-475.14.x86_64.rpm must be installed.
When I try to install the package I find a conflict.
Is it okay to ignore the linux32 rpm? Does the util-linux package
perform the same function as the linux32 rpm?

I tried to uninstall the util-linux packae but there are many
dependicies.

Platinium2:/pwoll/Patches # rpm -ivh linux32-1.0-475.14.x86_64.rpm

Preparing... ###########################################
[100%]

file /usr/bin/linux32 from install of linux32-1.0-475.14.x86_64
conflicts with file from package util-linux-2.19.1-6.48.12.x86_64
There are many dependencies associated with the util-linux rpm.
~/Desktop # rpm -e util-linux-2.19.1-6.48.12.x86_64 error: Failed
dependencies:
util-linux(fake+no-canonicalize) is needed by (installed)
fuse-2.8.7-0.9.12.x86_64
util-linux = 2.19.1 is needed by (installed)
util-linux-lang-2.19.1-6.48.12.x86_64
util-linux is needed by (installed) pam_mount-0.47-13.16.1.x86_64
util-linux is needed by (installed) grub-0.97-162.168.25.x86_64
util-linux is needed by (installed) cups-1.3.9-8.46.46.1.x86_64
util-linux is needed by (installed)
cryptsetup-1.0.5_SVNr46-58.37.3.x86_64
util-linux is needed by (installed) cryptconfig-0.3-68.8.17.x86_64
util-linux is needed by (installed)
subscription-tools-1.0-0.21.1.noarch
util-linux is needed by (installed) mkinitrd-2.4.2-0.80.1.x86_64
util-linux is needed by (installed) suseRegister-1.4-1.29.12.noarch
util-linux >= 2.16 is needed by (installed)
yast2-storage-2.17.142-0.7.1.x86_64
util-linux is needed by (installed) yast2-backup-2.17.14-0.5.1.noarch
/bin/logger is needed by (installed) lsb-4.0-2.4.21.x86_64
/bin/more is needed by (installed) lsb-4.0-2.4.21.x86_64
/bin/mount is needed by (installed) lsb-4.0-2.4.21.x86_64
/bin/umount is needed by (installed) lsb-4.0-2.4.21.x86_64
/usr/bin/col is needed by (installed) lsb-4.0-2.4.21.x86_64
/usr/bin/ipcrm is needed by (installed) lsb-4.0-2.4.21.x86_64
/usr/bin/ipcs is needed by (installed) lsb-4.0-2.4.21.x86_64
/usr/bin/renice is needed by (installed) lsb-4.0-2.4.21.x86_64
/usr/bin/time is needed by (installed) lsb-4.0-2.4.21.x86_64
/usr/bin/uuidgen is needed by (installed) libzypp-9.34.0-0.7.15.x86_64

Paul




Hi
That file only contains some icons and a desktop file to start a 32bit
xterm session

Create you own desktop entry that executes;


xterm -e "linux32 \\$SHELL"


So you don't need to install that rpm.

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-17-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

aksingh
22-Apr-2015, 19:16
Just adding this so other with similar issue get benefit.

In SLES11 SP1 (or later): linux32 is merged into util-linux.

linux32 is not needed on SLES11 SP1/SP2/SP3. I have requested Oracle to update doc.

-Arun