PDA

View Full Version : sles11sp1 (oes11) HP SPP update - now dependencies in update



pattymackay
16-Jul-2014, 17:43
Trying to migrate a sles11sp1 oes11 server to sles11sp3 oes11sp2. So, I ran hpsum and installed the latest spp201606 and restarted the server. Then went into yast online updates, but there are dependency errors now.


#### YaST2 conflicts list - generated 2014-07-16 11:11:44 ####

lsi-mpt2sas-kmp-default-10.10.22.00_2.6.32.12_0.7-1.x86_64 requires kernel(default:kernel_printk) = 3103c42dd6130248, but this requirement cannot be provided
uninstallable providers: kernel-default-base-2.6.32.12-0.7.1.x86_64[SUSE-Linux-Enterprise-Server-11-SP1_11.1.1-1.152]
kernel-default-base-2.6.32.12-0.7.1.x86_64[nu_novell_com:SLES11-SP1-Pool]
kernel-default-base-2.6.32.13-0.5.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.27-0.2.2.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.19-0.2.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.29-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.23-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.13-0.4.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.24-0.2.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.36-0.5.2.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.19-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.43-0.4.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.45-0.3.2.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.46-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.49-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.54-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.59-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
[ ] Following actions will be done:
deinstallation of lsi-mpt2sas-kmp-default-10.10.22.00_2.6.32.12_0.7-1.x86_64
deinstallation of cciss-kmp-default-4.6.28_2.6.32.12_0.7-20.x86_64
[ ] do not install patch:slessp2-kernel-8868.noarch

[ ] break lsi-mpt2sas-kmp-default-10.10.22.00_2.6.32.12_0.7-1.x86_64 by ignoring some of its dependencies



hpvsa-kmp-default-1.2.2_2.6.32.12_0.7-3.x86_64 requires kernel(default:kernel_printk) = 3103c42dd6130248, but this requirement cannot be provided
uninstallable providers: kernel-default-base-2.6.32.12-0.7.1.x86_64[SUSE-Linux-Enterprise-Server-11-SP1_11.1.1-1.152]
kernel-default-base-2.6.32.12-0.7.1.x86_64[nu_novell_com:SLES11-SP1-Pool]
kernel-default-base-2.6.32.13-0.5.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.27-0.2.2.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.19-0.2.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.29-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.23-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.13-0.4.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.24-0.2.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.36-0.5.2.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.19-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.43-0.4.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.45-0.3.2.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.46-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.49-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.54-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.59-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
[ ] break hpvsa-kmp-default-1.2.2_2.6.32.12_0.7-3.x86_64 by ignoring some of its dependencies

[ ] do not install patch:oes11sp1-May-2014-Scheduled-Maintenance-9151.noarch

[ ] Following actions will be done:
deinstallation of hpvsa-kmp-default-1.2.2_2.6.32.12_0.7-3.x86_64
deinstallation of cciss-kmp-default-4.6.28_2.6.32.12_0.7-20.x86_64
[ ] Following actions will be done:
deinstallation of nss-kmp-default-4.14.4665_2.6.32.12_0.7-0.2.3.x86_64
deinstallation of novell-zapi-kmp-default-1.4.4665_2.6.32.12_0.7-0.2.3.x86_64


hpsa-kmp-default-3.0.0_2.6.32.12_0.7-8.x86_64 requires kernel(default:kernel_printk) = 3103c42dd6130248, but this requirement cannot be provided
uninstallable providers: kernel-default-base-2.6.32.12-0.7.1.x86_64[SUSE-Linux-Enterprise-Server-11-SP1_11.1.1-1.152]
kernel-default-base-2.6.32.12-0.7.1.x86_64[nu_novell_com:SLES11-SP1-Pool]
kernel-default-base-2.6.32.13-0.5.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.27-0.2.2.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.19-0.2.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.29-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.23-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.13-0.4.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.24-0.2.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.36-0.5.2.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.19-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.43-0.4.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.45-0.3.2.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.46-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.49-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.54-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
kernel-default-base-2.6.32.59-0.3.1.x86_64[nu_novell_com:SLES11-SP1-Updates]
[ ] Following actions will be done:
do not install patch:oes11sp1-enable-OES11-SP2-online-migration-8304.noarch
do not install patch:oes11sp1-avoid-sles11-sp3-online-migration-7834.noarch
[ ] Following actions will be done:
deinstallation of hpsa-kmp-default-3.0.0_2.6.32.12_0.7-8.x86_64
deinstallation of cciss-kmp-default-4.6.28_2.6.32.12_0.7-20.x86_64
[ ] deinstallation of kernel-default-2.6.32.59-0.7.1.x86_64

[ ] break hpsa-kmp-default-3.0.0_2.6.32.12_0.7-8.x86_64 by ignoring some of its dependencies

pattymackay
16-Jul-2014, 20:44
Decided I would do the upgrade/migration to sles11sp3/oes11sp2 (from sles11sp1/oes11) by booting from the dvd (rather than using yast2 wagon). Hoping this fixes the above issues. I'll attempt this Thursday. Just an fyi
Patty

smflood
17-Jul-2014, 11:12
On 16/07/2014 17:44, pattymackay wrote:

> Trying to migrate a sles11sp1 oes11 server to sles11sp3 oes11sp2.

When you say "migrate" do you actually mean upgrade OES11 (on SLES11
SP1) to OES11 SP2 (SLES11 SP3)? Migrate suggests move to another server
(physical or virtual) whereas upgrade is in-place on same hardware.

> So, I
> ran hpsum and installed the latest spp201606 and restarted the server.

Why run "hpsum"?

> Then went into yast online updates, but there are dependency errors now.
>
> #### YaST2 conflicts list - generated 2014-07-16 11:11:44 ####

...snip..

> [ ] do not install patch:slessp2-kernel-8868.noarch

The above option suggests the server hasn't been fully patched before
upgrade.

...snip..

> [ ] do not install
> patch:oes11sp1-May-2014-Scheduled-Maintenance-9151.noarch

Ditto.

> [ ] Following actions will be done:
> do not install
> patch:oes11sp1-enable-OES11-SP2-online-migration-8304.noarch
> do not install
> patch:oes11sp1-avoid-sles11-sp3-online-migration-7834.noarch

Upgrading from OES11 directly to OES11 SP2 (skipping OES11 SP1) can only
be done offline.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

smflood
17-Jul-2014, 11:19
On 16/07/2014 20:54, pattymackay wrote:

> Decided I would do the upgrade/migration to sles11sp3/oes11sp2 (from
> sles11sp1/oes11) by booting from the dvd (rather than using yast2
> wagon). Hoping this fixes the above issues. I'll attempt this
> Thursday. Just an fyi

As I just said in my other reply, upgrading from OES11 directly to OES11
SP2 is only supported when done off-line via physical or network-based
media - see section 5.1 of OES11 Installation Guide[1].

If using physical media make sure that you use the combined OES11 SP2
with SLES11 SP3 DVD (to save swapping DVDs if using the separate SLES11
SP3 DVD) and if network-based install sources make sure you have both
SLES11 SP3 and OES11 SP2 available.

See section 5.4.4 of OES11 Installation Guide on how to use physical
media to upgrade off-line[2] (plus earlier sections for planning).

Oh and note that since OES is a Novell product you should really post in
one of Novell's OES-related forums @
https://forums.novell.com/forumdisplay.php/426-Open-Enterprise-Server
rather than here (since these are SUSE's forums).

HTH.

[1] https://www.novell.com/documentation/oes11/inst_oes_lx/data/bhu19u7.html
[2]
https://www.novell.com/documentation/oes11/inst_oes_lx/data/bv6uejh.html#babagdd
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------