PDA

View Full Version : Can't find libmysqlclient15 version 5.0.67



ticoon
30-Jul-2014, 17:17
Hi,

I'm trying to install Bacula, non corporate version on SLES SP3. I need to install libmysqlclient-devel which is part of SLES SDK 11, but its dependancy of libmysqlclient15 version 5.0.67 is not met. The newer version 5.0.96 is installed but I am still having issues when trying to install bacula. Below is the output when trying to make bacula install version is 7.0.3 of open bacula free version.

Thanks for all the help.

Compiling mysql.c
Making libbaccats-mysql.la ...
/opt/bacula-7.0.3/libtool --silent --tag=CXX --mode=link /usr/bin/g++ -D_BDB_PRIV_INTERFACE_ -o libbaccats-mysql.la mysql.lo -export-dynamic -rpath /usr/lib64 -release 7.0.3 \
-soname libbaccats-7.0.3.so -R /usr/lib64/mysql -L/usr/lib64/mysql -lmysqlclient_r -lz
/usr/lib64/gcc/x86_64-suse-linux/4.3/../../../../x86_64-suse-linux/bin/ld: cannot find -lz
collect2: ld returned 1 exit status
make[1]: *** [libbaccats-mysql.la] Error 1
make[1]: Leaving directory `/opt/bacula-7.0.3/src/cats'


====== Error in /opt/bacula-7.0.3/src/cats ======

jmozdzen
30-Jul-2014, 17:31
Hi ticoon,

Hi,

I'm trying to install Bacula, non corporate version on SLES SP3. I need to install libmysqlclient-devel which is part of SLES SDK 11, but its dependancy of libmysqlclient15 version 5.0.67 is not met. The newer version 5.0.96 is installed but I am still having issues when trying to install bacula. Below is the output when trying to make bacula install version is 7.0.3 of open bacula free version.

Thanks for all the help.

Compiling mysql.c
Making libbaccats-mysql.la ...
/opt/bacula-7.0.3/libtool --silent --tag=CXX --mode=link /usr/bin/g++ -D_BDB_PRIV_INTERFACE_ -o libbaccats-mysql.la mysql.lo -export-dynamic -rpath /usr/lib64 -release 7.0.3 \
-soname libbaccats-7.0.3.so -R /usr/lib64/mysql -L/usr/lib64/mysql -lmysqlclient_r -lz
/usr/lib64/gcc/x86_64-suse-linux/4.3/../../../../x86_64-suse-linux/bin/ld: cannot find -lz
collect2: ld returned 1 exit status
make[1]: *** [libbaccats-mysql.la] Error 1
make[1]: Leaving directory `/opt/bacula-7.0.3/src/cats'


====== Error in /opt/bacula-7.0.3/src/cats ======

two things:

1. Dependencies: Have you installed the SDK as an add-on product, so that you have access to the updated contents?

2. You need to provide libz (" cannot find -lz") - "zypper in zlib-devel" might help.

Regards,
Jens

ticoon
30-Jul-2014, 17:53
Thanks Jens,

when trying to install zlib-devel, i have yet another broken dependancy as it require zlib version 1.2.3 and the current one is 1.2.7

Ticoon

ticoon
30-Jul-2014, 17:56
Also yes, the SDK for SLES 11 has been added both to the add-on products and to available repos

ticoon
31-Jul-2014, 05:49
Can anyone recommend a backup software server solution similar to bacula that is compatible with SLES 11 SP3.

I ended up install zlib version 1.2.3 as required which would give me the dependancy for libmysqlclient15 5.0.67 which would then meet the requirement for libmysqlclient-devel. But in the process of installing zlib 1.2.3 it had to downgrade dependancies which resulted in a server that was useless at the end of the day as binutils rpm was downgraded and after the uninstall, the older version was unable to be installed, and failed.

Long story short is there something other than bacula project that is free as a backup solution on sles 11 sp3, something that acts like a backup server to pull data from other servers, and store locally or to tape.

Thanks in advance

jmozdzen
31-Jul-2014, 07:29
Hi ticoon,

I ended up install zlib version 1.2.3 as required which would give me the dependancy for libmysqlclient15 5.0.67 which would then meet the requirement for libmysqlclient-devel. But in the process of installing zlib 1.2.3 it had to downgrade dependancies which resulted in a server that was useless at the end of the day as binutils rpm was downgraded and after the uninstall, the older version was unable to be installed, and failed.

My SLES11SP3 says:

myhost:~ # zypper info --requires libmysqlclient-devel
[...]
Information for package libmysqlclient-devel:

Repository: SLE11-SDK-SP3-Pool
Name: libmysqlclient-devel
Version: 5.0.96-0.6.1
Arch: x86_64
Vendor: SUSE LINUX Products GmbH, Nuernberg, Germany
[...]
Requires:
[...]
zlib-devel
openssl-devel
libmysqlclient15 == 5.0.96
libmysqlclient_r15 == 5.0.96
so currently it's 5.0.96 and not 5.0.67. zlib-devel is at 1.2.7:

myhost:~ # zypper info zlib-devel
[...]
Information for package zlib-devel:

Repository: SLE11-SDK-SP3-Pool
Name: zlib-devel
Version: 1.2.7-0.10.128
Arch: x86_64
Vendor: SUSE LINUX Products GmbH, Nuernberg, Germany
Support Level: unknown
Installed: Yes
Status: up-to-date
Installed Size: 657.0 KiB
Summary: Include Files and Libraries mandatory for Development
Description:
This package contains all necessary include files and libraries needed
to develop applications that require the provided includes and
libraries.
Might it be your system is not properly configured for updates? What does "zypper lr" report?

Oh, and we're running self-compiled versions of Bacula on a wide range of SLES systems, including of course SLES11SP3.

Regards,
Jens