PDA

View Full Version : Looking for older version suse patches



Scottys
31-Jul-2014, 01:37
I am looking for libc.so.6 which is found in glibc 2.4. I am running a suse 9.2 (believe it or not) that has been running continuously non stop for 11 years in an internet radio station. Need to install a program and the dependencies tell me that I need glibc 2.4 especially the libc.20.6 rpm. Where can I find the older version rpms to dowload? Please help. Don't really want to go to a newer version with this track record.

malcolmlewis
31-Jul-2014, 04:11
Hi
Are we talking about SLE 9 SP2 or SuSE 9.2?

Can you post the output from;


cat /etc/SuSE-release

Scottys
31-Jul-2014, 16:13
We are using Suse 9.2 Professional version. What we are trying to do is to install a program where we can access the computer from a mobile phone through VNC. We will use Team Viewer app for Android. When we try to install the program it tells us we need libc.so.6 which is in glibc 2.4. We have glibc 2.3 on this version Suse. We need to know where we can access the older rpms to get this and because I have a feeling that we will have to install a lot more rpms before it is over. Do you think that this will work?

mikewillis
31-Jul-2014, 17:12
There was SUSE Linux releases version 9.0 9.1 and 9.2 and there's also SUSE Linux Enterprise Server 9. (This forum is for SUSE Linux Enterprise Server.) Can you post the output of


$ cat /etc/*release*

That said, whatever you're running you really need to figure out how to do what you need to do without requiring a newer glibc or update the OS to a (much) newer version. You don't mess with the glibc version on your system unless you're prepared to break everything.

jmozdzen
31-Jul-2014, 17:30
Hi Mike,

> We are using Suse 9.2 Professional version.

this is from before the split-up into SLES and SLED... so both forum ranges might be appropriate ;)

And your advice is right on the spot:

> You don't mess with the glibc version on your system unless you're prepared to break everything.

...and I doubt that a version update of glibc was available for SuSE 9.2 Pro... unless you count in SuSE 9.3 Pro ;)

Regards,
Jens

Scottys
31-Jul-2014, 17:57
Thank you. Sounds like good advice.