View Full Version : How to stop DHCPCD from running during boot?

16-Sep-2014, 21:35

I recently installed a SLES 11 SP3 server to work as an OES server. I configured all the network interfaces to static ip addresses, but for some reason, dhcpd is being run on boot, which is causing a bogus IP address get configured on the server, which is causing me trouble.

Does anyone knows which files holds this controls? I tried to compare all files with a similar server without this error, but I haven't found any clue until now.

This is an extract from the problematic server boot.msg:

<5>[ 212.280176] XFS (sda6): Ending recovery (logdev: internal)
<6>[ 213.934270] fuse init (API version 7.16)
Kernel logging (ksyslog) stopped.
Kernel log daemon terminating.

Boot logging started on /dev/tty1(/dev/console) at Mon Sep 15 17:16:56 2014

FATAL: Error inserting mgag200 (/lib/modules/3.0.101-0.35-default/kernel/drivers/gpu/drm/mgag200/mgag200.ko): Invalid argument
running dhcpcd on interface bond0
err, bond0: Failed to lookup hostname via DNS: Temporary failure in name resolution
Starting iSCSI daemon
Logging in to [iface: default, target: iqn.1992-04.com.emc:storage.ix4-300d.UTIL, portal:,3260] (multiple)
Logging in to [iface: default, target: iqn.1992-04.com.emc:storage.ix4-300d.BACKUP, portal:,3260] (multiple)
Logging in to [iface: default, target: iqn.1992-04.com.emc:storage.ix4-300d.DATA, portal:,3260] (multiple)
Logging in to [iface: default, target: iqn.1992-04.com.emc:storage.ix4-300d.CLUSTER, portal:,3260] (multiple)

16-Sep-2014, 23:34
Well, I found that the file responsible for this configuration is the initrd (/boot/initd-<kernel version>).
Now I need to find a way to force the correction to it.

17-Sep-2014, 00:40
Solved it... seems that the script /lib/mkinitrd/scripts/setup-network.sh decides whether the default interface's bootproto is dhcp/static by the presence of the dhcpcd service. But, instead of searching for "dhcpcd", it searches for "dhcp", which makes the presence of "dhcpd" service a false positive.

I'll try to file this as a bug to "mkinitrd" package.

17-Sep-2014, 13:05
Hi jqueiroz,

great find - thank you for reporting it here (and for bringing it to the developers' attention)!

Best regards,