PDA

View Full Version : Embedded Video is not played in Firefox



aabdelkhalek
20-Sep-2014, 17:52
Hi,

The below link contains a video which I'm not able to play on SLED 11 while I'm able to play on windows so why is that?

http://www.filgoal.com/Arabic/VideoView.aspx?AudioVideoID=12330

Could it be due to a missing plugin from firefox?

Thanks,
Ahmed

malcolmlewis
21-Sep-2014, 00:50
On Sat 20 Sep 2014 04:54:01 PM CDT, aabdelkhalek wrote:


Hi,

The below link contains a video which I'm not able to play on SLED 11
while I'm able to play on windows so why is that?

http://www.filgoal.com/Arabic/VideoView.aspx?AudioVideoID=12330

Could it be due to a missing plugin from firefox?

Thanks,
Ahmed




Hi
More likely a codec... Is this SLED 11, or one of the SPn versions? Can
you post the output from;


cat /etc/SuSE-release

If it's SP3, then have a read here;
https://www.suse.com/communities/conversations/additional-multimedia-codec-support-for-sled-11-sp3/

Also in Windows, if you right click on the embedded video, does it show
any media information on the stream?

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-21-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

aabdelkhalek
21-Sep-2014, 02:29
Hi
More likely a codec... Is this SLED 11, or one of the SPn versions?
It is actually SLED 11 SP2


SUSE Linux Enterprise Desktop 11 (x86_64)
VERSION = 11
PATCHLEVEL = 2



If it's SP3, then have a read here;
https://www.suse.com/communities/conversations/additional-multimedia-codec-support-for-sled-11-sp3/

Is there a way to install these additional codecs for SLED 11 SP2?



Also in Windows, if you right click on the embedded video, does it show
any media information on the stream?

When I do the right click, I don't get information about the stream but the last item in the menu is about Adobe Flash Player version and this is what I believe to be missing from my laptop

By the way, it is not only this page, this problem happens with a lot of pages!

Thanks,
Ahmed

aabdelkhalek
21-Sep-2014, 02:41
Hi again,

Would like to highlight that the problem is not that I'm not able to play the video but the real problem is that the page is loaded without recognizing that this is a video there is no play sign so that I click it!

Please let me know if this is not clear.

Thanks,
Ahmed

malcolmlewis
21-Sep-2014, 03:00
On Sun 21 Sep 2014 01:44:02 AM CDT, aabdelkhalek wrote:


Hi again,

Would like to highlight that the problem is not that I'm not able to
play the video but the real problem is that the page is loaded without
recognizing that this is a video there is no play sign so that I click
it!

Please let me know if this is not clear.

Thanks,
Ahmed




Hi
Since it's SP2, then probably the installed flash player is too old...

You can check via YaST software management and search on
flash.

You should upgrade to SP3 if you can?

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-21-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

mikewillis
22-Sep-2014, 13:21
The below link contains a video which I'm not able to play on SLED 11 while I'm able to play on windows so why is that?

http://www.filgoal.com/Arabic/VideoView.aspx?AudioVideoID=12330

Could it be due to a missing plugin from firefox?

As Malcom suggested, could be your version of Flash could be too old. General support for SLED 11 SP2 ended some time ago, you really should update to SP3.

However, the videos at that website play on my iPad, which means they do not require Flash to view. Quite possibly they serve Flash video to some browsers and something in a HTML video tag to others. You could try using a useragent switcher extension for Firefox such as https://addons.mozilla.org/en-US/firefox/addon/user-agent-overrider/ to make Firefox pretend to be Safari on iOS.

aabdelkhalek
22-Sep-2014, 14:38
As Malcom suggested, could be your version of Flash could be too old.
I upgraded the flash player to release 11.2.202.406-0.3.1 and the problem is the same!


General support for SLED 11 SP2 ended some time ago, you really should update to SP3.
I have that HP repro problem! I have posted the request on their forum long time ago but no reply and the forum is the only way I could find on HP website for support and technical assistance!


However, the videos at that website play on my iPad, which means they do not require Flash to view. Quite possibly they serve Flash video to some browsers and something in a HTML video tag to others. You could try using a useragent switcher extension for Firefox such as https://addons.mozilla.org/en-US/firefox/addon/user-agent-overrider/ to make Firefox pretend to be Safari on iOS.
Strange enough, when I use iOS/Safari 7 I'm not able to play the video!!!

Any other suggestions?

Thanks,
Ahmed

malcolmlewis
22-Sep-2014, 14:52
On Mon 22 Sep 2014 01:44:01 PM CDT, aabdelkhalek wrote:


mikewillis;23737 Wrote:
> As Malcom suggested, could be your version of Flash could be too old.
I upgraded the flash player to release 11.2.202.406-0.3.1 and the
problem is the same!

> General support for SLED 11 SP2 ended some time ago, you really should
> update to SP3.
I have that HP repro problem! I have posted the request on their forum
long time ago but no reply and the forum is the only way I could find on
HP website for support and technical assistance!

> However, the videos at that website play on my iPad, which means they
> do not require Flash to view. Quite possibly they serve Flash video
> to some browsers and something in a HTML video tag to others. You
> could try using a useragent switcher extension for Firefox such as
> https://addons.mozilla.org/en-US/firefox/addon/user-agent-overrider/
> to make Firefox pretend to be Safari on iOS.
Strange enough, when I use iOS/Safari 7 I'm not able to play the
video!!!

Any other suggestions?

Thanks,
Ahmed




Hi
So in firefox, if you enter about:plugins as the url, what are
installed?

It works in iOS8/safari for me?

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-21-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

malcolmlewis
22-Sep-2014, 14:57
On Mon 22 Sep 2014 01:52:07 PM CDT, malcolmlewis wrote:



On Mon 22 Sep 2014 01:44:01 PM CDT, aabdelkhalek wrote:


mikewillis;23737 Wrote:
> As Malcom suggested, could be your version of Flash could be too old.
I upgraded the flash player to release 11.2.202.406-0.3.1 and the
problem is the same!

> General support for SLED 11 SP2 ended some time ago, you really should
> update to SP3.
I have that HP repro problem! I have posted the request on their forum
long time ago but no reply and the forum is the only way I could find on
HP website for support and technical assistance!

> However, the videos at that website play on my iPad, which means they
> do not require Flash to view. Quite possibly they serve Flash video
> to some browsers and something in a HTML video tag to others. You
> could try using a useragent switcher extension for Firefox such as
> https://addons.mozilla.org/en-US/firefox/addon/user-agent-overrider/
> to make Firefox pretend to be Safari on iOS.
Strange enough, when I use iOS/Safari 7 I'm not able to play the
video!!!

Any other suggestions?

Thanks,
Ahmed




Hi
So in firefox, if you enter about:plugins as the url, what are
installed?

It works in iOS8/safari for me?



The other option is pipelight, but I doubt it would work for SP2.

Do you still have an active subscription for your system, if not then
maybe you should look at openSUSE, else get an updated subscription for
SLED 11 and upgrade...

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-21-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

aabdelkhalek
22-Sep-2014, 15:29
Hi
So in firefox, if you enter about:plugins as the url, what are
installed?

It works in iOS8/safari for me?

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-21-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!


Here you're the enabled plugins in firefox



Enabled plugins
Find more information about browser plugins at mozilla.org.
Find updates for installed plugins at mozilla.com/plugincheck.
Help for installing plugins is available from plugindoc.mozdev.org.
Citrix Receiver for Linux

File: npwrapper.npica.so
Version:
ICA Plugin (Linux) Version 12.1.0.203066 (/usr/lib/ICAClient/wfica)

MIME Type Description Suffixes
application/x-ica Handles ICA connections ica
Shockwave Flash

File: libflashplayer.so
Version: 11,2,202,406
Shockwave Flash 11.2 r202

MIME Type Description Suffixes
application/x-shockwave-flash Shockwave Flash swf
application/futuresplash FutureSplash Player spl
IcedTea-Web Plugin (using IcedTea-Web 1.4.1 (suse-0.8.1-x86_64))

File: IcedTeaPlugin.so
Version:
The IcedTea-Web Plugin executes Java applets.

MIME Type Description Suffixes
application/x-java-vm IcedTea class,jar
application/x-java-applet IcedTea class,jar
application/x-java-applet;version=1.1 IcedTea class,jar
application/x-java-applet;version=1.1.1 IcedTea class,jar
application/x-java-applet;version=1.1.2 IcedTea class,jar
application/x-java-applet;version=1.1.3 IcedTea class,jar
application/x-java-applet;version=1.2 IcedTea class,jar
application/x-java-applet;version=1.2.1 IcedTea class,jar
application/x-java-applet;version=1.2.2 IcedTea class,jar
application/x-java-applet;version=1.3 IcedTea class,jar
application/x-java-applet;version=1.3.1 IcedTea class,jar
application/x-java-applet;version=1.4 IcedTea class,jar
application/x-java-applet;version=1.4.1 IcedTea class,jar
application/x-java-applet;version=1.4.2 IcedTea class,jar
application/x-java-applet;version=1.5 IcedTea class,jar
application/x-java-applet;version=1.6 IcedTea class,jar
application/x-java-applet;jpi-version=1.6.0_50 IcedTea class,jar
application/x-java-bean IcedTea class,jar
application/x-java-bean;version=1.1 IcedTea class,jar
application/x-java-bean;version=1.1.1 IcedTea class,jar
application/x-java-bean;version=1.1.2 IcedTea class,jar
application/x-java-bean;version=1.1.3 IcedTea class,jar
application/x-java-bean;version=1.2 IcedTea class,jar
application/x-java-bean;version=1.2.1 IcedTea class,jar
application/x-java-bean;version=1.2.2 IcedTea class,jar
application/x-java-bean;version=1.3 IcedTea class,jar
application/x-java-bean;version=1.3.1 IcedTea class,jar
application/x-java-bean;version=1.4 IcedTea class,jar
application/x-java-bean;version=1.4.1 IcedTea class,jar
application/x-java-bean;version=1.4.2 IcedTea class,jar
application/x-java-bean;version=1.5 IcedTea class,jar
application/x-java-bean;version=1.6 IcedTea class,jar
application/x-java-bean;jpi-version=1.6.0_50 IcedTea class,jar
application/x-java-vm-npruntime IcedTea
NPAPI Plugins Wrapper 1.4.4

File: npwrapper.so
Version:
nspluginwrapper is a cross-platform NPAPI plugin viewer, in particular for linux/i386 plugins.
This beta software is available under the terms of the GNU General Public License.

MIME Type Description Suffixes
unknown/mime-type Do not open none
Windows Media Player Plug-in 10 (compatible; Moonshine Media Player)

File: libmoonshine-plugin.so
Version:
A media player powered by Moonlight, largely compatible with the Windows Media Player ActiveX control.

MIME Type Description Suffixes
application/x-moonshine-player Media Files *
application/x-mplayer2 Media Files *
application/x-ms-wms Media Files *
application/x-ms-wmp Media Files *
application/asx Media Files *
video/x-ms-asf-plugin Media Files *
video/x-msvideo Media Files *
video/x-ms-wmp Media Files *
video/x-ms-asf Media Files asf,asx,*
video/x-ms-wm Media Files wm,*
video/x-ms-wmv Media Files wmv,*
video/x-ms-wvx Media Files wvx,*
audio/x-ms-wma Media Files wma,*
audio/x-ms-wax Media Files wax,*
Silverlight Plug-In

File: libmoonloader.so
Version:
3.0.40818.0

MIME Type Description Suffixes
application/x-silverlight Novell Moonlight xaml
application/x-silverlight-2 Novell Moonlight
OpenSC Signer plugin

File: opensc-signer.so
Version:
This plugins handles web signatures using OpenSC smart card library.

MIME Type Description Suffixes
text/x-text-to-sign Text to be signed sgn



By the way, after my last post I thought of giving the SP3 update another shot and I got one conflict, not related to the kernel as last time, and I opted for keeping the obsolete version of that package and the update passed so now I have SP3



aabdelkhalek@linux-moati:~> cat /etc/SuSE-release
SUSE Linux Enterprise Desktop 11 (x86_64)
VERSION = 11
PATCHLEVEL = 3
aabdelkhalek@linux-moati:~>

aabdelkhalek
22-Sep-2014, 15:35
Hi
If it's SP3, then have a read here;
https://www.suse.com/communities/conversations/additional-multimedia-codec-support-for-sled-11-sp3/

Now I'm on SP3 so I tried these additional codec but I got an error saying:



configure: No package 'gstreamer-0.10' found
configure: error: no gstreamer-0.10 >= 0.10.33 (GStreamer) found


I checked in YAST and I have version 0.10.35-2.9.46 (in red) so what's wrong?

Thanks,
Ahmed

malcolmlewis
22-Sep-2014, 16:13
On Mon 22 Sep 2014 02:44:02 PM CDT, aabdelkhalek wrote:


malcolmlewis;23714 Wrote:
> Hi
> If it's SP3, then have a read here;
> https://www.suse.com/communities/conversations/additional-multimedia-codec-support-for-sled-11-sp3/

Now I'm on SP3 so I tried these additional codec but I got an error
saying:


Code:
--------------------

configure: No package 'gstreamer-0.10' found
configure: error: no gstreamer-0.10 >= 0.10.33 (GStreamer) found

--------------------


I checked in YAST and I have version 0.10.35-2.9.46 (in red) so what's
wrong?

Thanks,
Ahmed




Hi
I'll let Mike help you with that....

Anyway, I believe it's a flash player issue since they have dropped
support for it. I would suggest you contact the website admin and ask
them if/when they will support html5 playback. The method they use is a
revenue stream as they use playwire..

I does work with pipelight (which uses the latest flash version and
wine), however, you would need to ask the folks on the Open Build
Service to enable and see if it would build for SLE 11 SP3;
https://build.opensuse.org/package/users/home:DarkPlayer:Pipelight/Pipelight

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-21-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

mikewillis
23-Sep-2014, 08:59
Now I'm on SP3 so I tried these additional codec but I got an error saying:



configure: No package 'gstreamer-0.10' found
configure: error: no gstreamer-0.10 >= 0.10.33 (GStreamer) found


I checked in YAST and I have version 0.10.35-2.9.46 (in red) so what's wrong?


Probably you don't have the gstreamer-devel package installed. You need to install several packages from the SDK first. It's all explained in the README.txt

Even with the extra multimedia codecs installed I've not been able to make the videos play though.

aabdelkhalek
23-Sep-2014, 19:44
Probably you don't have the gstreamer-devel package installed. You need to install several packages from the SDK first. It's all explained in the README.txt

Even with the extra multimedia codecs installed I've not been able to make the videos play though.

I ran the checkdependencies file to find out the missing packages and installed most of them but I have a problem with the below list of packages



package libstdc++47-devel is not installed
package check-devel is not installed
package gtk-doc is not installed
package libdc1394-devel is not installed
package mjpegtools-devel is not installed
package translation-update-upstream is not installed
package gstreamer-0_10-devel is not installed
package gstreamer-0_10-plugins-base-devel is not installed


When I try to install these packages they fail due to dependencies as below:


Problem: nothing provides libstdc++6 >= 4.7.2_20130108-0.17.2 needed by libstdc++47-devel-4.7.2_20130108-0.17.2.x86_64
Problem: nothing provides check = 0.9.5 needed by check-devel-0.9.5-63.21.x86_64
Problem: nothing provides docbook_4 needed by gtk-doc-1.11-3.6.48.noarch
Problem: nothing provides libraw1394-11 = 2.0.7 needed by libraw1394-devel-2.0.7-3.5.18.x86_64 (libdc1394-devel)
Problem: nothing provides libraw1394-11 = 2.0.7 needed by libraw1394-devel-2.0.7-3.5.18.x86_64 (mjpegtools-devel)
Problem: nothing provides gettext-tools needed by translation-update-upstream-20130506-0.9.1.noarch
Problem: nothing provides check = 0.9.5 needed by check-devel-0.9.5-63.21.x86_64 (gstreamer-0_10-devel)
Problem: nothing provides check = 0.9.5 needed by check-devel-0.9.5-63.21.x86_64 (gstreamer-0_10-plugins-base-devel)


So how to install these packages?

To conclude the issue of the videos in that website, from my side, the only solution is to install pipelight, correct?

Thanks,
Ahmed

mikewillis
23-Sep-2014, 21:07
I ran the checkdependencies file to find out the missing packages and installed most of them but I have a problem with the below list of packages



package libstdc++47-devel is not installed
package check-devel is not installed
package gtk-doc is not installed
package libdc1394-devel is not installed
package mjpegtools-devel is not installed
package translation-update-upstream is not installed
package gstreamer-0_10-devel is not installed
package gstreamer-0_10-plugins-base-devel is not installed


When I try to install these packages they fail due to dependencies as below:


Problem: nothing provides libstdc++6 >= 4.7.2_20130108-0.17.2 needed by libstdc++47-devel-4.7.2_20130108-0.17.2.x86_64
Problem: nothing provides check = 0.9.5 needed by check-devel-0.9.5-63.21.x86_64
Problem: nothing provides docbook_4 needed by gtk-doc-1.11-3.6.48.noarch
Problem: nothing provides libraw1394-11 = 2.0.7 needed by libraw1394-devel-2.0.7-3.5.18.x86_64 (libdc1394-devel)
Problem: nothing provides libraw1394-11 = 2.0.7 needed by libraw1394-devel-2.0.7-3.5.18.x86_64 (mjpegtools-devel)
Problem: nothing provides gettext-tools needed by translation-update-upstream-20130506-0.9.1.noarch
Problem: nothing provides check = 0.9.5 needed by check-devel-0.9.5-63.21.x86_64 (gstreamer-0_10-devel)
Problem: nothing provides check = 0.9.5 needed by check-devel-0.9.5-63.21.x86_64 (gstreamer-0_10-plugins-base-devel)


So how to install these packages?

You mentioned in another post that you have updated to SP3 but in doing so had encountered a conflict. That and the above may be linked. I think there's a problem with your repositories. libstdc++6-4.7.2_20130108-0.17.2 is in the SLED 11 SP3 Updates repo. check-0.9.5-63.21 is in the SLED 11 SP3 Pool repo (there haven't been any updates to it).
What's the output of

$ zypper lr -u
$ zypper verify




To conclude the issue of the videos in that website, from my side, the only solution is to install pipelight, correct?

I can't see another way just now, but also I don't know if pipelight will work. The website in question is evidently not as smart as it could be regarding how it's serving up video. I've no idea what will make it viewable.

malcolmlewis
23-Sep-2014, 21:54
On Tue 23 Sep 2014 08:14:02 PM CDT, mikewillis wrote:

>
> To conclude the issue of the videos in that website, from my side, the
> only solution is to install pipelight, correct?
>
I can't see another way just now, but also I don't know if pipelight
will work. The website in question is evidently not as smart as it could
be regarding how it's serving up video. I've no idea what will make it
viewable.

Hi
Pipelight on openSUSE 13.1 works, it should work if it builds for SP3...

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-21-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

aabdelkhalek
23-Sep-2014, 22:18
I think there's a problem with your repositories.
You're right, the SLED11-SP3-Pool and SLED11-SP3-Updates were disabled while the SLE11-SDK-SP3-Pool and SLE11-SDK-SP3-Updates were enabled

Here's the output of zypper lr -u, which repos should I keep and which should I removed?



zypper lr -u
# | Alias | Name | Enabled | Refresh | URI
---+-------------------------------------------+-------------------------------------------------------+---------+---------+-----------------------------------------------------------------------------------------------------------------
1 | /home:DarkPlayer:Pipelight.repo | /home:DarkPlayer:Pipelight.repo | Yes | Yes | http://download.opensuse.org/repositories/home:/DarkPlayer:/Pipelight/openSUSE_12.2
2 | ATI-Driver-SLE11-SP3 | ATI-Driver-SLE11-SP3 | Yes | Yes | http://www2.ati.com/suse/sle11sp3
3 | HP-BNB-Dedicated-Update-Channel | HP-BNB-Dedicated-Update-Channel | Yes | Yes | https://SLED11SP2HPBNBUNREGISTERED@nu.novell.com/repo/$RCE/SLED11-SP2-HP-BNB-Unregistered-Updates/sle-11-x86_64/
4 | SLED11-SP3-SDK | SUSE Linux Enterprise Software Development Kit 11 SP3 | Yes | No | iso:///?iso=SLE-11-SP3-SDK-DVD-x86_64-GM-DVD1.iso&url=file:///home/aabdelkhalek/installs/
5 | nVidia-Driver-SLE11-SP3 | nVidia-Driver-SLE11-SP3 | Yes | Yes | http://download.nvidia.com/novell/sle11sp3
6 | nu_novell_com:SLE11-SDK-SP1-Pool | SLE11-SDK-SP1-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP1-Pool/sle-11-x86_64?credentials=NCCcredentials
7 | nu_novell_com:SLE11-SDK-SP1-Updates | SLE11-SDK-SP1-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP1-Updates/sle-11-x86_64?credentials=NCCcredentials
8 | nu_novell_com:SLE11-SDK-SP2-Core | SLE11-SDK-SP2-Core | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP2-Core/sle-11-x86_64?credentials=NCCcredentials
9 | nu_novell_com:SLE11-SDK-SP2-Updates | SLE11-SDK-SP2-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP2-Updates/sle-11-x86_64?credentials=NCCcredentials
10 | nu_novell_com:SLE11-SDK-SP3-Pool | SLE11-SDK-SP3-Pool | Yes | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP3-Pool/sle-11-x86_64?credentials=NCCcredentials
11 | nu_novell_com:SLE11-SDK-SP3-Updates | SLE11-SDK-SP3-Updates | Yes | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP3-Updates/sle-11-x86_64?credentials=NCCcredentials
12 | nu_novell_com:SLE11-SP1-Debuginfo-Pool | SLE11-SP1-Debuginfo-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP1-Debuginfo-Pool/sle-11-x86_64?credentials=NCCcredentials
13 | nu_novell_com:SLE11-SP1-Debuginfo-Updates | SLE11-SP1-Debuginfo-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP1-Debuginfo-Updates/sle-11-x86_64?credentials=NCCcredentials
14 | nu_novell_com:SLE11-SP2-Debuginfo-Core | SLE11-SP2-Debuginfo-Core | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP2-Debuginfo-Core/sle-11-x86_64?credentials=NCCcredentials
15 | nu_novell_com:SLE11-SP2-Debuginfo-Updates | SLE11-SP2-Debuginfo-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP2-Debuginfo-Updates/sle-11-x86_64?credentials=NCCcredentials
16 | nu_novell_com:SLED11-Extras | SLED11-Extras | Yes | Yes | https://nu.novell.com/repo/$RCE/SLED11-Extras/sle-11-x86_64?credentials=NCCcredentials
17 | nu_novell_com:SLED11-SP1-Pool | SLED11-SP1-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLED11-SP1-Pool/sle-11-x86_64?credentials=NCCcredentials
18 | nu_novell_com:SLED11-SP1-Updates | SLED11-SP1-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLED11-SP1-Updates/sle-11-x86_64?credentials=NCCcredentials
19 | nu_novell_com:SLED11-SP2-Core | SLED11-SP2-Core | No | Yes | https://nu.novell.com/repo/$RCE/SLED11-SP2-Core/sle-11-x86_64?credentials=NCCcredentials
20 | nu_novell_com:SLED11-SP2-HP-BNB-Updates | SLED11-SP2-HP-BNB-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLED11-SP2-HP-BNB-Updates/sle-11-x86_64?credentials=NCCcredentials
21 | nu_novell_com:SLED11-SP2-Updates | SLED11-SP2-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLED11-SP2-Updates/sle-11-x86_64?credentials=NCCcredentials
22 | nu_novell_com:SLED11-SP3-Pool | SLED11-SP3-Pool | Yes | Yes | https://nu.novell.com/repo/$RCE/SLED11-SP3-Pool/sle-11-x86_64?credentials=NCCcredentials
23 | nu_novell_com:SLED11-SP3-Updates | SLED11-SP3-Updates | Yes | Yes | https://nu.novell.com/repo/$RCE/SLED11-SP3-Updates/sle-11-x86_64?credentials=NCCcredentials



I can't see another way just now, but also I don't know if pipelight will work. The website in question is evidently not as smart as it could be regarding how it's serving up video. I've no idea what will make it viewable.
But what's the problem with SLED 11 SP3? and why the videos are played on windows not SLED? I don't understand the source of the problem

Thanks,
Ahmed

aabdelkhalek
23-Sep-2014, 22:31
After installing the multimedia codecs I tried a movie that I had long time ago and it didn't work back then.

Now, the video is ok with no audio and I get an error as follows:



PackageKit-gstreamer-plugin requires additional plugins

An additional plugin is required to play this content.

The following plugin is required:

DTS decoder

Do you want to search for this now?

And when I choose Search. I get the error: Failed to search the plugin. Could not find plugin in any configured software source

At the same time, the video freezes and hangs

Thanks,
Ahmed

P.S.: Please let me know if I should have opened a new thread for that problem

mikewillis
24-Sep-2014, 08:27
After installing the multimedia codecs I tried a movie that I had long time ago and it didn't work back then.

Now, the video is ok with no audio and I get an error as follows:



PackageKit-gstreamer-plugin requires additional plugins

An additional plugin is required to play this content.

The following plugin is required:

DTS decoder

Do you want to search for this now?

And when I choose Search. I get the error: Failed to search the plugin. Could not find plugin in any configured software source

At the same time, the video freezes and hangs

Hmmm. So many codecs, I haven't tested them all ;) However if I run

$ gst-inspect-1.0 | grep -i dts
there is mention of a DTS decoder in the output by way of ffmpeg. There's info on a DTS decoder at
https://www.videolan.org/developers/libdca.html
I downloaded a couple of the samples at the Swedish Radio website that links to, one seemed like audio garbage, the other got me the same error you cite.
I'll have a look at it at some point.

LLiner
26-Sep-2014, 11:08
Hi,

Let me add my cents...
In Windows HP, I cannot play the video in question:
After clicking on it, I see, as usually recently, a pblack puzzle scree
requesting to press to launch Adobe Flash Player.
Normally after such an option, vedeo starts playing.
However, these video DO NOT, displaying a black windows or even a blue windows.

Regards

Lliner

AndreasMeyer
21-Dec-2014, 20:08
I'm able to play your video without any flash player plugin. You need:

1.) SLED11 Service Pack 3 or SLED12.

2.) GStreamer-Plugins -> Fluendo One Play Codec Pack -> http://eu.fluendo.com
SLED11SP3: GStreamer v0.10 -> "Linux generic" (read Readme.txt)
SLED12: GStreamer v1.00 -> "Linux RPM"

3.) Only SLED11: Firefox ESR 31 with SUSE-Patch 7776. SUSE-Patch 7776 is not public available.
Ask SUSE Linux Enterprise Hotline (http://www.suse.com -> Support) for this patch.
SLED12 don't need SUSE-Patch 7776.

# rpm -q MozillaFirefox
MozillaFirefox-31.3.0esr-0.8.1.7776.5.PTF.906111

# rpm -q --changelog MozillaFirefox |more
* Die Dez 16 2014 stokos@suse.de
- build with gstreamer-0_10
(bnc#906111)

* Mit Dez 03 2014 pcerny@suse.com
- update to Firefox 31.3.0 ESR (bnc#908009)
* MFSA 2014-83/CVE-2014-1587/CVE-2014-1588
(bmo#1042567, bmo#1072847, bmo#1079729, bmo#1080312,
bmo#1089207, bmo#1013001, bmo#1023158, bmo#1026037,
bmo#1037830, bmo#1048517, bmo#1064835, bmo#1073577,
bmo#1075546, bmo#1077687, bmo#1086842, bmo#1096026)
Miscellaneous memory safety hazards (rv:34.0 / rv:31.3)
* MFSA 2014-85/CVE-2014-1590
(bmo#1087633)
XMLHttpRequest crashes with some input streams
* MFSA 2014-87/CVE-2014-1592
(bmo#1088635)
Use-after-free during HTML5 parsing
* MFSA 2014-88/CVE-2014-1593
(bmo#1085175)
Buffer overflow while parsing media content
* MFSA 2014-89/CVE-2014-1594
(bmo#1074280)
Bad casting from the BasicThebesLayer to BasicContainerLayer
- removing merged patch disabling SSLv3 by default

* Fre Nov 14 2014 pcerny@suse.com
- disable firefox-multilocale-chrome.patch causing build
breakages on SLE11 and SLE10 (bnc#905528)

aabdelkhalek
27-Dec-2014, 00:43
I'm able to play your video without any flash player plugin. You need:

1.) SLED11 Service Pack 3 or SLED12.

2.) GStreamer-Plugins -> Fluendo One Play Codec Pack -> http://eu.fluendo.com
SLED11SP3: GStreamer v0.10 -> "Linux generic" (read Readme.txt)
SLED12: GStreamer v1.00 -> "Linux RPM"

3.) Only SLED11: Firefox ESR 31 with SUSE-Patch 7776. SUSE-Patch 7776 is not public available.
Ask SUSE Linux Enterprise Hotline (http://www.suse.com -> Support) for this patch.
SLED12 don't need SUSE-Patch 7776.

# rpm -q MozillaFirefox
MozillaFirefox-31.3.0esr-0.8.1.7776.5.PTF.906111

# rpm -q --changelog MozillaFirefox |more
* Die Dez 16 2014 stokos@suse.de
- build with gstreamer-0_10
(bnc#906111)

* Mit Dez 03 2014 pcerny@suse.com
- update to Firefox 31.3.0 ESR (bnc#908009)
* MFSA 2014-83/CVE-2014-1587/CVE-2014-1588
(bmo#1042567, bmo#1072847, bmo#1079729, bmo#1080312,
bmo#1089207, bmo#1013001, bmo#1023158, bmo#1026037,
bmo#1037830, bmo#1048517, bmo#1064835, bmo#1073577,
bmo#1075546, bmo#1077687, bmo#1086842, bmo#1096026)
Miscellaneous memory safety hazards (rv:34.0 / rv:31.3)
* MFSA 2014-85/CVE-2014-1590
(bmo#1087633)
XMLHttpRequest crashes with some input streams
* MFSA 2014-87/CVE-2014-1592
(bmo#1088635)
Use-after-free during HTML5 parsing
* MFSA 2014-88/CVE-2014-1593
(bmo#1085175)
Buffer overflow while parsing media content
* MFSA 2014-89/CVE-2014-1594
(bmo#1074280)
Bad casting from the BasicThebesLayer to BasicContainerLayer
- removing merged patch disabling SSLv3 by default

* Fre Nov 14 2014 pcerny@suse.com
- disable firefox-multilocale-chrome.patch causing build
breakages on SLE11 and SLE10 (bnc#905528)

Hi,

I have SLED 11 SP3 so I checked the version of GStreamer I have and below is the output of zypper and the fludendo mp3 package is installed. Yet, I miss the licensed fludendo ONEPLAY codec pack, right?



# zypper se GStreamer
Refreshing service 'nu_novell_com'.
Loading repository data...
Reading installed packages...

S | Name | Summary | Type
--+------------------------------------+----------------------------+-----------
i | PackageKit-gstreamer-plugin | Simple software installa-> | package
i | banshee-1-backend-engine-gstreamer | GStreamer engine support-> | package
i | bluez-gstreamer | Bluetooth Sound Support | package
| gstreamer-0_10 | Streaming-Media Framewor-> | srcpackage
i | gstreamer-0_10 | Streaming-Media Framewor-> | package
| gstreamer-0_10-32bit | Streaming-Media Framewor-> | package
i | gstreamer-0_10-devel | Include Files and Librar-> | package
| gstreamer-0_10-doc | Streaming-Media Framewor-> | package
| gstreamer-0_10-doc | Streaming-Media Framewor-> | srcpackage
i | gstreamer-0_10-fluendo-mp3 | Gstreamer mp3 plugin fro-> | package
i | gstreamer-0_10-lang | Languages for package gs-> | package
i | gstreamer-0_10-plugins-bad | GStreamer Streaming-Medi-> | package
i | gstreamer-0_10-plugins-bad-lang | Languages for package gs-> | package
| gstreamer-0_10-plugins-base | GStreamer Streaming-Medi-> | srcpackage
i | gstreamer-0_10-plugins-base | GStreamer Streaming-Medi-> | package
| gstreamer-0_10-plugins-base-32bit | GStreamer Streaming-Medi-> | package
i | gstreamer-0_10-plugins-base-devel | Include files and librar-> | package
i | gstreamer-0_10-plugins-base-lang | Languages for package gs-> | package
i | gstreamer-0_10-plugins-farsight | Gstreamer plugins for fa-> | package
| gstreamer-0_10-plugins-farsight | Gstreamer plugins for fa-> | srcpackage
i | gstreamer-0_10-plugins-good | GStreamer Streaming-Medi-> | package
| gstreamer-0_10-plugins-good | GStreamer Streaming-Medi-> | srcpackage
i | gstreamer-0_10-plugins-good-lang | Languages for package gs-> | package
i | gstreamer-0_10-plugins-v4l | GStreamer Streaming-Medi-> | package
| gstreamer-0_10-plugins-v4l | GStreamer Streaming-Medi-> | srcpackage
i | gstreamer-0_10-utils | Streaming-Media Framewor-> | package
i | gstreamer-utils | Streaming-Media Framewor-> | package
i | libgstreamer-0_10-0 | Streaming-Media Framewor-> | package
i | libgstreamer-0_10-0-32bit | Streaming-Media Framewor-> | package
i | phonon-backend-gstreamer-0_10 | Phonon Multimedia Platfo-> | package
i | python-gstreamer-0_10 | Python Bindings for GStr-> | package
| python-gstreamer-0_10 | Python Bindings for GStr-> | srcpackage
i | sledsp3-gstreamer-plugins | Recommended update for G-> | patch
linux-moati:/home/aabdelkhalek # zypper se fluendo
Refreshing service 'nu_novell_com'.
Loading repository data...
Reading installed packages...

S | Name | Summary | Type
--+----------------------------+-----------------------------------+--------
i | gstreamer-0_10-fluendo-mp3 | Gstreamer mp3 plugin from Fluendo | package
# rpm -q MozillaFirefox
MozillaFirefox-31.3.0esr-0.8.1
#


Then MozillaFirefox is 31.3.0esr-0.8.1 so I also miss that patch? But how to order that one, When I checked my account on SUSE customer center - support, it says "You are not currently entitled to use the support system. "!

Thanks,
Ahmed

AndreasMeyer
27-Dec-2014, 10:35
gstreamer-0_10-fluendo-mp3 is a GStreamer-Plugin. gstreamer-0_10-fluendo-mp3 is a MP3 Audio Decoder for GStreamer and part of each SLED. Gstreamer-0_10-fluendo-mp3 allows you to play *.mp3 with Banshee and Totem. Totem and Banshee can use GStreamer. Banshee and Totem has GStreamer support. Original Linux Firefox ESR 31 has GStreamer support. Official SLED11-Firefox don't support GStreamer. Try it out:

Original Linux Firefox ESR 31
---------------------------------
1.) Take the Firefox ESR-*.tar.bz2 from http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/31.3.0esr/
2.) Unpack the Firefox ESR-*.tar.bz2 to /tmp
3.) Deinstall Flash Player Plugin: # zypper remove flash-player
4.) Start original Firefox: # /tmp/firefox/firefox
5.) Open HTML5 Audio Test Page: http://www.russianlessons.net/audio/audio-test.php
6.) Audio Test 1 -> second audio example -> context menu (right mouse button) -> Audio Save as "masha-1.mp3" -> Firefox support GStreamer -> Fine
7.) Close original Firefox


Official SLED11-Firefox ESR 31
---------------------------------
8.) Start SLED-Firefox: # /usr/bin/firefox
9.) Open HTML5 Audio Test Page: http://www.russianlessons.net/audio/audio-test.php
10.) Audio Test 1 -> second audio example -> context menu (right mouse button) -> Audio Save as "*.ogg" -> Firefox GStreamer don't support GStreamer -> Bad.


Patched SLED-Firefox ESR 31
----------------------------------
With SLED11 and SUSE-Patch 7776 or SLED12 (no patch necessary):

8.) Start SLED-Firefox: # /usr/bin/firefox
9.) Open HTML5 Audio Test Page: http://www.russianlessons.net/audio/audio-test.php
10.) Audio Test 1 -> second audio example -> context menu (right mouse button) -> Audio Save as "masha-1.mp3" -> Firefox support GStreamer -> Fine


You need a Standard or Priority Subscription to receive SUSE-Patch 7776:
https://www.suse.com/products/desktop/how-to-buy/


ONEPLAY Codec Pack has some GStreamer-Plugins for many Audio and Video Codecs:

Windows Media Audio Decoder
Windows Media Video Decoder
Windows Media ASF Demuxer
Windows Media MMS Networking
MPEG2 Video Decoder
MPEG4 Part 2 Video Decoder
DivX 3.11 Alpha ;-) Video Decoder
H.264/AVC Video Decoder
MPEG2 Program Stream und Transport Stream demuxer
MPEG4 ISO Demuxer
MP3 Audio Decoder (allready included in gstreamer-0_10-fluendo-mp3)
AAC Audio Decoder
LPCM Audio Decoder
AC3 Audio Decoder (Dolby Digital) for Totem Media Player only
iLBC Audio Decoder
ADPCM Audio Decoder

aabdelkhalek
29-Dec-2014, 14:39
Thanks for the elaborative answer.

To conclude, I need to buy the ONEPLAY codec pack and at least standard subscription to get the firefox ESR patch.

I guess I will just have to live without these videos :)

Anyway, thanks a lot for your help and time

Regards,
Ahmed

AndreasMeyer
08-Feb-2015, 00:13
SUSE-Patch 7776 is included in official SLED11-Firefox ESR 31.4.0 and above:

# rpm -q --changelog MozillaFirefox |more
* Mit Jan 14 2015 pcerny@suse.com
- update to Firefox 31.4.0 ESR (bsc#910669)
* MFSA 2015-01/CVE-2014-8634/CVE-2014-8635
(bmo#1109889, bmo#1111737, bmo#1026774, bmo#1027300,
bmo#1054538, bmo#1067473, bmo#1070962, bmo#1072130,
bmo#1072871, bmo#1098583)
Miscellaneous memory safety hazards (rv:35.0 / rv:31.4)
* MFSA 2015-03/CVE-2014-8638
(bmo#1080987)
sendBeacon requests lack an Origin header
* MFSA 2015-04/CVE-2014-8639
(bmo#1095859)
Cookie injection through Proxy Authenticate responses
* MFSA 2015-06/CVE-2014-8641
(bmo#1108455)
Read-after-free in WebRTC
- fix broken install scripts in some locales (bsc#909563)
- enable gstreamer (bsc#906111)

* Mit Dez 03 2014 pcerny@suse.com
- update to Firefox 31.3.0 ESR (bnc#908009)

You need to buy the ONEPLAY codec pack and at least basic subscription to get the official SLED11-Firefox ESR 31.4.0.