PDA

View Full Version : Upgrade from SUSE11 SP1 to SP3



dmiller
29-Sep-2014, 13:03
I hate to upgrade or patch SUSE products because I have always failed. I always get tons of dependancy errors and given a list of options on how to resolve a file conflict issue. How do I upgrade fro Suse Enterprise Server 11 SP1 to SP3? I have never tried an SP upgrade have always failed on things like PHP updates and such. Now the state says I have to upgrade all servers even if they are not on the internet.

Thanks
Dave.

mikewillis
29-Sep-2014, 13:18
I hate to upgrade or patch SUSE products because I have always failed. I always get tons of dependancy errors and given a list of options on how to resolve a file conflict issue. How do I upgrade fro Suse Enterprise Server 11 SP1 to SP3? I have never tried an SP upgrade have always failed on things like PHP updates and such. Now the state says I have to upgrade all servers even if they are not on the internet.

You can't update direct from SP1 to SP3, you have to go via SP2.
https://www.suse.com/documentation/sles11/book_sle_deployment/data/sec_update_proc_prep_paths.html

Assuming you haven't installed any third party packages, you shouldn't get any dependency errors yet alone 'tons'. If you've installed third party packages you have to be prepared to deal with possible dependency issues they may cause when you try to update SLES packages. You mention PHP as a cause of update failure, have you installed third party PHP packages?

dmiller
29-Sep-2014, 15:53
The only PHP I have installed is on the install disk. And did the update through yast.
I'll give it a shot Friday evening after classes.

Thans
Dave.

dmiller
03-Oct-2014, 15:23
Ok. I tried using yast and online update. And I am getting ruby update errors from the very beginning. It gives me to options of
1. following actions will be done,
2. do not install patch slessp1-ruby-
3. break ruby-devle by ignoring some of its dependencies.

I included a snap shot of the windows.

Am I doing this wrong is there a different way I should be doing the updates of the Support Packs?

91

mikewillis
03-Oct-2014, 16:47
Ok. I tried using yast and online update. And I am getting ruby update errors from the very beginning. It gives me to options of
1. following actions will be done,
2. do not install patch slessp1-ruby-
3. break ruby-devle by ignoring some of its dependencies.

I included a snap shot of the windows.

Am I doing this wrong is there a different way I should be doing the updates of the Support Packs?

91

So the screenshot mentions ruby-devel-1.8.7.p72-5.24.2.x86_64.rpm and that is in the SLE 11 SDK SP1 Pool repo. So it's the version of ruby-devel that's on the SLE 11 SDK SP1 DVD which means, you've never installed any update for ruby-devel from the SDK. ruby-1.8.7.p72-5.24.2.x86_64.rpm that YaST is failing to install is in the SLES 11 SP1 Pool repo, which makes me wonder how you got ruby-devel installed.

One of the first steps in updating to SP2 is "Make sure the currently installed version has the latest patches". Is this the point at which you're getting problems? I.e you haven't added SP2 repos yet, you're just trying to get all the SP1 updates installed?

Can you post the output of


$ zypper lr -u
$ zypper verify
Wrap it in CODE tags for readability. (look for the # button on the toolbar when posting)

bbendily
07-Oct-2014, 15:53
Also, (i don't know the exact steps with the SDK, but) I think you need to add the SP2-SDK up front, before trying to upgrade/patch, from SP1-SP2.
Then add SP3-SDK before going sp2-sp3. I think you may have installed Ruby from the SDK and when you upgrade it registers with the SMT server and
adds the SP2 Repos automatically, but doesn't add the SP2-SDK automatically. You have to do that manually.
Rubygems definitely comes from the SDK. You could remove all the SDK repos. Upgrade and choose "break ruby-devel" then after you've upgrade, add the SDK repos and
fully patch again. That should fix it. "ruby-devel" definitely comes from the SDK as well.
You can use -s when you search with zypper to see which repo the package comes from:
zypper se -s ruby