PDA

View Full Version : SLES12 no postgresql93-libs or openssl-devel packages



ravenet
28-Oct-2014, 22:56
Installed a new SLES12 and discovered there is no postgresql93-libs package, but there is an included postgresql93-libs source included. Attempt to build postgresql93-libs from the source and it complains it has no available openssl-devel package.Checked the other SLES12 media on their new Modules and cannot find on those either.

malcolmlewis
29-Oct-2014, 05:09
Hi
During the install did you select to add the SDK? If not, check on SCC (https://scc.suse.com) for the new url's and add manually via YaST Software Repositories.


Repository: SLE-SDK12-Pool
Name: postgresql93-devel
Version: 9.3.5-2.3

mainadmin
29-Oct-2014, 18:31
Hi
During the install did you select to add the SDK? If not, check on SCC (https://scc.suse.com) for the new url's and add manually via YaST Software Repositories.


Repository: SLE-SDK12-Pool
Name: postgresql93-devel
Version: 9.3.5-2.3


No, I did not, and am unsure as to why we should be installing the SDK to work with Devel packages in order to get the postgresql93-libs package, shouldn't postgresql93-libs be include in the base media of sles12 the way postgresql-libs was included in sles11?

malcolmlewis
29-Oct-2014, 18:39
No, I did not, and am unsure as to why we should be installing the SDK to work with Devel packages in order to get the postgresql93-libs package, shouldn't postgresql93-libs be include in the base media of sles12 the way postgresql-libs was included in sles11?
Hi
All devel packages have moved to the SDK, so anything (like libopenssl-devel) is here. I only have a SLED 12 system at present, there are only postgresql93 and postgresql93-devel, no libs package?

heinkonijn
29-Oct-2014, 22:12
I checked on sles11.
I see package postgresql91-libs, this is a srcpackage.

On the second SLES12 DVD there is /suse/src/postgresql93-libs-9.3.5-2.3.src.rpm



Hi
All devel packages have moved to the SDK, so anything (like libopenssl-devel) is here. I only have a SLED 12 system at present, there are only postgresql93 and postgresql93-devel, no libs package?

malcolmlewis
29-Oct-2014, 22:35
On Wed 29 Oct 2014 09:14:02 PM CDT, heinkonijn wrote:


I checked on sles11.
I see package postgresql91-libs, this is a srcpackage.

On the second SLES12 DVD there is
/suse/src/postgresql93-libs-9.3.5-2.3.src.rpm


malcolmlewis;24454 Wrote:
> Hi
> All devel packages have moved to the SDK, so anything (like
> libopenssl-devel) is here. I only have a SLED 12 system at present,
> there are only postgresql93 and postgresql93-devel, no libs package?




Hi
Which will produce postgresql93 and postgresql93-devel, there is no
libs suffix.

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.28-4-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!