PDA

View Full Version : mkv problem



albumns
16-Sep-2011, 11:56
Hello:
I've installed mplayer and related codecs from mplayer webisite. And
I found that the .mkv files cannot well played:

the sound is OK, but the picture is very slow and it lag behind too
much behind sound.

I also installed VLC player in my computer and related codecs, but the
case is reverse comparing to mplayer:

the picture is OK, but there is no sound and subtitle.....

can you give me advices?

THX


--
albumns
------------------------------------------------------------------------
albumns's Profile: http://forums.novell.com/member.php?userid=48883
View this thread: http://forums.novell.com/showthread.php?t=444803

mikewillis
16-Sep-2011, 13:36
If VLC doesn't produce sound maybe it doesn't have the required audio
codec. mkv is container, it can contain streams encoded with various
codecs.

The method I use for adding codec support to SLED without installing
third party applications like VLC or MPlayer or replacing all your
gstreamer packages with ones from packman is written up at 'Additional
multimedia codec support for SLED 11 SP1 | Novell User Communities'
(http://www.novell.com/communities/node/13146/additional-multimedia-codec-support-sled-11-sp1)

Whether that will give you the necessary codecs to play these mkv files
I couldn't say. If you can put one of the files somewhere I can download
it, I'll try playing it.


--
mikewillis
------------------------------------------------------------------------
mikewillis's Profile: http://forums.novell.com/member.php?userid=7510
View this thread: http://forums.novell.com/showthread.php?t=444803