PDA

View Full Version : disable transparent_hugepage in grub.conf for SLES 12



merlin128
03-Nov-2014, 19:55
on sles 11 I would edit /etc/grub.conf and add transparent_hugepage=never
but on SLES 12 that file does not exist..

I have tried :
grub2-editenv set transparent_hugepage=never (says its not a option)

I have tried adding to the following files and then running: grub2-mkconfig -o /boot/grub2/grub.cfg
gedit /etc/grub.d/90_persistent
gedit /etc/default/grub

and I have tried creating /etc/rc.local

nothing I have tried works, 'cat sys/kernel/mm/transparent_hugepage/enabled' still shows always

malcolmlewis
03-Nov-2014, 20:11
Hi
Use YaST -> System -> Bootloader and add the entry into the kernel options.

merlin128
03-Nov-2014, 20:13
nevermind, figured out it works if I put it in /etc/init.d/after.local:

added lines:
if test -f /sys/kernel/mm/transparent_hugepage/enabled; then
echo never > /sys/kernel/mm/transparent_hugepage/enabled
fi
if test -f /sys/kernel/mm/transparent_hugepage/defrag; then
echo never > /sys/kernel/mm/transparent_hugepage/defrag
fi

merlin128
05-Nov-2014, 06:07
Hi
Use YaST -> System -> Bootloader and add the entry into the kernel options.

Thanks, I made the change to the kernel optional parameters and that worked great..