PDA

View Full Version : Network card not detected after installation



titaniark
02-Feb-2012, 11:26
Hi

I have installed a Linux SUSE Enterprise 10 Server. After the
installation and connecting the machine to the network, the network card
does not seem to be detected. The hardware was checked and it seems to
be working fine as the network card is detected at the BIOS level but
not at the OS level.
Please assist asap, what can be done to resolve this issue?

Thanks.


--
titaniark
------------------------------------------------------------------------
titaniark's Profile: http://forums.novell.com/member.php?userid=123303
View this thread: http://forums.novell.com/showthread.php?t=451696

malcolmlewis
02-Feb-2012, 15:38
On Thu, 02 Feb 2012 10:26:02 GMT
titaniark <titaniark@no-mx.forums.novell.com> wrote:

>
> Hi
>
> I have installed a Linux SUSE Enterprise 10 Server. After the
> installation and connecting the machine to the network, the network
> card does not seem to be detected. The hardware was checked and it
> seems to be working fine as the network card is detected at the BIOS
> level but not at the OS level.
> Please assist asap, what can be done to resolve this issue?
>
> Thanks.
>
>
Hi
The kernel doesn't have the device driver.... What hardware and NIC?


lspci -nnk

And post the output for your card.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.9-1.4-desktop
up 1 day 10:48, 3 users, load average: 0.04, 0.06, 0.20
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

titaniark
03-Feb-2012, 04:56
Its IBM x3250 M3 (machine type 4252) and NIC is Intel.

CDGBELSIZEAPP:~ # lspci -nn
00:00.0 Host bridge [Class 0600]: Intel Corporation Unknown device
[8086:d130] (rev 11)00:03.0 PCI bridge [Class 0604]: Intel Corporation
Unknown device [8086:d138] (rev 11)00:05.0 PCI bridge [Class 0604]:
Intel Corporation Unknown device [8086:d13a] (rev 11)00:08.0 System
peripheral [Class 0880]: Intel Corporation Unknown device [8086:d155]
(rev 11)00:08.1 System peripheral [Class 0880]: Intel Corporation
Unknown device [8086:d156] (rev 11)00:08.2 System peripheral [Class
0880]: Intel Corporation Unknown device [8086:d157] (rev 11)00:08.3
System peripheral [Class 0880]: Intel Corporation Unknown device
[8086:d158] (rev 11)00:10.0 System peripheral [Class 0880]: Intel
Corporation Unknown device [8086:d150] (rev 11)00:10.1 System peripheral
[Class 0880]: Intel Corporation Unknown device [8086:d151] (rev
11)00:1a.0 USB Controller [Class 0c03]: Intel Corporation Unknown device
[8086:3b3c] (rev 05)00:1c.0 PCI bridge [Class 0604]: Intel Corporation
Unknown device [8086:3b42] (rev 05)00:1c.4 PCI bridge [Class 0604]:
Intel Corporation Unknown device [8086:3b4a] (rev 05)00:1c.5 PCI bridge
[Class 0604]: Intel Corporation Unknown device [8086:3b4c] (rev
05)00:1c.6 PCI bridge [Class 0604]: Intel Corporation Unknown device
[8086:3b4e] (rev 05)00:1c.7 PCI bridge [Class 0604]: Intel Corporation
Unknown device [8086:3b50] (rev 05)00:1d.0 USB Controller [Class 0c03]:
Intel Corporation Unknown device [8086:3b34] (rev 05)00:1e.0 PCI bridge
[Class 0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev a5)
00:1f.0 ISA bridge [Class 0601]: Intel Corporation Unknown device
[8086:3b14] (rev 05)00:1f.2 IDE interface [Class 0101]: Intel
Corporation Unknown device [8086:3b20] (rev 05)00:1f.3 SMBus [Class
0c05]: Intel Corporation Unknown device [8086:3b30] (rev 05)00:1f.5 IDE
interface [Class 0101]: Intel Corporation Unknown device [8086:3b26]
(rev 05)01:00.0 SCSI storage controller [Class 0100]: LSI Logic /
Symbios Logic SAS1064E PCI-Express Fusion-MPT SAS [1000:0056] (rev
08)06:00.0 PCI bridge [Class 0604]: Vitesse Semiconductor Unknown device
[101b:0452] (rev 01)07:00.0 VGA compatible controller [Class 0300]:
Matrox Graphics, Inc. Unknown device [102b:0530]0b:00.0 Ethernet
controller [Class 0200]: Intel Corporation Unknown device
[8086:10d3]15:00.0 Ethernet controller [Class 0200]: Intel Corporation
Unknown device [8086:10d3]CDGBELSIZEAPP:~ #


--
titaniark
------------------------------------------------------------------------
titaniark's Profile: http://forums.novell.com/member.php?userid=123303
View this thread: http://forums.novell.com/showthread.php?t=451696

malcolmlewis
03-Feb-2012, 05:40
On Fri, 03 Feb 2012 03:56:08 GMT
titaniark <titaniark@no-mx.forums.novell.com> wrote:

>
> Its IBM x3250 M3 (machine type 4252) and NIC is Intel.
>
> 0b:00.0 Ethernet controller [Class 0200]: Intel Corporation Unknown
> device [8086:10d3]
> 15:00.0 Ethernet controller [Class 0200]: Intel Corporation Unknown
> device [8086:10d3]
>
Hi
The driver you need is the Intel e1000e which I don't think is in
that kernel.... it's there for SLE 11 SP1.



/sbin/modinfo e1000e


You would need to compile the driver downloaded from here;
http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=3025&DwnldID=15817&ProductFamily=Network+Connectivity&ProductLine=Intel%C2%AE+Desktop+Adapters&ProductProduct=Intel%C2%AE+Gigabit+CT+Desktop+Adap tereng

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.9-1.4-desktop
up 6:30, 5 users, load average: 0.00, 0.03, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

titaniark
03-Feb-2012, 06:26
Hi,

How do we compile the driver? And how to install it? Appreciate
detailed instructions as we are not experts.
Thanks.


--
titaniark
------------------------------------------------------------------------
titaniark's Profile: http://forums.novell.com/member.php?userid=123303
View this thread: http://forums.novell.com/showthread.php?t=451696

malcolmlewis
03-Feb-2012, 06:46
On Fri, 03 Feb 2012 05:26:02 GMT
titaniark <titaniark@no-mx.forums.novell.com> wrote:

>
> Hi,
>
> How do we compile the driver? And how to install it? Appreciate
> detailed instructions as we are not experts.
> Thanks.
>
>
Hi
Your lucky, looks like a user has already built it on the Open Build
Service;
http://software.opensuse.org/search?q=e1000e&baseproject=SUSE%3ASLE-10%3ASDK&lang=en&include_home=true&exclude_debug=true

You need to check the output from the command;


uname -a

And grab the correct kernel flavor and also kernel release matches
those available. Else you would need to download a src rpm and rebuild
that on your system.

If you post the output from the above command I can verify for you.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.9-1.4-desktop
up 7:40, 5 users, load average: 0.08, 0.07, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

titaniark
03-Feb-2012, 07:06
Hi,

The output for uname -a is

CDGBELSIZEAPP:~/Desktop/20120203/e1000e-1.9.5/src # uname -a
Linux CDGBELSIZEAPP 2.6.16.46-0.12-bigsmp #1 SMP Thu May 17 14:00:09
UTC 2007 i686 i686 i386 GNU/Linux


--
titaniark
------------------------------------------------------------------------
titaniark's Profile: http://forums.novell.com/member.php?userid=123303
View this thread: http://forums.novell.com/showthread.php?t=451696

malcolmlewis
03-Feb-2012, 07:19
On Fri, 03 Feb 2012 06:06:02 GMT
titaniark <titaniark@no-mx.forums.novell.com> wrote:

>
> Hi,
>
> The output for uname -a is
>
> CDGBELSIZEAPP:~/Desktop/20120203/e1000e-1.9.5/src # uname -a
> Linux CDGBELSIZEAPP 2.6.16.46-0.12-bigsmp #1 SMP Thu May 17 14:00:09
> UTC 2007 i686 i686 i386 GNU/Linux
>
>
Hi
The very first one in the list: intel-e1000e-kmp-bigsmp, download and
install via;


rpm -Uhv intel-e1000e-kmp-bigsmp-1.9.5_2.6.16.46_0.12-1.2.i586.rpm

You probably need to reboot and the module should load up.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.9-1.4-desktop
up 8:14, 5 users, load average: 0.06, 0.08, 0.11
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

titaniark
03-Feb-2012, 07:46
Hi,

We tried and there are some error

CDGBELSIZEAPP:~ # cd /root/Desktop/20120203
CDGBELSIZEAPP:~/Desktop/20120203 # rpm -Uhv
intel-e1000e-kmp-bigsmp-1.9.5_2.6.16.46_0.12-1.2.i586.rpm
warning: intel-e1000e-kmp-bigsmp-1.9.5_2.6.16.46_0.12-1.2.i586.rpm:
Header V3 DSA signature: NOKEY, key ID abde7ce2
error: Failed dependencies:
intel-e1000e is needed by
intel-e1000e-kmp-bigsmp-1.9.5_2.6.16.46_0.12-1.2.i586
CDGBELSIZEAPP:~/Desktop/20120203 #


--
titaniark
------------------------------------------------------------------------
titaniark's Profile: http://forums.novell.com/member.php?userid=123303
View this thread: http://forums.novell.com/showthread.php?t=451696

malcolmlewis
03-Feb-2012, 14:00
On Fri, 03 Feb 2012 06:46:01 GMT
titaniark <titaniark@no-mx.forums.novell.com> wrote:

>
> Hi,
>
> We tried and there are some error
>
> CDGBELSIZEAPP:~ # cd /root/Desktop/20120203
> CDGBELSIZEAPP:~/Desktop/20120203 # rpm -Uhv
> intel-e1000e-kmp-bigsmp-1.9.5_2.6.16.46_0.12-1.2.i586.rpm
> warning: intel-e1000e-kmp-bigsmp-1.9.5_2.6.16.46_0.12-1.2.i586.rpm:
> Header V3 DSA signature: NOKEY, key ID abde7ce2
> error: Failed dependencies:
> intel-e1000e is needed by
> intel-e1000e-kmp-bigsmp-1.9.5_2.6.16.46_0.12-1.2.i586
> CDGBELSIZEAPP:~/Desktop/20120203 #
>

Hi
Grab the last one in the list ;) Then ensure they are both in the same
download location then;


rpm -Uhv e1000e*


--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.9-1.4-desktop
up 14:55, 5 users, load average: 0.16, 0.06, 0.06
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

titaniark
07-Feb-2012, 02:30
Hi,

It seems okay after I did the followings:

1) Install kernel source and kernel syms
2) Install gcc, gcc++ from yast (software mgt)
3) Download and extract e1000e-1.9.5.tar.gz
4) cd to the above folder ...../src then make install
5) Go to network card and edit ethernet controller

malcolmlewis
07-Feb-2012, 03:55
On Tue, 07 Feb 2012 01:34:05 GMT
titaniark <titaniark@no-mx.forums.suse.com> wrote:

>
> Hi,
>
> It seems okay after I did the followings:
>
> 1) Install kernel source and kernel syms
> 2) Install gcc, gcc++ from yast (software mgt)
> 3) Download and extract e1000e-1.9.5.tar.gz
> 4) cd to the above folder ...../src then make install
> 5) Go to network card and edit ethernet controller
>
>
Hi
Just remember if the kernel updates you will need to do it again, if
you use the rpm method it will drop the module into an area called weak
updates and keep working until you rebuild/re-install the rpm.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.9-1.4-desktop
up 2 days 6:28, 6 users, load average: 0.00, 0.06, 0.10
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

titaniark
07-Feb-2012, 06:54
Hi,

In what cases will the kernel updates? Will reboot or shutdown and startup update the kernel?

Simon Flood
07-Feb-2012, 13:59
On 07/02/2012 06:04, titaniark wrote:

> In what cases will the kernel updates? Will reboot or shutdown and
> startup update the kernel?

The process of rebooting or shutting down and then restarting will not
in itself update the kernel but it will use a newer kernel if it has
been updated since last reboot/restart.

HTH.
--
Simon
Novell/SUSE/NetIQ Knowledge Partner

------------------------------------------------------------------------
Do you work with Novell technologies at a university, college or school?
If so, your campus could benefit from joining the Novell Technology
Transfer Partner (TTP) program. See novell.com/ttp for more details.
------------------------------------------------------------------------

titaniark
08-Feb-2012, 06:24
Hi,

If there is newer kernel, it will be shown at the Software Updater?
If so, will it auto update those items in the Software Updater?

veerus_b
28-Dec-2012, 03:38
Hi ,
I am also facing the same issue with Network driver, could you suggest me the driver . I am putting the lspci out put here.

00:00.0 Host bridge [0600]: Intel Corporation Auburndale/Havendale DRAM Controller [8086:0040] (rev 02)
00:02.0 VGA compatible controller [0300]: Intel Corporation Auburndale/Havendale Integrated Graphics Controller [8086:0042] (rev 02)
00:16.0 Communication controller [0780]: Intel Corporation Ibex Peak HECI Controller [8086:3b64] (rev 06)
00:16.2 IDE interface [0101]: Intel Corporation Ibex Peak PT IDER Controller [8086:3b66] (rev 06)
Kernel modules: ide-pci-generic, ata_generic, pata_acpi
00:16.3 Serial controller [0700]: Intel Corporation Ibex Peak KT Controller [8086:3b67] (rev 06)
Kernel driver in use: serial
00:19.0 Ethernet controller [0200]: Intel Corporation Device [8086:10f0] (rev 06)
00:1a.0 USB Controller [0c03]: Intel Corporation Ibex Peak USB2 Enhanced Host Controller [8086:3b3c] (rev 06)
Kernel driver in use: ehci_hcd
Kernel modules: ehci-hcd
00:1b.0 Audio device [0403]: Intel Corporation Ibex Peak High Definition Audio [8086:3b56] (rev 06)
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel
00:1d.0 USB Controller [0c03]: Intel Corporation Ibex Peak USB2 Enhanced Host Controller [8086:3b34] (rev 06)
Kernel driver in use: ehci_hcd
Kernel modules: ehci-hcd
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev a6)
00:1f.0 ISA bridge [0601]: Intel Corporation Ibex Peak LPC Interface Controller [8086:3b06] (rev 06)
00:1f.2 IDE interface [0101]: Intel Corporation Ibex Peak 4 port SATA IDE Controller [8086:3b20] (rev 06)
Kernel driver in use: ata_piix
Kernel modules: ide-pci-generic, ata_generic, pata_acpi, ata_piix
00:1f.3 SMBus [0c05]: Intel Corporation Ibex Peak SMBus Controller [8086:3b30] (rev 06)
Kernel driver in use: i801_smbus
Kernel modules: i2c-i801
00:1f.5 IDE interface [0101]: Intel Corporation Ibex Peak 2 port SATA IDE Controller [8086:3b26] (rev 06)
Kernel driver in use: ata_piix
Kernel modules: ide-pci-generic, ata_generic, pata_acpi, ata_piix
Thanks
Veer

malcolmlewis
28-Dec-2012, 05:44
On Fri 28 Dec 2012 02:44:01 AM CST, veerus b wrote:


Hi ,
I am also facing the same issue with Network driver, could you suggest
me the driver . I am putting the lspci out put here.


00:19.0 Ethernet controller [0200]: Intel Corporation Device [8086:10f0] (rev 06)


Thanks
Veer


Hi
What version of SLE and kernel, please post the output from the
following commands;



cat /etc/SuSE-release
uname -a


The device is;


vendor: 8086 ("Intel Corporation"), device: 10ef ("82578DM Gigabit Network Connection")

So it's the e1000e module.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 5:28, 3 users, load average: 0.20, 0.12, 0.07
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

veerus_b
28-Dec-2012, 06:58
Here is the output for kernel and release.


linux-n65g:~/Desktop # cat /etc/SuSE-release
SUSE Linux Enterprise Server 11 (x86_64)
VERSION = 11
PATCHLEVEL = 0
linux-n65g:~/Desktop # uname -a
Linux linux-n65g 2.6.27.19-5-default #1 SMP 2009-02-28 04:40:21 +0100 x86_64 x86_64 x86_64 GNU/Linux


Thanks for your quick reply.
Veerendra B

Hi
What version of SLE and kernel, please post the output from the
following commands;



cat /etc/SuSE-release
uname -a


The device is;


vendor: 8086 ("Intel Corporation"), device: 10ef ("82578DM Gigabit Network Connection")

So it's the e1000e module.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 5:28, 3 users, load average: 0.20, 0.12, 0.07
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

malcolmlewis
28-Dec-2012, 15:32
On Fri 28 Dec 2012 06:04:01 AM CST, veerus b wrote:


Here is the output for kernel and release.


linux-n65g:~/Desktop # cat /etc/SuSE-release
SUSE Linux Enterprise Server 11 (x86_64)
VERSION = 11
PATCHLEVEL = 0
linux-n65g:~/Desktop # uname -a
Linux linux-n65g 2.6.27.19-5-default #1 SMP 2009-02-28 04:40:21 +0100
x86_64 x86_64 x86_64 GNU/Linux


Hi
So did you try the steps in post #11? As in download the driver and
compile?

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 8:27, 3 users, load average: 0.02, 0.05, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

jlivitski
14-Mar-2013, 19:38
I have the same problem:

Intel Corporation Device [8086:1502]
Linux linux 2.6.32.12-0.7-Default #1 SMP

jmozdzen
15-Mar-2013, 15:55
Hi jlivitski,


I have the same problem:

Intel Corporation Device [8086:1502]
Linux linux 2.6.32.12-0.7-Default #1 SMP

and which of the two routes proposed in this thread do you want to follow?

Regards,
Jens

jmozdzen
15-Mar-2013, 16:03
Hi jlivitski,

from the kernel version I assume you're on SLES11SP1.
In SLES11SP2, the proper driver for your card seems to be available already - do you have reason not to upgrade?


# modinfo /lib/modules/3.0.58-0.6.2-default/kernel/drivers/net/e1000e/e1000e.ko
filename: /lib/modules/3.0.58-0.6.2-default/kernel/drivers/net/e1000e/e1000e.ko
version: 1.3.16-k
license: GPL
description: Intel(R) PRO/1000 Network Driver
author: Intel Corporation, <linux.nics@intel.com>
srcversion: 383C8394BFC3CD78867D73C
alias: pci:v00008086d00001503sv*sd*bc*sc*i*
alias: pci:v00008086d00001502sv*sd*bc*sc*i*
...

Regards,
Jens

jlivitski
15-Mar-2013, 23:03
Hi jlivitski,

from the kernel version I assume you're on SLES11SP1.
In SLES11SP2, the proper driver for your card seems to be available already - do you have reason not to upgrade?


# modinfo /lib/modules/3.0.58-0.6.2-default/kernel/drivers/net/e1000e/e1000e.ko
filename: /lib/modules/3.0.58-0.6.2-default/kernel/drivers/net/e1000e/e1000e.ko
version: 1.3.16-k
license: GPL
description: Intel(R) PRO/1000 Network Driver
author: Intel Corporation, <linux.nics@intel.com>
srcversion: 383C8394BFC3CD78867D73C
alias: pci:v00008086d00001503sv*sd*bc*sc*i*
alias: pci:v00008086d00001502sv*sd*bc*sc*i*
...

Regards,
Jens

I am actually running OES 11 on SLES 11 SP1, and I understand no upgrade is available yet.

I had to get the drivers from Intel and install them manually. However, patches will break the driver and necessitate a reinstall. Major pain in the rump.

konecnya
16-Mar-2013, 03:41
In article <jlivitski.5s9l0p@no-mx.forums.suse.com>, Jlivitski wrote:
> I am actually running OES 11 on SLES 11 SP1, and I understand no
> upgrade is available yet.
>
OES 11.sp1 on SLES11.sp2 has been available since late last year.
So you are clear to update.


Andy Konecny
KonecnyConsulting.ca in Toronto
----------------------------------------------------------------------
Andy's Profiles: http://forums.novell.com/member.php?userid=75037
https://forums.suse.com/member.php?2959-konecnya

jlivitski
16-Mar-2013, 14:42
Thanks. I think my whole problem was that, for some reason, the base media package is OES 11/SLES 11 SP1. I had to upgrade immediately. Why doesn't the download media have OES 11 SP1/SLES11 SP2? The latter seems to have the correct driver. If the OES 11 installation media was up to date, I could have avoided a lot of hassle.

KBOYLE
16-Mar-2013, 21:31
jlivitski wrote:

> Why doesn't the download media have OES 11 SP1/SLES11 SP2?

I have asked the folks at the Novell Customer Center why there are no
links to the current release media. I'll update this thread when I hear
back from them.

--
Kevin Boyle - Knowledge Partner
If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...