PDA

View Full Version : No Wi-Fi Network on SLED-12



naren_bishayee
12-Nov-2014, 05:58
Hi All,

I'm using SLED-12 x86_64. Today, when I've started my laptop, I've noticed that System didn't detect any Wi-Fi Network. But Lastday it worked well, and I didn't install/remove any system pacakges.

Currently, If I'll Click 'Select Network' from the wi-fi it says 'no network' Please see the attached Image, but I can turn on/off the wifi. That means the wifi is enabled.

can any one please help me to figure it out.

I've installed the wi-fi driver using 'broadcom-wl-6.30.223.141-3.19.src.rpm' downloaded from the http://packman.links2linux.org/package/broadcom-wl/410485/all Then compiled it & installed it.

Please some one help, it's very very urgent.


94

malcolmlewis
12-Nov-2014, 06:21
Hi
Haven't bumped the wireless key (Fn key) on the system, or does it have a switch?

Is the driver loaded?


/sbin/lspci -nnk |grep -A3 Network

naren_bishayee
12-Nov-2014, 06:36
Hello Malcolm,

yes wifi on-off fn key is present, & it's on.


naren_bishayee@linux-26oq:~> /sbin/lspci -nnk |grep -A3 Network
04:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
Subsystem: Dell Wireless 1397 WLAN Mini-Card [1028:000c]
Kernel driver in use: wl
Kernel modules: ssb, wl
naren_bishayee@linux-26oq:~>

malcolmlewis
12-Nov-2014, 13:00
On Wed 12 Nov 2014 05:44:02 AM CST, naren bishayee wrote:


Hello Malcolm,

yes wifi on-off fn key is present, & it's on.


Kernel modules: ssb, wl


Hi
You need to also blacklist the ssb driver... as in add it
to the /etc/modprobe.d/broadcom-wl-blacklist file.

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.28-4-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

naren_bishayee
15-Nov-2014, 16:19
Hello Malcolm,

I've found one file, 50-broadcom-wl-blacklist.conf, inside '/etc/modprob.d/' directory and the file has bellow lines::


# modules blacklisted for broadcom-wl
blacklist bcm43xx
blacklist ssb
blacklist b43
blacklist ndiswrapper
blacklist brcm80211
blacklist bcma
blacklist brcmsmac


And also note that, my wifi is running, but no network is displaying, which I can connect.

Can you help me

Thanks,

malcolmlewis
15-Nov-2014, 16:34
On Sat 15 Nov 2014 03:24:02 PM CST, naren bishayee wrote:


Hello Malcolm,

I've found one file, 50-broadcom-wl-blacklist.conf, inside
'/etc/modprob.d/' directory and the file has bellow lines::

Code:
--------------------

# modules blacklisted for broadcom-wl
blacklist bcm43xx
blacklist ssb
blacklist b43
blacklist ndiswrapper
blacklist brcm80211
blacklist bcma
blacklist brcmsmac

--------------------


And also note that, my wifi is running, but no network is displaying,
which I can connect.

Can you help me

Thanks,




Hi
Fire up YaST and under Network Devices, check on the 'Global Options'
tab in the 'Network Setup Method' is set to NetworklManager Service.

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.28-4-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

naren_bishayee
15-Nov-2014, 16:56
Hello Malcolm,

I've checked, and yes it's set to NetworklManager Service.

One another thing, I've tried, from the wi-fi settings, Hidden wi-fi network, click the connection dropdown & found previously saved network, then select the one & then click connect, but nothing happen
95.

Thanks,

malcolmlewis
15-Nov-2014, 17:15
Hi
If the ssb module is active then in won't work;

Try;


rmmod -f ssd wl
modprobe wl

naren_bishayee
16-Nov-2014, 01:48
Hello Malcolm,



linux-26oq:~ # rmmod -f ssd wl
rmmod: ERROR: could not remove 'ssd': No such file or directory
rmmod: ERROR: could not remove module ssd: No such file or directory
linux-26oq:~ # modprobe wl
linux-26oq:~ #


Nothing happen, what your thoughts.
I'm using SLED-12 form last 3 weeks, & this is happening from last week.

malcolmlewis
16-Nov-2014, 01:58
On Sun 16 Nov 2014 12:54:02 AM CST, naren bishayee wrote:


Hello Malcolm,


Code:
--------------------

linux-26oq:~ # rmmod -f ssd wl
rmmod: ERROR: could not remove 'ssd': No such file or directory
rmmod: ERROR: could not remove module ssd: No such file or directory
linux-26oq:~ # modprobe wl
linux-26oq:~ #

--------------------


Nothing happen, what your thoughts.
I'm using SLED-12 form last 3 weeks, & this is happening from last week.




Hi
Oops, a typo it should be ssb (playing with SSD's as well today....lol)

An update, maybe with glib or the kernel...

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.28-4-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

naren_bishayee
13-Dec-2014, 13:17
Hello Malcolm,

I've found the bellow information from 'dmesg'


[ 11.723518] wl: module license 'unspecified' taints kernel.
[ 11.723523] Disabling lock debugging due to kernel taint
[ 11.727272] wl: module verification failed: signature and/or required key missing - tainting kernel
[ 11.787758] eth0: Broadcom BCM4315 802.11 Hybrid Wireless Controller 6.30.223.248 (r487574)
.......
[ 13.084575] cfg80211: World regulatory domain updated:
[ 13.084582] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 13.084584] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 13.084586] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 13.084589] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm)
[ 13.084590] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm)
[ 13.084592] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm)
[ 13.084594] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm)
.........
[ 20.774231] ERROR @wl_cfg80211_scan : WLC_SCAN error (-22)
[ 20.774457] ERROR @wl_cfg80211_scan : WLC_SCAN error (-22)
.........
[ 44.130273] ERROR @wl_cfg80211_scan : WLC_SCAN error (-22)
.........
[ 77.138892] ERROR @wl_cfg80211_scan : WLC_SCAN error (-22)
..........


What the meaning of

wl: module license 'unspecified' taints kernel.
AND

wl: module verification failed: signature and/or required key missing - tainting kernel

Is that the reason for not getting any Wi-Fi network on my System?

Thanks

naren_bishayee
13-Dec-2014, 13:29
The 'ifconfig' output


linux-nuaw:~ # ifconfig
eth1 Link encap:Ethernet HWaddr C4:17:FE:D5:42:11
inet6 addr: fe80::c617:feff:fed5:4211/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:308 errors:0 dropped:0 overruns:0 frame:0
TX packets:308 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:23908 (23.3 Kb) TX bytes:23908 (23.3 Kb)

p5p1 Link encap:Ethernet HWaddr 00:26:B9:20:D4:BD
inet addr:192.168.0.100 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::226:b9ff:fe20:d4bd/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:6580 errors:0 dropped:0 overruns:0 frame:0
TX packets:6476 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3526066 (3.3 Mb) TX bytes:924680 (903.0 Kb)



Hello Malcolm,

I've found the bellow information from 'dmesg'


[ 11.723518] wl: module license 'unspecified' taints kernel.
[ 11.723523] Disabling lock debugging due to kernel taint
[ 11.727272] wl: module verification failed: signature and/or required key missing - tainting kernel
[ 11.787758] eth0: Broadcom BCM4315 802.11 Hybrid Wireless Controller 6.30.223.248 (r487574)
.......
[ 13.084575] cfg80211: World regulatory domain updated:
[ 13.084582] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 13.084584] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 13.084586] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 13.084589] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm)
[ 13.084590] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm)
[ 13.084592] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm)
[ 13.084594] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm)
.........
[ 20.774231] ERROR @wl_cfg80211_scan : WLC_SCAN error (-22)
[ 20.774457] ERROR @wl_cfg80211_scan : WLC_SCAN error (-22)
.........
[ 44.130273] ERROR @wl_cfg80211_scan : WLC_SCAN error (-22)
.........
[ 77.138892] ERROR @wl_cfg80211_scan : WLC_SCAN error (-22)
..........


What the meaning of

AND


Is that the reason for not getting any Wi-Fi network on my System?

Thanks