PDA

View Full Version : OpenFOAM 2.3.0 On SLED and missing tools/libraries



acahuzac
20-Nov-2014, 08:39
I am trying to install via rpm or compile the source of OpenFOAM on my newly bought SLED and have some issues.

I worked a lot on Fedora previously and I miss a lot of development tools and libraries. I downloaded and added the "SLE-11-SDK-DVD-x86_64-GM-Media1" iso which is supposed to contain the development tools.

On the OpenFOAM wiki, i followed the "openSuse" instructions as they seemed to be the closest to my case (http://openfoamwiki.net/index.php/Installation/Linux/OpenFOAM-2.3.0/openSUSE).

My first problems aroused when trying to install the prerequired tools :

sudo zypper install -t pattern devel_C_C++
sudo zypper install cmake libqt4-devel qt4-x11-tools qt4-assistant-adp-devel gnuplot openmpi-devel boost-devel gmp-devel mpfr-devel libQtWebKit-devel

C and C++, qt4-assistant-adp-devel and qt4-x11-tools are not found.

While libqt4-devel-4.4.3-12.9.x86_64 (missing libqt4 = 4.4.3) libQtWebKit-devel-4.4.3-12.9.x86_64 (missing libQtWebKit4 = 4.4.3) cannot be installed due to missing libraries.

If I ignore the missing dependencies, OpenFOAM compilation fails.

Thanks for any help !

mikewillis
20-Nov-2014, 09:51
I worked a lot on Fedora previously and I miss a lot of development tools and libraries. I downloaded and added the "SLE-11-SDK-DVD-x86_64-GM-Media1" iso which is supposed to contain the development tools.

You've either got the wrong version of the SDK of you're using SLED 11, support for which has long ended. The currently supported version of SLED is SLED 11 SP3. Which version of SLED are you using? If you're not sure look at the output of

$ cat /etc/*issue*
You need to match the version of the SDK to the version of SLED you're using. You can find SDK downloads at
https://download.suse.com/index.jsp
or check this handy guide
https://forums.suse.com/content.php?121-SUSE-Linux-Enterprise-SDK-downloads





C and C++, qt4-assistant-adp-devel and qt4-x11-tools are not found.

In SLED 11 SP3 the equivalent pattern of openSUSE's devel_C_C++ seems to be sdk_c_c++. A full list of patterns can be obtained with

$ zypper patterns
qt4-assistant-adp-devel and qt4-x11-tools aren't in SLED 11 SP3 or the SLE 11 SP3 SDK. I can't find versions at the openSUSE Build Service either (http://software.opensuse.org/)



While libqt4-devel-4.4.3-12.9.x86_64 (missing libqt4 = 4.4.3) libQtWebKit-devel-4.4.3-12.9.x86_64 (missing libQtWebKit4 = 4.4.3) cannot be installed due to missing libraries.

Possibly due to wrong version of SDK.




If I ignore the missing dependencies, OpenFOAM compilation fails.

That tends to happen ;)

Someone has built openFOAM 2.3 for SLED 12
http://software.opensuse.org/package/openfoam23x
You could ask them about enabling build for SLED 11 SP3, assuming that's what you're using.
https://build.opensuse.org/package/show?project=home%3Adkxls%3Acfd&package=openfoam23x

acahuzac
28-Nov-2014, 17:39
Thank you very much for your quick and precise answer !

My problem was that I used the wrong SDK iso. Now all the libraries get installed.

But... but I still have an issue. The compilation needs cmake 2-8-2 it seems while I only have cmake 2-6-2 installed (and cannot find a more recent one).

mikewillis
28-Nov-2014, 19:40
Thank you very much for your quick and precise answer !

My problem was that I used the wrong SDK iso. Now all the libraries get installed.

But... but I still have an issue. The compilation needs cmake 2-8-2 it seems while I only have cmake 2-6-2 installed (and cannot find a more recent one).


$ cd /tmp
$ wget http://www.cmake.org/files/v2.8/cmake-2.8.12.2.tar.gz
$ tar xf cmake-2.8.12.2.tar.gz
$ cd cmake-2.8.12.2/
$ ./bootstrap --prefix=${HOME}/opt/cmake_2.8.12.2 --parallel=$(grep -c ^processor /proc/cpuinfo) && make -j $(grep -c ^processor /proc/cpuinfo) && make install

Prefix whatever command needs cmake 2.8 with


$ PATH=${HOME}/opt/cmake_2.8.12.2/bin/

E.g.


$ cmake --version
cmake version 2.6-patch 2
$ PATH="${HOME}/opt/cmake_2.8.12.2/bin/:${PATH}" cmake --version
cmake version 2.8.12.2