PDA

View Full Version : Fetchmail could not get mail



linuxformat
22-Dec-2014, 11:15
Hi

I installed mail server from yast and its working good send and receive local and relay mail outgoing through public mail all that good .

I trying now to fetch mail from internet through public mail so i configured from yast .

code: vi /etc/fetchmailrc

poll "imap.gmail.com" protocol IMAP : user "suliman.s@gmail.com" there with password "mypassword" is "solom@hospital.mail" here ;

Then error came to my mail box local .

( Fetchmail could not get mail from suliman.s@gmail.com.

The attempt to get authorization failed.
This probably means your password is invalid, but some servers have
other failure modes that fetchmail cannot distinguish from this
because they don't send useful error messages on login failure.

The fetchmail daemon will continue running and attempt to connect
at each cycle. No future notifications will be sent until service
is restored.
-- The Fetchmail Daemon )

Please Help


Regards

ab
22-Dec-2014, 12:21
Was your password correct?

Google is one of those providers mentioned in that error message which may
be blocking access from a new client so maybe that applies. An easy way
around this is to use the GMail web interface to setup "application
passwords" so you have a dedicated password for something like fetchmail
which has limited access (e-mail/calendar but not administration) and also
does not use any of the other authentication options (SMS, e-mail, etc.).

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...

linuxformat
22-Dec-2014, 12:59
Yes Google need configure to fetch mail because i tried with other host and is working will .

Thank you very mach

Regards

hendersj
22-Dec-2014, 19:43
On Mon, 22 Dec 2014 12:04:01 +0000, linuxformat wrote:

> Yes Google need configure to fetch mail because i tried with other host
> and is working will .
>
> Thank you very mach
>
> Regards

I use fetchmail here, and this works for me.

Did you configure gmail to allow imap connections for your account?
There are settings you need to configure on the gmail side, or it'll fail.

Jim



--
Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10
Novell/SUSE/NetIQ Knowledge Partner