PDA

View Full Version : SLES Upgrade from 10 to 11 Increased CPU utilization



smithwilliamsmith
22-Dec-2014, 17:59
After an upgrade from SLES 10 to SLES 11 on hardware supporting a Teradata database, we are seeing increased CPU consumption of nearly 9%. Is this normal for this type of upgrade?

ab
24-Dec-2014, 12:19
The changes from SLE 10 to 11 were many assuming you are on SLE 11 with
semi-current SPs, including a change to the major kernel version (2.6.x to
3.x) and basically everything between applications and that kernel.
Depending on what your hardware is doing, it may be better-utilized now
(allowing for other bottlenecks to be removed, then shifting bottlenecks
elsewhere, such as to the CPU) or perhaps there are more services running
on the box contributing to the increased load (more to do).

It may be useful to note whether or not that is 9% of one CPU, or 9%
across all CPUs, then how many CPUs there are. It may also be useful to
note other metrics such as application responsiveness, end user
experience, etc.

For my systems, I did not notice increased load as far as CPU utilization
was concerned, but I am not a benchmark expert and did not do extensive
testing between SLE 10 and 11 when 11 first came out since it worked much
better in terms of administration and functionality so switching was a
no-brainer (again, for me).

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...

smithwilliamsmith
26-Dec-2014, 15:01
Thanks for the response on this... I will keep these considerations in mind