PDA

View Full Version : cannot install bleachbit due to missing dependency



ofvergara
31-Dec-2014, 22:55
gentlemen,
i went over these two websites:
1) http://software.opensuse.org/package/bleachbit?search_term=bleachbit
2) http://bleachbit.sourceforge.net/download/linux

on both cases, the packages for SLE11 are supposed to be installed correctly with the current sled11sp3 system.
however, even though both versions differ slightly on numbers, both require different dependency files.

it is surprising to me though, that when i click the 1-click-install button from software.opensuse.org it is supposed to install everything including the missing dependency.
however, the installer stops complaining about the missing dependency and the application doesn't install.

i tried finding the missing dependency from http://rpm.pbone.net but it conflicts with a local python file.
so the question is, where do i find the missing dependency?
is it safe by forcing it by doing rpm -Uvh *.rpm --nodeps?

thanks for your reply.
Omar

malcolmlewis
31-Dec-2014, 23:24
On Wed 31 Dec 2014 10:04:01 PM CST, ofvergara wrote:


gentlemen,
i went over these two websites:
1) http://software.opensuse.org/package/bleachbit?search_term=bleachbit
2) http://bleachbit.sourceforge.net/download/linux

on both cases, the packages for SLE11 are supposed to be installed
correctly with the current sled11sp3 system.
however, even though both versions differ slightly on numbers, both
require different dependency files.

it is surprising to me though, that when i click the 1-click-install
button from software.opensuse.org it is supposed to install everything
including the missing dependency.
however, the installer stops complaining about the missing dependency
and the application doesn't install.

i tried finding the missing dependency from http://rpm.pbone.net but it
conflicts with a local python file.
so the question is, where do i find the missing dependency?
is it safe by forcing it by doing -rpm -Uvh *.rpm --nodeps-?

thanks for your reply.
Omar




Hi
I would guess (since you left us wondering on which file it's
missing ;) ) your talking about python-gnomevfs?

If so ignore and install python-gnomevfs2 since that's what is
available, looks like a packaging error.


--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.28-4-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

ofvergara
01-Jan-2015, 19:00
Hi
I would guess (since you left us wondering on which file it's
missing ;) ) your talking about python-gnomevfs?

If so ignore and install python-gnomevfs2 since that's what is
available, looks like a packaging error.


--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.28-4-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

Hi Malcolm and happy new year!
yes, sorry about that. i realized i forgot to mention what was the missing dependency. i took python-gnomevfs from opensuse 11.4 which was the closest one for sled11sp3

however, it still conflicted with a local python from sled11sp3, as you can see below:
file /usr/lib/gnome-vfs-2.0/modules/libpythonmethod.so from install of python-gnomevfs-2.28.1-9.1.i586 conflicts with file from package python-gnome-2.22.0-67.32.i586

so i decided to install only bleachbit with the --nodeps option in the terminal command and it worked.
apparently, sled11sp3 has python-gnomevfs somewhere yet under a different name.

thanks Malcolm for your hint. so far bleachbit is opening up and kind of working. if anything out of the ordinary comes up, i'll post it here.
Cheers.