PDA

View Full Version : SLES11 for SAP ldap client issue.



ThomasC1981
06-Jan-2015, 09:32
Hi,

Im fairly new to suse, and we are in the process of moving our sap environment from Solaris to suse. Hopefully this will be an easy one for you guys (and gals) :)

When trying to set up one of these new suse systems and adding it as a LDAP client using yast, when i configure the base DN then go in to advanced settings, it bombs out with this

/sbin/yast: line 471: 25925 Aborted $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

It then messes up the session and i need to restart my connection. I can't see any log files that give me any indication as to what the issue might be. has anyone ever seen this before? any help or pointers would be much appreciated. or even a command line equivelant to configure it would be nice instead of yast :)

Many thanks,

Thomas

ab
06-Jan-2015, 19:57
Which SP of SLES 11 exactly? Are you doing this from a GUI or command
line, and have you tried the other?

/var/log/y2log (or something like that) has the Yast logs which may give
you more details, though I have not looked recently. The y2log tends to
be very verbose, so getting only what you receive from a single attempt
would be nice.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...

ThomasC1981
07-Jan-2015, 09:38
Which SP of SLES 11 exactly? Are you doing this from a GUI or command
line, and have you tried the other?

/var/log/y2log (or something like that) has the Yast logs which may give
you more details, though I have not looked recently. The y2log tends to
be very verbose, so getting only what you receive from a single attempt
would be nice.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...

Hi Ab,

Thanks for the reply. We're currently on SLES11 SP3. most of the time im on the command line and use "yast". I have tried yast2 from within the desktop environment but the window blows away when i encounter the problem. I had a look in /var/log and there doesn't seem to be a y2log file, however in /var/log/YaST2/ there is a y2log. I'm assuming the YaST2 dir contains the log for both yast and yast2. There's nothing in the file that jumps out as being an error :confused: i shall persevere :)

Many thanks again,

Thomas

ab
07-Jan-2015, 19:46
I've done some testing and so far cannot duplicate this. Perhaps having
some additional details on what you have in all of your fields will help.

You can launch this portion of Yast directly which may not be different,
but may at least save some time going into Yast over and over:



sudo /sbin/yast ldap-client


Once in there I have the following specified, pointed to my eDirectory
instance:

Use LDAP (checked)
Addresses of LDAP Servers (one IPv4 address there)
LDAP Base DN: dc=org (one of the top containers in my tree)
Create Home Directory on Login (checked)

Under Advanced:
All defaults under Client Settings (dc=org for Naming Contexts, presumably
pulled from previous screen)

Under Advanced: Administration Settings
Configuration Base DN: cn=ldapconfig,dc=ldap,dc=server,dc=system
I had to create the dc=ldap,dc=server,dc=system context myself as it did
not exist yet, though the parent containers did
Administration DN: cn=admin,dc=sa,dc=system

Under Configure User Management Settings I entered a password and then
tried to do other things like specify the configuration settings for users
and groups, but a schema problem in my tree prevented creation so those
threw little errors when saving changes in Yast.

After all of that, no crashes. RPM shows me the following about the
yast2-ldap-client package:



> rpm -qi yast2-ldap-client
Name : yast2-ldap-client Relocations: (not relocatable)
Version : 2.17.38 Vendor: SUSE LINUX
Products GmbH, Nuernberg, Germany
Release : 0.7.2 Build Date: Mon 25 Nov 2013
10:12:25 AM MST
Install Date: Wed 07 Jan 2015 11:31:31 AM MST Build Host: furud
Group : System/YaST Source RPM:
yast2-ldap-client-2.17.38-0.7.2.src.rpm
Size : 593801 License: GPL-2.0
Signature : RSA/8, Mon 25 Nov 2013 10:12:27 AM MST, Key ID e3a5c360307e3d54
Packager : http://bugs.opensuse.org
Summary : Configuration of LDAP client
Description :
With this YaST2 module you can configure an LDAP client so that an
OpenLDAP server will be used for user authentication.
Distribution: SUSE Linux Enterprise 11


As you can see, I patched to this (latest) version today after trying the
steps above, and still cannot duplicate a crash. Perhaps your resolution
is really, really weird. If you're SSHing in, which client are you using?

What do you get from the 'env' command before running Yast? Maybe a
session-specific variable is throwing Yast off.

From my box:


LESSKEY=/etc/lesskey.bin
NNTPSERVER=news
INFODIR=/usr/local/info:/usr/share/info:/usr/info
MANPATH=/usr/share/man:/usr/local/man:/opt/novell/man:/opt/novell/man:/opt/novell/man:/opt/novell/man
HOSTNAME=mybox0
XKEYSYMDB=/usr/share/X11/XKeysymDB
HOST=mybox0
TERM=xterm
SHELL=/bin/bash
PROFILEREAD=true
HISTSIZE=20000
SSH_CLIENT=137.65.223.197 51274 22
MORE=-sl
SSH_TTY=/dev/pts/0
USER=root
LS_COLORS=no=00:fi=00:di=01;34:ln=00;36:pi=40;33:s o=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=41;33; 01:ex=00;32:*.cmd=00;32:*.exe=01;32:*.com=01;32:*. bat=01;32:*.btm=01;32:*.dll=01;32:*.tar=00;31:*.tb z=00;31:*.tgz=00;31:*.rpm=00;31:*.deb=00;31:*.arj= 00;31:*.taz=00;31:*.lzh=00;31:*.lzma=00;31:*.zip=0 0;31:*.zoo=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*. bz2=00;31:*.tb2=00;31:*.tz2=00;31:*.tbz2=00;31:*.a vi=01;35:*.bmp=01;35:*.fli=01;35:*.gif=01;35:*.jpg =01;35:*.jpeg=01;35:*.mng=01;35:*.mov=01;35:*.mpg= 01;35:*.pcx=01;35:*.pbm=01;35:*.pgm=01;35:*.png=01 ;35:*.ppm=01;35:*.tga=01;35:*.tif=01;35:*.xbm=01;3 5:*.xpm=01;35:*.dl=01;35:*.gl=01;35:*.wmv=01;35:*. aiff=00;32:*.au=00;32:*.mid=00;32:*.mp3=00;32:*.og g=00;32:*.voc=00;32:*.wav=00;32:
XNLSPATH=/usr/X11R6/lib/X11/nls
ENV=/etc/bash.bashrc
HOSTTYPE=x86_64
FROM_HEADER=
PAGER=less
CSHEDIT=emacs
XDG_CONFIG_DIRS=/etc/xdg
MINICOM=-c on
MAIL=/var/mail/root
PATH=/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/usr/games:/usr/lib/mit/bin:/usr/lib/mit/sbin
CPU=x86_64
SSH_SENDS_LOCALE=yes
INPUTRC=/etc/inputrc
PWD=/root
LANG=en_US.UTF-8
PYTHONSTARTUP=/etc/pythonstart
PS1=\[\]\D{%Y-%m-%d %H:%M:%S} Jobs:\j Err:$?\n\u@\h:\w# \[\]
QT_SYSTEM_DIR=/usr/share/desktop-data
SHLVL=1
HOME=/root
LESS_ADVANCED_PREPROCESSOR=no
OSTYPE=linux
LS_OPTIONS=-A -N --color=tty -T 0
XCURSOR_THEME=
G_FILENAME_ENCODING=@locale,UTF-8,ISO-8859-15,CP1252
LESS=-M -I
MACHTYPE=x86_64-suse-linux
LOGNAME=root
XDG_DATA_DIRS=/usr/share
SSH_CONNECTION=10.1.1.1 51274 10.1.1.2 22
LESSOPEN=lessopen.sh %s
INFOPATH=/usr/local/info:/usr/share/info:/usr/info
LESSCLOSE=lessclose.sh %s %s
G_BROKEN_FILENAMES=1
COLORTERM=1
_=/usr/bin/env


To be clear, I'm SSHing in from a Linux-based workstation to the server;
the server is a virtual Xen-based VM I believe.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...

jmozdzen
12-Jan-2015, 17:53
Hi Thomas,

side notes:

a - "It then messes up the session and i need to restart my connection.": Try calling "reset" (it's a command) when this happens - it might save you the relogin.

b - try running the yast command while redirecting stderr to a file ("yast 2>/tmp/yast.err") and have a look at the contents of that file, once the error re-appeared. Even better: If using the GUI version, you ought to redirect stdout, too - that way you might catch any subcommand's output besides errors as well. OTOH - you should see that now anyhow, in the console session you started yast2...

Regards,
Jens