PDA

View Full Version : Broken Updates



NathanRuddick
12-Jan-2015, 21:46
Hi all, first time post so I hope itís in the right section
Firstly my linux knowledge is okay but not fantastic so forgive me if i make any mistakes
Basically we have a Novell OES that is having issues after an update, It seems something has Iím really not sure how this happened and if the server was interrupted while updating but this server p has now fallen into my lap, so the problem is every time novell-nss is started it dumps:

Starting Novell Storage Services (NSS)
WARNING: Couldn't open directory /lib/modules/3.0.58-0.6.6-default: No such file or directory
FATAL: Could not open /lib/modules/3.0.58-0.6.6-default/modules.dep.temp for writing: No such file or directory
ERROR: modinfo: could not open /lib/modules/3.0.58-0.6.6-default/modules.dep
ERROR: Cannot find nwraid.ko
.......... ABORTING /etc/init.d/novell-nss ..........
Scan devices and mount pools
NSS is NOT fully running!

I can connect to the servers shares using the Novell client but after a while it falls offline, my question is how do I Fix this, I really am treading blind I have redone the updates in YaST and zypper to no avail but I am not sure what I need to do now, should I look at re-installing that module which I believe is in a kernel package?

Any help you could provide would be welcome, sorry again for any mistakes!

-Nate

jmozdzen
13-Jan-2015, 11:55
Hi Nate,

as this question seems to point to a problem with the underlying SLES system, I'm not going to redirect you to the OES forums ;) (https://forums.novell.com/forumdisplay.php/514-OES-Linux)

Hi all, first time post so I hope itís in the right section
Firstly my linux knowledge is okay but not fantastic so forgive me if i make any mistakes
Basically we have a Novell OES that is having issues after an update, It seems something has Iím really not sure how this happened and if the server was interrupted while updating but this server p has now fallen into my lap, so the problem is every time novell-nss is started it dumps:

Starting Novell Storage Services (NSS)
WARNING: Couldn't open directory /lib/modules/3.0.58-0.6.6-default: No such file or directory
FATAL: Could not open /lib/modules/3.0.58-0.6.6-default/modules.dep.temp for writing: No such file or directory
ERROR: modinfo: could not open /lib/modules/3.0.58-0.6.6-default/modules.dep
ERROR: Cannot find nwraid.koThis does indeed look like an interrupted update or a missing reboot since the last kernel update. Another typical case might be a partial system restore (from an old backup), leading to inconsistencies between /boot and /lib/modules.

I recommend to re-install the current kernel package(s) ( run

rpm -qa|grep "^kernel" and install using "zypper install --force <package names>" or via YaST. The kernel to install should match the error message. If the installed kernel is *newer* than the reported version (3.0.58-0.6.6), then the earlier update process probably didn't update the boot loader, which then is still referencing an old kernel. (But then I'd wonder why the system could boot the old kernel, but could not access the module files - see "partial restore" assumption above.)

The symptoms you describe point to missing "modules", which are part of the kernel install and need to match the running kernel. In case you want to verify the situation before blindly running some update statements named in some forum reply, you could use "rpm -V <packagename>" to verify the installed kernel package and have it checked if the coerresponding module files are missing.

Regards,
Jens

NathanRuddick
13-Jan-2015, 21:28
Just wanted to say thank you,

I re-installed the kernel 3.0.58.XXXX and tested and it worked fine novell storage is happy again and is working

I'm glad there are some smart people out there! :D