PDA

View Full Version : Sles 11SP3 update problem



mikkokok
13-Jan-2015, 11:58
I just installed fresh system of Sles 11SP3. However when I try to access any repository or update the system with "zypper update" I get:


Refreshing service 'nu_novell_com'.
Download (curl) error for 'https://nu.novell.com//repo/repoindex.xml?credentials=NCCcredentials':
Error code: HTTP response: 410
Error message: The requested URL returned error: 410

Registration went smoothly and I can see my system under my subscription so credentials should be okay. Proxies are ok so now I don't have any idea what might be wrong. I can get to that url fine from same network with my own desktop.

Any ideas?

ab
13-Jan-2015, 13:38
This looks like another content delivery system problem at first glance
and has been reported to Novell earlier today. I'll post an update when I
see one.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...

ab
13-Jan-2015, 13:42
Silly question: have you tried changing your repository to point to the
new SCC instead of the NCC? I have no idea if this is the right thing for
this case, but the HTTP 410 is odd and maybe this is to help customers
transition to the new site in a more-visible way than using a 404.

https://updates.suse.com/repo/$RCE/SLES11-SP3-Updates/sle-11-x86_64

With that said, this may be a silly idea without merit; if so, please
disregard.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...

arcdmin
13-Jan-2015, 13:54
same issue here
http://picload.org/image/ccigaic/nov.jpg

@ab

do you mean to replace the repo url https://nu.novell.com/?credentials=NCCcredentials with https://updates.suse.com/repo/$RCE/SLES11-SP3-Updates/sle-11-x86_64 seems not to work

ab
13-Jan-2015, 14:11
Okay, thanks for the update.

For what it is worth, I ran a 'zypper ref' and pulled down a new
'subversion' package update this morning on my SLES 11 SP3 x86_64 system,
so maybe it's specific repositories. If you ping nu.novell.com what do
you get back? From one part of the world I get 93.184.215.212 so if that
is not yours, perhaps hack your /etc/hosts file to force it and see if
that makes a difference.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...

arcdmin
13-Jan-2015, 14:34
hello, it was worth a try.

I had 68.232.34.212 (eu)

changed to 93.184.215.212 in /etc/hosts 93.184.215.212 nu.novell.com

same error

zypper refresh-services -r
Refreshing service 'nu_novell_com'.
Download (curl) error for 'https://nu.novell.com//repo/repoindex.xml?credentials=NCCcredentials':
Error code: HTTP response: 410
Error message: The requested URL returned error: 410


unfortunately it does not work

thank you

mikkokok
14-Jan-2015, 07:08
hello, it was worth a try.

I had 68.232.34.212 (eu)

changed to 93.184.215.212 in /etc/hosts 93.184.215.212 nu.novell.com

same error

zypper refresh-services -r
Refreshing service 'nu_novell_com'.
Download (curl) error for 'https://nu.novell.com//repo/repoindex.xml?credentials=NCCcredentials':
Error code: HTTP response: 410
Error message: The requested URL returned error: 410


unfortunately it does not work

thank you

It seems to be working now fine without any changes. So most likely a problem at Novell end.

smflood
19-Jan-2015, 14:59
On 14/01/2015 06:14, mikkokok wrote:

> It seems to be working now fine without any changes. So most likely a
> problem at Novell end.

Yes it was a problem at Novell's end which has now been resolved.

For anyone following this thread in future, unless officially advised to
do so by Novell don't add a static entry for nu.novell.com to your
/etc/hosts file.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

bobino
16-Feb-2015, 16:40
On 14/01/2015 06:14, mikkokok wrote:

> It seems to be working now fine without any changes. So most likely a
> problem at Novell end.

Yes it was a problem at Novell's end which has now been resolved.

For anyone following this thread in future, unless officially advised to
do so by Novell don't add a static entry for nu.novell.com to your
/etc/hosts file.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

Hello, I'm troubleshooting same issue, my server can't connect to nu...
in yast smt-server nu configuration,
I receiving mirroring credential invalid when I'm doing a test.
Cold you let me know what I should write as registration server url and as download server url ?
nu or scc or ncc ?
I'm lost.
Our firewall don't let us ping so I can't try, but I'm able to resolve nu.novell.com.
thank you

Dan

irunisys
17-Feb-2015, 20:54
Dan - I found all our SMT mirroring problems went away after switching to SCC. (NCC was always flaky )
Reg server : https://scc.suse.com/connect
Download : https://updates.suse/com

Make sure you test your mirroring credentials within the yast SMT module.

smflood
18-Feb-2015, 16:08
On 16/02/2015 15:44, bobino wrote:

> Hello, I'm troubleshooting same issue, my server can't connect to nu...
> in yast smt-server nu configuration,
> I receiving mirroring credential invalid when I'm doing a test.
> Cold you let me know what I should write as registration server url and
> as download server url ?
> nu or scc or ncc ?
> I'm lost.
> Our firewall don't let us ping so I can't try, but I'm able to resolve
> nu.novell.com.
> thank you

Are you asking about registering "regular" SLES or mirroring via SMT
(Subscription Management Tool)?

With "regular" versions of SLES earlier than SLES12 you register servers
against Novell Customer Center (NCC) which then show up in SUSE Customer
Center (SCC). With SLES12 you register directly against SCC.

If you have SMT then you need latest SMT11 SP3 code (on SLES11 SP3) and
manually switch it over from NCC to SCC - please see TID 7015836[1].

HTH.

[1] https://www.suse.com/support/kb/doc.php?id=7015836
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

smflood
18-Feb-2015, 16:09
On 17/02/2015 20:04, irunisys wrote:

> Dan - I found all our SMT mirroring problems went away after switching
> to SCC. (NCC was always flaky )
> Reg server : https://scc.suse.com/connect
> Download : https://updates.suse/com
>
> Make sure you test your mirroring credentials within the yast SMT
> module.

The above only applies to latest SMT11 SP3 code (on SLES11 SP3) and
doesn't apply to individual SLES servers running versions of SLES
earlier than SLES12.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

epretorious
05-Feb-2016, 23:36
Dan - I found all our SMT mirroring problems went away after switching to SCC. (NCC was always flaky )

Thanks for updating this thread, irun!

Can you explain a bit more of how you fixed the problem?