PDA

View Full Version : failed upgrade to SP3



Mike
28-Jan-2015, 20:21
I had a Sles 11 Sp2 server that I attempted to upgrade to SP3 using the
zypper commands because the wagon method failed. Somewhere along the
way the server now thinks it's now sles for vmware instead of sles 11
sp2 so the machine is no longer registered since I don't have a
registration code for sles for vmware, nor do I want one. How do I get
it to recognize it for what it is which is Sles 11 SP2?

malcolmlewis
28-Jan-2015, 20:40
On Wed 28 Jan 2015 07:21:35 PM CST, Mike wrote:

I had a Sles 11 Sp2 server that I attempted to upgrade to SP3 using the
zypper commands because the wagon method failed. Somewhere along the
way the server now thinks it's now sles for vmware instead of sles 11
sp2 so the machine is no longer registered since I don't have a
registration code for sles for vmware, nor do I want one. How do I
get it to recognize it for what it is which is Sles 11 SP2?



Hi
If you log into SCC and remove the system and then re-registering it
with your activation code should sort it out.

You might want to also clean out the credentials;


rm /etc/zypp/credentials.d/NCCcredentials


--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.32-33-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

smflood
29-Jan-2015, 11:40
On 28/01/2015 19:40, malcolmlewis wrote:

> If you log into SCC and remove the system and then re-registering it
> with your activation code should sort it out.
>
> You might want to also clean out the credentials;
>

> rm /etc/zypp/credentials.d/NCCcredentials
>

Since this is SLES11 SP2/SP3 you'll need to log into Novell Customer
Center (as indicated by .../NCCcredentials).

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

smflood
29-Jan-2015, 11:51
On 28/01/2015 19:21, Mike wrote:

> I had a Sles 11 Sp2 server that I attempted to upgrade to SP3 using the
> zypper commands because the wagon method failed. Somewhere along the
> way the server now thinks it's now sles for vmware instead of sles 11
> sp2 so the machine is no longer registered since I don't have a
> registration code for sles for vmware, nor do I want one. How do I get
> it to recognize it for what it is which is Sles 11 SP2?

How was the server upgraded - what steps did you follow?

What do "cat /etc/*release" and "zypper se -t product" output?

If the server thinks it's SLES for VMware rather than "regular" SLES
then removing it from NCC and re-registering it will only achieve the
same outcome. Is it possible the server was actually SLES11 SP2 for
VMware before the upgrade?

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------