PDA

View Full Version : GLIBC Upgrade in SLES 11 SP3



rzhidalgo
31-Jan-2015, 04:37
We currently have SLES 11 SP3, with glibc version 2.11. I need to upgrade glibc to 2.17 to be able to install several software (PostGIS, etc.). Do I have to delete 2.11 and install 2.17, which could be destructive?
Can the upgrade be done with yast or zypper?
I appreciate your help.

ab
31-Jan-2015, 05:31
You do not need to upgrade to 2.17; if you just apply available patches
from the channel you'll get the GHOST fix (assuming you have not done so
already. I believe the correct version is 2.11.3.17.74.13 (or later).
You can query the package's changelog to see that the fix is included:



rpm -q --changelog glibc


* Mon Jan 19 2015 schwab@suse.de
- gethostbyname-digits-dots.patch: Fix parsing of numeric hosts in
gethostbyname_r (CVE-2015-0235, bsc#913646, BZ #15014)

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...

jmozdzen
02-Feb-2015, 11:51
Hi rzhidalgo,

We currently have SLES 11 SP3, with glibc version 2.11. I need to upgrade glibc to 2.17 to be able to install several software (PostGIS, etc.). Do I have to delete 2.11 and install 2.17, which could be destructive?
Can the upgrade be done with yast or zypper?
I appreciate your help.

if you actually need the newer version (rather than simply are looking for security patches - those typically are back-ported by SUSE and thus included), please keep in mind that changing such a core element is not for the faint of heart. I *strongly* suggest to look into upgrading to a newer version of the distribution (make that "SLES12" at the moment,with glibc 2.19 iirc).

Regards,
Jens