PDA

View Full Version : Newbie on SLED 11 SP3



dracul
02-Feb-2015, 01:23
Hello suse community,

after a loooong experience with highs and lows with microsoft, i decided to give linux another try.
I managed to install SLED 11SP3 on my HP Workstation Z1 with nvidia card.
I also tried latest versions of SLED 12, opensuse, linux mint and ubuntu. With none of them i had 100% working machine.
Most of them had no support for dimming the backlight. I tried a lot of things activating xbacklight ... none worked good.
With all distros and working workarounds there was a high pitch noise when diming the screen...except SLED11SP3.
Here the diming works as it should. After a lot of reading and trying i think it is a kernel bug.
So i will remain on my version 11 with suse, with a 60 days try time.
Does that mean that i have 60 days time to update the system with the latest patches?
When i search for new updates in yast there are "0", but firefox browser is version 31.4.0.
Why does it not get updatet?
What repository should i add to get more software like vlc player, because i don't know how to install b2z packed software corectly.
Thanks for helping.

mikewillis
02-Feb-2015, 09:17
So i will remain on my version 11 with suse, with a 60 days try time.
Does that mean that i have 60 days time to update the system with the latest patches?

It means that you get updates for 60 days from the time you register the system. After 60 days your system keeps working but you no longer get any updates. If you want to get updates after the 60 trial period you need to purchase a license.




When i search for new updates in yast there are "0", but firefox browser is version 31.4.0.
Why does it not get updatet?

SLED 11 SP3 does not ship with Firefox 31.4.0 so that you have Firefox 31.4.0 means that updates have been installed. I would guess that you are being told there are 0 updates because you have installed all updates currently available. You can be more certain that you have all updates installed by running

$ uname -a
which will tell you the Kernel version. Currently Kernel version for SLED 11 SP3 is 3.0.101-0.42.1.



What repository should i add to get more software like vlc player, because i don't know how to install b2z packed software corectly.

It is very easy to make a mess of your system by adding third party repositories so unless you are sure what you are doing I would avoid them, at least until you are more confident with Linux. You may be able to find SLED 11 SP3 versions of some software you want at the openSUSE Build Service. http://software.opensuse.org/search (Make sure you set the distro to SLED 11 SP3 by clicking the spanner. Don't just type in the name of something and try to use the first package you find, it will not end well ;)


If you want additional codec support without adding lots of third part packages to your system take a look at https://www.suse.com/communities/conversations/additional-multimedia-codec-support-for-sled-11-sp3/ It's not really as complicated as a it looks provided that you follow the instructions in the README file.

'b2z packed software' is a bit vague. a file with suffix bz2 is just a compressed file. It's like saying you don't know how to install a .zip file ;) A bz2 file could contain source code that needs to be compiled or pre-compiled binaries that you just unpack and run and do not require any installation.

dracul
02-Feb-2015, 22:29
Thank You mikewillis!
$ uname -a shows me the kernel is up to date.

I tried to build the rpm, but didn't succeed :-(

configure: error: no gstreamer-0.10 >= 0.10.33 (GStreamer) found
xxx@localhost:~/Downloads/multimediacodecs_sled11sp3>
I checked the installed software in yast and there it shows me gstreamer-0.10.35-2.9.46 is installed.
and 0.10.35 is greater than 0.10.33

So this are the things that are so disappointing to me. Setting up a new system and got stuck in such problems at the beginning.
And i always ask me "why", why do i try it once more and do not stay with windows, where i haven't got such problems.
Now it's one week that i try to figure out a running system with such stones on the way.

mikewillis
02-Feb-2015, 23:03
I tried to build the rpm, but didn't succeed :-(

configure: error: no gstreamer-0.10 >= 0.10.33 (GStreamer) found
xxx@localhost:~/Downloads/multimediacodecs_sled11sp3>
I checked the installed software in yast and there it shows me gstreamer-0.10.35-2.9.46 is installed.
and 0.10.35 is greater than 0.10.33

It sounds like you do not have not installed the dependencies as described in the PREREQUISITES section of README.txt.

dracul
02-Feb-2015, 23:05
I think i'm to stupid for linux - just downloaded Thunderbird ymp from http://software.opensuse.org/search for SLE 11SP3 installed it replaced the old version and voila, it's working ... but has no icon, it's just a white icon on the desktop and under the menu it is a terminal icon.

dracul
02-Feb-2015, 23:07
It sounds like you do not have not installed the dependencies as described in the PREREQUISITES section of README.txt.

installed them with

$ zypper in $(grep ^BuildRequires multimediacodecs.spec | cut -d : -f 2 | tr '\t' ' ' | tr '\n' ' ') like it is stated in the readme

mikewillis
03-Feb-2015, 01:00
installed them with

$ zypper in $(grep ^BuildRequires multimediacodecs.spec | cut -d : -f 2 | tr '\t' ' ' | tr '\n' ' ') like it is stated in the readme


What is the output of


$ rpm -qa | grep gstreamer | grep devel

dracul
03-Feb-2015, 13:34
What is the output of


$ rpm -qa | grep gstreamer | grep devel

simply nothing :-(



$ rpm -qa | grep gstreamer

gstreamer-0_10-lang-0.10.35-2.9.46
PackageKit-gstreamer-plugin-0.3.14-2.28.46
gstreamer-0_10-32bit-0.10.35-2.9.46
gstreamer-0_10-plugins-farsight-0.12.11-1.1.158
gstreamer-0_10-plugins-good-0.10.30-5.12.15
bluez-gstreamer-4.99-0.7.91
gstreamer-0_10-plugins-good-lang-0.10.30-5.12.15
gstreamer-0_10-0.10.35-2.9.46
libgstreamer-0_10-0-32bit-0.10.35-2.9.46
libgstreamer-0_10-0-0.10.35-2.9.46
gstreamer-0_10-utils-0.10.35-2.9.46
gstreamer-0_10-plugins-base-lang-0.10.35-5.15.8
phonon-backend-gstreamer-0_10-4.3.1-3.5.1
banshee-1-backend-engine-gstreamer-2.0.1-2.20.41
gstreamer-0_10-plugins-bad-0.10.22-7.9.63
python-gstreamer-0_10-0.10.17-1.1.124
gstreamer-0_10-plugins-bad-lang-0.10.22-7.9.63
gstreamer-0_10-plugins-base-32bit-0.10.35-5.15.8
gstreamer-0_10-fluendo-mp3-12-4.7.18
gstreamer-0_10-plugins-base-0.10.35-5.15.8
gstreamer-0_10-plugins-v4l-0.10.30-0.12.14

$ rpm -qa | grep devel

xorg-x11-libfontenc-devel-7.4-1.15
xorg-x11-libXp-devel-7.4-1.16.1
xorg-x11-libXdmcp-devel-7.4-1.15
python-devel-2.6.9-0.33.1
glibc-devel-2.11.3-17.74.13
freetype2-devel-2.3.7-25.32.1
xorg-x11-libxcb-devel-7.4-1.29.1
xorg-x11-libXpm-devel-7.4-1.17
xorg-x11-proto-devel-7.4-1.35.47
xorg-x11-xtrans-devel-7.4-4.25.46
xorg-x11-libXext-devel-7.4-1.18.1
xorg-x11-devel-7.4-8.26.32.53
glib2-devel-2.22.5-0.8.8.1
zlib-devel-1.2.7-0.10.128
libpng-devel-1.2.31-5.31.1
xorg-x11-libXfixes-devel-7.4-1.16.1
xorg-x11-libSM-devel-7.4-1.18
gtk2-devel-2.18.9-0.23.63
xorg-x11-fonts-devel-7.4-1.15
fontconfig-devel-2.6.0-10.15.26
libstdc++43-devel-4.3.4_20091019-0.37.30
xorg-x11-libXprintUtil-devel-7.4-1.17
atk-devel-1.28.0-1.4.40
xorg-x11-libXau-devel-7.4-1.15
xorg-x11-libxkbfile-devel-7.4-1.14
libuuid-devel-2.19.1-6.54.1
cairo-devel-1.8.8-2.1.48
glibc-devel-32bit-2.11.3-17.54.1
xorg-x11-libICE-devel-7.4-1.15
xorg-x11-libXt-devel-7.4-1.19.1
libpixman-1-0-devel-0.24.4-0.11.1
xorg-x11-libX11-devel-7.4-5.9.4
xorg-x11-libXmu-devel-7.4-1.17
libpciaccess0-devel-7.4_0.11.0-0.4.6.17
xorg-x11-libXrender-devel-7.4-1.16.1
pango-devel-1.26.2-1.3.86
kernel-default-devel-3.0.101-0.46.1
xorg-x11-util-devel-7.4-1.15
xorg-x11-libXv-devel-7.4-1.16.1

mikewillis
03-Feb-2015, 13:47
simply nothing :-(


That's why the build script fails then, you don't have the gstreamer-0_10-devel package installed. The rpm output you provided shows you don't have most of the other dependencies installed either.
The checkdependencies script will list all the dependencies and whether or not they are installed.

dracul
03-Feb-2015, 18:31
how do i install the gstreamer-0_10-devel package, under software i can't find it.

mikewillis
03-Feb-2015, 18:56
how do i install the gstreamer-0_10-devel package, under software i can't find it.

Did you add the SDK?


me@mine:/tmp/multimediacodecs_sled11sp3> head README.txt
PREREQUISITES
-------------

You need to have the SLE SDK 11 SP3 available as a repository.

You can download it from
http://download.novell.com/Download?buildid=hF8sRGTVC04~

You only need DVD1, DVD2 is sources. (The download page unhelpfully fails to explain this.)

me@mine:/tmp/multimediacodecs_sled11sp3>


Download the iso then in YaST go to Software > Add-On Products. Click Add, select Local ISO image..

Or, since I put together the codecs thing there's now a documented way of adding the SDK without download the iso first.
https://www.novell.com/support/kb/doc.php?id=7015337 It says SLES, it'll work for SLED too.


SUSE have made adding the SDK much easier in SLED 12!

dracul
03-Feb-2015, 23:39
Did you add the SDK?

Sorry!!!
I didn't. I missed out the SLE SDK 11 SP3
Thought the normal installation DVD is meant.
Downloading ....

Surely the version 12 is "better", but i didn't figure it out, how to enable a true backlight-control without noise of the inverter.
Second reason to install Suse 11 were the wonderful desktop effects with gnome 2
Third reason was that the Workstation Z1 ships by HP either with Windows or with Suse 11 SP3. and i couldn't buy the Linux version.

dracul
04-Feb-2015, 11:13
Everything worked nice. TANK YOU FOR YOUR PATIENCE AND HELP!!!

Interestingly the Thunderbird icon reappeared.