PDA

View Full Version : Problem with error Message by use virt- install



floregs3
12-Feb-2015, 17:19
Hi Forum users,

my problem is about the command line Tool "virt-Install", to Install my first VM on command line. My Host is a Suse Linux Enterprise Server 12. The Problem is in my opinion a Virtualizations Problem, not an (for the Guest) Ubuntu problem.

My first config is in the following way: (with ubuntu-14.04.1-server-amd64.iso)

sudo virt-install --connect qemu:///system -n vmsnort1 -r 8096 -f /dev/vgDATE/snortuserv1404 --location /var/lib/libvirt/images/ubuntu-14.04.1-server-amd64.iso --os-type linux --network=bridge:br0 --extra-args="console=ttys0,115200" --os-variant=ubuntutrusty

I get following error message:

Installation wird gestartet...
Datei info wird abgerufen... | 136 B 00:00 ...
Datei version.info wird abgerufen... | 116 B 00:00 ...
ERROR Konnte hvm Kernel für Ubuntu Struktur nicht finden.

After that nothing happens!


My second config I use is because I thought the virt-install can't work with the latest Ubuntu Version:
Now I use ubuntu-12.04.5-server-amd64.iso


sudo virt-install --connect qemu:///system -n vmsnort1 -r 8096 -f /dev/vgDATE/snortuserv1404 --location /var/lib/libvirt/images/ubuntu-12.04.5-server-amd64.iso --os-type linux --network=bridge:br0 --extra-args="console=ttys0,115200" --os-variant=ubuntuprecise

I get following error message (it's a bit different to the above):


Installation wird gestartet...
Datei version.info wird abgerufen... | 116 B 00:00 ...
Datei linux wird abgerufen... | 11 MB 00:00 ...
Datei initrd.gz wird abgerufen... | 39 MB 00:00 ...
Domain wird erstellt... | 0 B 00:00
Verbunden mit der Domain: vmsnort1
Escape-Zeichen ist ^]

After that nothing happens!


Thanks for read!

jmozdzen
12-Feb-2015, 18:41
Hi floregs3,

Hi Forum users,

my problem is about the command line Tool "virt-Install", to Install my first VM on command line. My Host is a Suse Linux Enterprise Server 12. The Problem is in my opinion a Virtualizations Problem, not an (for the Guest) Ubuntu problem.

My first config is in the following way: (with ubuntu-14.04.1-server-amd64.iso)

sudo virt-install --connect qemu:///system -n vmsnort1 -r 8096 -f /dev/vgDATE/snortuserv1404 --location /var/lib/libvirt/images/ubuntu-14.04.1-server-amd64.iso --os-type linux --network=bridge:br0 --extra-args="console=ttys0,115200" --os-variant=ubuntutrusty

I get following error message:

Installation wird gestartet...
Datei info wird abgerufen... | 136 B 00:00 ...
Datei version.info wird abgerufen... | 116 B 00:00 ...
ERROR Konnte hvm Kernel für Ubuntu Struktur nicht finden.

After that nothing happens!


My second config I use is because I thought the virt-install can't work with the latest Ubuntu Version:

I'd say that this perfectly describes the cause. You can configure a different VM loader, which you can tell where to get the kernel and initrd from...


Now I use ubuntu-12.04.5-server-amd64.iso


sudo virt-install --connect qemu:///system -n vmsnort1 -r 8096 -f /dev/vgDATE/snortuserv1404 --location /var/lib/libvirt/images/ubuntu-12.04.5-server-amd64.iso --os-type linux --network=bridge:br0 --extra-args="console=ttys0,115200" --os-variant=ubuntuprecise

I get following error message (it's a bit different to the above):


Installation wird gestartet...
Datei version.info wird abgerufen... | 116 B 00:00 ...
Datei linux wird abgerufen... | 11 MB 00:00 ...
Datei initrd.gz wird abgerufen... | 39 MB 00:00 ...
Domain wird erstellt... | 0 B 00:00
Verbunden mit der Domain: vmsnort1
Escape-Zeichen ist ^]

After that nothing happens!


Thanks for read!

Taking a peek at the log files inside the VM (by mounting the virtual disk image on Dom0, once the VM was stopped) might exhibit the cause of this. Either some device probe (or device handler) is blocking the boot process, or maybe the installer is not prepared to run on a text-only console?

Regards,
Jens