PDA

View Full Version : SLES 12 GUI



ekappes
17-Feb-2015, 14:39
I have a new installation of SLES 12. Regardless of settings, the only GUI that will display is one that shows the minimal options of Internet..System..Utilities..Settings..Logout when retrieving the menu from the lower left. Each of these items contains about two options.

I've tried setting default_wm in /etc/sysconfig to both Gnome and KDE, but neither will display. What other settings should I change?

jmozdzen
17-Feb-2015, 14:46
Hi ekappes,

I have a new installation of SLES 12. Regardless of settings, the only GUI that will display is one that shows the minimal options of Internet..System..Utilities..Settings..Logout when retrieving the menu from the lower left. Each of these items contains about two options.

I've tried setting default_wm in /etc/sysconfig to both Gnome and KDE, but neither will display. What other settings should I change?

from what I've read (I have no hands-on experience with SLES12 yet), there's no KDE in SLES12 no more.

Regards,
Jens

mikewillis
17-Feb-2015, 15:06
from what I've read (I have no hands-on experience with SLES12 yet), there's no KDE in SLES12 no more.

That's right, there is no KDE in SLE 12.



I have a new installation of SLES 12. Regardless of settings, the only GUI that will display is one that shows the minimal options of Internet..System..Utilities..Settings..Logout when retrieving the menu from the lower left. Each of these items contains about two options.

I've tried setting default_wm in /etc/sysconfig to both Gnome and KDE, but neither will display. What other settings should I change?
What you descibe could be ether IceWM or the default which is called the SLE-Classic variant of GNOME 3. If you open a terminal window and run

$ echo $DESKTOP_SESSION
that should return the relevant info.

/etc/sysconfig is a directory. default_wm is not a value that appears in any of the files in /etc/sysconfig. There is a value DEFAULT_WM that can be set in /etc/sysconfig/windowmanager . Comments in /etc/sysconfig/windowmanager indicates the default value is 'kde4' but that's wrong, as is the list of example values listed in Type:. A list of valid values can be determined by the names of the .desktop files in /usr/share/xsessions/


$ (cd /usr/share/xsessions/ && ls *desktop | sed 's/\.desktop//')

The Desktop Enviroment can be selected per-user on the login screen by selecting a user or entering a usercode, then clicking the cog icon next to the 'Sign In' button.

ekappes
17-Feb-2015, 17:35
You were correct--the only .desktop file I had was icewm.desktop, even though Gnome was supposedly already installed. I added additional Gnome components, changed DEFAULT_WM to gnome, and I am set (although I am disappointed about KDE).