PDA

View Full Version : Not able to Boot SUSE 12 using UEFI with PXE Server



manoj_bsw
18-Feb-2015, 08:25
Hi,

I am booting Suse12 with UEFI using PXE server. I am getting the below error:
VFS:Cannot open root device "(null)" or unknown-block(0,0): error-6
Please append a correct "root=" boot option; here are the avaialbe partiontons:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

I am new to Suse env. Please help me with above error. Below are the Partitioning and Answer file details which I am using.

Partitioning in YAST is given as below:

<partitioning config:type="list">
<drive>
<initialize config:type="boolean">true</initialize>
<partitions config:type="list">
<partition>
<filesystem config:type="symbol">vfat</filesystem>
<mount>/boot/efi</mount>
<partition_id config:type="integer">131</partition_id>
<size>240mb</size>
<disklabel>gpt</disklabel>
</partition>
<partition>
<filesystem config:type="symbol">swap</filesystem>
<mount>swap</mount>
<partition_id config:type="integer">130</partition_id>
<size>512mb</size>
</partition>
<partition>
<filesystem config:type="symbol">ext3</filesystem>
<mount>/</mount>
<partition_id config:type="integer">131</partition_id>
<size>max</size>
</partition>
</partitions>
<use>free</use>
</drive>
</partitioning>

And my answer (configuration) file I am using as below:

default=0
timeout=1
splashimage=(nd)/splash.xpm.gz
hiddenmenu
title Redhat
root (nd)
localboot 0
# The rest of this file is machine-generated

kernel /suse/suse13.2_x64/linux
append initrd=/suse/suse13.2_x64/initrd load_ramdisk=1 textmode=1 netdevice=eth0 autoyast=http://192.168.10.5/datastore/00-0C-29-B0-A3-CC install=http://192.168.10.5/datastore/suse/suse12x86_64

Thanks for solutions.

Automatic reply
22-Feb-2015, 14:30
manoj,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com

malcolmlewis
22-Feb-2015, 20:35
Hi
So your title is Redhat? Your initrd is openSUSE 13.2? and your source is suse12?



default=0
timeout=1
splashimage=(nd)/splash.xpm.gz
hiddenmenu
title Redhat
root (nd)
localboot 0
# The rest of this file is machine-generated

kernel /suse/suse13.2_x64/linux
append initrd=/suse/suse13.2_x64/initrd load_ramdisk=1 textmode=1 netdevice=eth0 autoyast=http://192.168.10.5/datastore/00-0C-29-B0-A3-CC install=http://192.168.10.5/datastore/suse/suse12x86_64

manoj_bsw
23-Feb-2015, 03:07
Hi
So your title is Redhat? Your initrd is openSUSE 13.2? and your source is suse12?



default=0
timeout=1
splashimage=(nd)/splash.xpm.gz
hiddenmenu
title Redhat
root (nd)
localboot 0
# The rest of this file is machine-generated

kernel /suse/suse13.2_x64/linux
append initrd=/suse/suse13.2_x64/initrd load_ramdisk=1 textmode=1 netdevice=eth0 autoyast=http://192.168.10.5/datastore/00-0C-29-B0-A3-CC install=http://192.168.10.5/datastore/suse/suse12x86_64



No, Sorry I copied wrong file. Correct Snippet is as below.

default=0
timeout=1
splashimage=(nd)/splash.xpm.gz
hiddenmenu
root (nd)
localboot 0
# The rest of this file is machine-generated

kernel /suse/suse12_x64/linux
append initrd=/suse/suse12_x64/initrd load_ramdisk=1 textmode=1 netdevice=eth0 autoyast=http://192.168.10.5/datastore/00-0C-29-B0-A3-CC install=http://192.168.10.5/datastore/suse/suse12x86_64