PDA

View Full Version : SMT sync failure



e972157
02-Mar-2015, 18:34
I'm getting a bunch of these in the SMT Sync Report:

DBD::mysql::db do failed: Duplicate entry 'suse-linux-enterprise-server-sp1-10-online-i386' for key 'PRODUCTLOWER' at /usr/lib/perl5/vendor_perl/5.10.0/SMT/SCCSync.pm line 675.

I probably won't spend much time trying to figure out how to fix SMT however I'll probably just rebuild.

kwk
03-Mar-2015, 10:09
Is the SMT up-to-date with the latest patches ?

If yes, please report your issue via a support request.

jjouannet
23-Mar-2015, 15:05
I'm getting a bunch of these in the SMT Sync Report:

DBD::mysql::db do failed: Duplicate entry 'suse-linux-enterprise-server-sp1-10-online-i386' for key 'PRODUCTLOWER' at /usr/lib/perl5/vendor_perl/5.10.0/SMT/SCCSync.pm line 675.

I probably won't spend much time trying to figure out how to fix SMT however I'll probably just rebuild.

Hello We figured out same issue on our SMT server. Server is SLES11SP3.

Downloading Product and Repository information
DBD::mysql::db do failed: Duplicate entry 'suse-linux-enterprise-server-sp1-10-online-i386' for key 'PRODUCTLOWER' at /usr/lib/perl5/vendor_perl/5.10.0/SMT/SCCSync.pm line 675.
DBD::mysql::db do failed: Duplicate entry 'suse-linux-enterprise-server-sp1-10-online-i386' for key 'PRODUCTLOWER' at /usr/lib/perl5/vendor_perl/5.10.0/SMT/SCCSync.pm line 675.

Any idea to solve this issue will be helpful.

kwk
23-Mar-2015, 15:42
Please update your SMT server to the latest patchlevel.

If the problem persists, open a support request.

mikewillis
23-Mar-2015, 16:01
Hello We figured out same issue on our SMT server. Server is SLES11SP3.

Downloading Product and Repository information
DBD::mysql::db do failed: Duplicate entry 'suse-linux-enterprise-server-sp1-10-online-i386' for key 'PRODUCTLOWER' at /usr/lib/perl5/vendor_perl/5.10.0/SMT/SCCSync.pm line 675.
DBD::mysql::db do failed: Duplicate entry 'suse-linux-enterprise-server-sp1-10-online-i386' for key 'PRODUCTLOWER' at /usr/lib/perl5/vendor_perl/5.10.0/SMT/SCCSync.pm line 675.

Any idea to solve this issue will be helpful.

I opened a Service Rrequest this morning about my instance of SMT producing that error when smt-sync is run. It was also producing lots more similar errors about other versions of suse-linux-enterprise-server. Less than two hours after raising the SR I was sent a link to PTF rpm which I was told would fix the issue, and it did. (The errors were still there on the first run of smt-sync after installing the update, but gone when I ran smt-sync the second time.) Given the speed with which I was sent a PTF I highly doubt it was created just for me. I suspect this is a known issue the fix for which is currently being provided to people who report the encountering the issue. I advise you raise a Service Request.