PDA

View Full Version : No video in ekiga



AlexDudko
12-Nov-2011, 10:36
Ekiga fails to show video with the "Your video driver doesn't support
the requested video format" message. In preferences only *v4l* is listed
but no *v4l2* at the same moment > gstreamer-properties command shows it uses *v4l2*.
Any thoughts how to enable video in Ekiga are welcome. It is SLED-11
SP1 OEM HP620.


--
AlexDudko
------------------------------------------------------------------------
AlexDudko's Profile: http://forums.novell.com/member.php?userid=100476
View this thread: http://forums.novell.com/showthread.php?t=448128

mikewillis
14-Nov-2011, 10:16
Have a look at the description for the package libv4l, I think it solves
your problem.
With libv4l installed you'd do.


Code:
--------------------
$ LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so ekiga
--------------------


A while back I wrote a wrapper script to make this it a bit less
cumbersome

Code:
--------------------
$ cat /usr/local/bin/v4l1compat
#!/bin/bash

# wrapper that can be used to... "add v4l1 application compatibility to v4l2
# drivers (such as the new gspca and the uvc driver)..." and "...it also handles
# conversion from cam specific formats to generic video formats for v4l2
# applications..."
# above text taken from
# http://fedoraproject.org/wiki/Features/BetterWebcamSupport#Documentation

# it will also correct for some cameras that output an upside down image
# and have no option to flip it in the driver. E.g. with the current RM One.

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so "$@"
--------------------



Code:
--------------------
$ v4l1compat ekiga
--------------------


--
mikewillis
------------------------------------------------------------------------
mikewillis's Profile: http://forums.novell.com/member.php?userid=7510
View this thread: http://forums.novell.com/showthread.php?t=448128