PDA

View Full Version : Problem syncing epel repository



nzle
17-Mar-2015, 20:41
We have channels setup for Oracle Linux which work ok, but we also have one for the epel repository which is giving me headaches.

We sync the channel via cron using the command
/usr/bin/spacewalk-repo-sync -Y -c epel_el6_x86_64

The sync goes through the motions but then gives many errors like


The package filezilla-debuginfo-3.7.3-1.el6.i686 which is referenced by patch FEDORA-EPEL-2013-11198 was not found in the database. This patch has been skipped.
Add Patch FEDORA-EPEL-2014-4642
The package mup-6.3-1.el6.i686 which is referenced by patch FEDORA-EPEL-2014-4642 was not found in the database. This patch has been skipped.
Add Patch FEDORA-EPEL-2013-6007
The package iipsrv-debuginfo-1.0.0-0.7.git0b63de7.el6.i686 which is referenced by patch FEDORA-EPEL-2013-6007 was not found in the database. This patch has been skipped.


Most but not all are -debuginfo. In the repository is a subdirectory for debug that appears to contain these(but not the ones that are not -debuginfo).

I tried adding another repository to the channel adding the debug folder to the url but it doesnt seem to be a repo unto itself.
Am I missing some setting that tells the sync to follow subfolders, or alternativly to not sync or not fail on these files?

kwk
18-Mar-2015, 09:09
Well, it seems as if EPEL does not provide -debuginfo packages. If I look at http://dl.fedoraproject.org/pub/epel/6 or http://dl.fedoraproject.org/pub/epel/6Server/, there are no debuginfo or debugsource packages.
Please contact the EPEL developers (see https://fedoraproject.org/wiki/EPEL for contact info) on how to access debuginfo packages.

nzle
18-Mar-2015, 13:32
They're in a subfolder underneath http://dl.fedoraproject.org/pub/epel/6/x86_64/debug/. But my sync doesn't pick them up. Is there Something I need to do to properly include them. It imports the others so its not a show stopper, but I really dislike disregarding status emails that say Failed.



Well, it seems as if EPEL does not provide -debuginfo packages. If I look at http://dl.fedoraproject.org/pub/epel/6 or http://dl.fedoraproject.org/pub/epel/6Server/, there are no debuginfo or debugsource packages.
Please contact the EPEL developers (see https://fedoraproject.org/wiki/EPEL for contact info) on how to access debuginfo packages.