PDA

View Full Version : SLES 11 SP3 Container can't connect to LAN



ndhuynh
30-Mar-2015, 10:11
Hi All,

I am a newbie in LXC, I create a new container with SLES (host & guest)
- The same network of cause (10.10.15.0/24).
- The host can access to LAN.
- The guest can connect to host and vice versa.
- The guest can't access from LAND and vice versa.

Could you show me where i am wrong?

This is my configuration:
Host:
hot-srv-sles11-01:/etc/sysconfig/network # cat ifcfg-br0

BOOTPROTO='static'
BRIDGE='yes'
BRIDGE_FORWARDDELAY='0'
BRIDGE_PORTS='eth1'
BRIDGE_STP='off'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR='10.10.15.53/24'
MTU=''
NAME=''
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='no'
PREFIXLEN='24'

hot-srv-sles11-01:/etc/sysconfig/network # cat ifcfg-eth1

BOOTPROTO='dhcp'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR=''
MTU=''
NAME='82545EM Gigabit Ethernet Controller (Copper)'
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='no'
PREFIXLEN='32'
PROMISC='yes'


hot-srv-sles11-01:/etc/sysconfig/network # cat /etc/lxc/a/config

lxc.network.type = veth
lxc.network.flags = up
lxc.network.link = br0
lxc.network.hwaddr = 02:00:43:fc:f9:17
lxc.network.ipv4 = 10.10.15.36/24
lxc.network.name = eth0
lxc.network.ipv4.gateway = 10.10.15.1
#remove next line if host DNS configuration should not be available to container
lxc.mount.entry = /etc/resolv.conf etc/resolv.conf none bind,ro 0 0
lxc.utsname = a

lxc.tty = 4
lxc.pts = 1024
lxc.rootfs = /var/lib/lxc/a/rootfs
lxc.mount = /etc/lxc/a/fstab


Thanks
Huynh Nguyen

Automatic reply
06-Apr-2015, 05:30
ndhuynh,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com

savithari
07-May-2015, 01:30
Hi :

I am also on SLES 11 SP3. I installed LXC on it. However I cant find the SLES LXC template. Could you please let me know where you found the SLES LXC template ?

Thanks for your time and attention.

Regards
-Narahari

smflood
12-May-2015, 13:16
On 07/05/2015 01:34, savithari wrote:

> I am also on SLES 11 SP3. I installed LXC on it. However I cant find
> the SLES LXC template. Could you please let me know where you found
> the SLES LXC template ?
>
> Thanks for your time and attention.

Answered in your own thread @ https://forums.suse.com/showthread.php?6355

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------