PDA

View Full Version : SLED 12... Is it really as broken as it feels?



djaquays
28-Apr-2015, 19:20
This is mostly a rant, but I'm hoping someone out there will see some of my rants and have an idea about how I'm doing something wrong/stupid and tell me the right way to do it. SLED 12 just seems broken. I really wish I would've stuck with SLED11 as I've never had any significant issues with it.

1) The combination of VMWare Workstation and life (especially browsers) are incompatible. We have a few installed of VMWare Workstation 11 (started with 10, same problems) and things randomly freeze - badly. This is especially true if you have a browser open. Firefox is the worst, but Opera 28 does it as well. The same hardware running SLED11 and Workstation 10 had no such problems.
2) The repositories are broken. Currently, there are 17 extensions for ant available in SLE-SDK12-Pool.. but no package for ant itself. java-1_7_0-openjdk-devel seems to be missing. There have been a couple of other strange omissions from the repositories, but these are the two I can remember off hand.
3) The audio subsystem seems broken. The default path reverts back to.. whatever instead of remembering your changes. There's also an issue with pidgin changing system volume. (which appears to be an upstream bug originally reported in 2013)


There are random other quirks that our users keep finding, most of them seem to be related to Gnome3, but it's hard to tell.
In general, going from SLED9, 10 and 11 where you'd have a few minor annoyances here and there but overall a fully developed and stable platform to.. this. If SLED12 were my first experience with SLED I would've never recommended anyone else use it.. ever.
It just seems that there was no effort on SUSE's (read: Attachmate's) part to make sure they were delivering a polished product.

mikewillis
29-Apr-2015, 22:07
1) The combination of VMWare Workstation and life (especially browsers) are incompatible. We have a few installed of VMWare Workstation 11 (started with 10, same problems) and things randomly freeze - badly. This is especially true if you have a browser open. Firefox is the worst, but Opera 28 does it as well. The same hardware running SLED11 and Workstation 10 had no such problems.

Can't comment on that since I haven't tried running VMWare Workstation on SLED 12 yet. I did have to downgrade from Workstation 11 to 10 on SLED 11 SP3 though due to a problem with VMs not letting go of mouse/keyboard focus though. Never saw the problem with 10, haven't seen it since I downgraded to 10.




2) The repositories are broken. Currently, there are 17 extensions for ant available in SLE-SDK12-Pool.. but no package for ant itself. java-1_7_0-openjdk-devel seems to be missing. There have been a couple of other strange omissions from the repositories, but these are the two I can remember off hand.

The SDK is accompaniment to both SLES and SLED and as a result contains packages that are installable on SLES but not SLED. The same is true on SLED 11 SP3. (I just tried installing all packages in the 11 SP3 SDK. I got through 50 packages zypper couldn't install due to missing dependencies before I got bored of select 'do not install'.) I guess there is a debate which could be had about how…helpful… it is to offer people a repo that contains packages they cannot install. ant is in the 11 SP3 SDK though and installable on SLED 11 SP3.




3) The audio subsystem seems broken. The default path reverts back to.. whatever instead of remembering your changes. There's also an issue with pidgin changing system volume. (which appears to be an upstream bug originally reported in 2013)

Url(s) for the bug?



There are random other quirks that our users keep finding, most of them seem to be related to Gnome3, but it's hard to tell.


Are you using the SLE-Classic mode of GNOME 3 that SUSE created for SLED 12? If so it might be interesting to see if the quirks occur under GNOME Classic or GNOME.


If you encounter reproducible issues, tell SUSE. If you can, raise Service Requests, if not use https://www.suse.com/support/report-a-bug/

malcolmlewis
29-Apr-2015, 22:28
On Wed 29 Apr 2015 09:14:01 PM CDT, mikewillis wrote:


djaquays;27663 Wrote:
>
> 1) The combination of VMWare Workstation and life (especially
> browsers) are incompatible. We have a few installed of VMWare
> Workstation 11 (started with 10, same problems) and things randomly
> freeze - badly. This is especially true if you have a browser open.
> Firefox is the worst, but Opera 28 does it as well. The same
> hardware running SLED11 and Workstation 10 had no such problems.
>
Can't comment on that since I haven't tried running VMWare Workstation
on SLED 12 yet. I did have to downgrade from Workstation 11 to 10 on
SLED 11 SP3 though due to a problem with VMs not letting go of
mouse/keyboard focus though. Never saw the problem with 10, haven't seen
it since I downgraded to 10.


djaquays;27663 Wrote:
>
> 2) The repositories are broken. Currently, there are 17 extensions
> for ant available in SLE-SDK12-Pool.. but no package for ant itself.
> java-1_7_0-openjdk-devel seems to be missing. There have been a
> couple of other strange omissions from the repositories, but these
> are the two I can remember off hand.
>
The SDK is accompaniment to both SLES and SLED and as a result contains
packages that are installable on SLES but not SLED. The same is true on
SLED 11 SP3. (I just tried installing all packages in the 11 SP3 SDK. I
got through 50 packages zypper couldn't install due to missing
dependencies before I got bored of select 'do not install'.) I guess
there is a debate which could be had about how_helpful_ it is to offer
people a repo that contains packages they cannot install. ant is in the
11 SP3 SDK though and installable on SLED 11 SP3.


djaquays;27663 Wrote:
>
> 3) The audio subsystem seems broken. The default path reverts back
> to.. whatever instead of remembering your changes. There's also an
> issue with pidgin changing system volume. (which appears to be an
> upstream bug originally reported in 2013)
>
Url(s) for the bug?

djaquays;27663 Wrote:
>
> There are random other quirks that our users keep finding, most of
> them seem to be related to Gnome3, but it's hard to tell.
>

Are you using the SLE-Classic mode of GNOME 3 that SUSE created for SLED
12? If so it might be interesting to see if the quirks occur under
GNOME Classic or GNOME.


If you encounter reproducible issues, tell SUSE. If you can, raise
Service Requests, if not use https://www.suse.com/support/report-a-bug/




Hi
I'm assuming that SUSE felt that ant and the jdk development packages
where more likely to be used at the server level rather than desktop
since the packages are both present on SLES 12, or just an oversight
(probably worth an SR or bug).

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.39-47-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

dojaqu
30-Apr-2015, 04:25
The SDK is accompaniment to both SLES and SLED and as a result contains packages that are installable on SLES but not SLED. The same is true on SLED 11 SP3. (I just tried installing all packages in the 11 SP3 SDK. I got through 50 packages zypper couldn't install due to missing dependencies before I got bored of select 'do not install'.) I guess there is a debate which could be had about how…helpful… it is to offer people a repo that contains packages they cannot install. ant is in the 11 SP3 SDK though and installable on SLED 11 SP3.
I understand how the SDK works. If the base packages are in the SLES iso, I'll gladly chase them down to get things working.


Url(s) for the bug?
The bugs listed are specific Knotify/Kmix
Bug at KDE: https://bugs.kde.org/show_bug.cgi?id=324975
Bug at Redhat: https://bugzilla.redhat.com/show_bug.cgi?id=1035066

However, it seems that it's really an issue with pulseaudio and they're trying to work around it.


Are you using the SLE-Classic mode of GNOME 3 that SUSE created for SLED 12? If so it might be interesting to see if the quirks occur under GNOME Classic or GNOME.
I was using SLE-Classic. I switched to GNOME Classic today but didn't have VMWare Workstation open much, so over the next couple of days I'll see if it resolves my freezing before changing anyone else.



If you encounter reproducible issues, tell SUSE. If you can, raise Service Requests, if not use https://www.suse.com/support/report-a-bug/
Will do.


Hi
I'm assuming that SUSE felt that ant and the jdk development packages
where more likely to be used at the server level rather than desktop
since the packages are both present on SLES 12, or just an oversight
(probably worth an SR or bug).

Which seems silly to me, since I prefer to do development on my workstation before moving it to a server, but as I said above.. if I can scavenge the packages from the SLES iso I can make due.


Most of the things we've run into are just annoyances that really add up to make the end product feel unfinished compared to the past few versions of SLED. I'll continue hoping that SP1 (and maybe a change away from SLE-Classic) fixes most of them.

The state of vinagre/xfreerdp/tsclient is another thing that's quite annoying.
You can install tsclient from the repos, but not rdesktop (required). Vinagre doesn't really front-end XFreeRDP well without calling Vinagre from CLI (to approve certs and enter passwords).

djaquays
04-May-2015, 15:15
After a few days of working, GNOME Classic seems to resolve the issues with VMWare Workstation completely.