PDA

View Full Version : Installing ImageMagick on SLES 11 SP3



MarkyC4A
30-Apr-2015, 19:20
I've been trying to get ImageMagick (and php5-imagick, it's respective PHP extension) to install on my SLES 11 SP3 server, but to no avail. It appears I'm missing libMagickWand.so.1, which is necessary to install. Are there repos I can add to zypper to get this shared lib?


> sudo zypper in php5-imagick
Refreshing service 'nu_novell_com'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libMagickWand.so.1()(64bit) needed by php5-imagick-3.1.2-1.17.x86
_64
Solution 1: do not install php5-imagick-3.1.2-1.17.x86_64
Solution 2: break php5-imagick-3.1.2-1.17.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c):

mikewillis
30-Apr-2015, 20:12
I've been trying to get ImageMagick (and php5-imagick, it's respective PHP extension) to install on my SLES 11 SP3 server, but to no avail. It appears I'm missing libMagickWand.so.1, which is necessary to install. Are there repos I can add to zypper to get this shared lib?


> sudo zypper in php5-imagick
Refreshing service 'nu_novell_com'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libMagickWand.so.1()(64bit) needed by php5-imagick-3.1.2-1.17.x86
_64
Solution 1: do not install php5-imagick-3.1.2-1.17.x86_64
Solution 2: break php5-imagick-3.1.2-1.17.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c):


Well there's a packaged called libMagickWand1 in SLED 11 SP3 that provides libMagickWand.so.1 but it's not in SLES 11 or in the SLE 11 SDK SP3. There is a package built for SLE 11 SP3 available from the openSUSE Build Service, but it's not supported by SUSE.
http://software.opensuse.org/package/libMagickWand1?search_term=libMagickWand1

Also I don't see a package called php5-imagick in the SLES 11 SP3 or SLE 11 SDK SP3 repos. Where is this php5-imagick package you're trying to install from?

MarkyC4A
30-Apr-2015, 20:31
I don't see a package called php5-imagick in the SLES 11 SP3 or SLE 11 SDK SP3 repos. Where is this php5-imagick package you're trying to install from?


I added the repo from here: http://software.opensuse.org/download.html?project=server:php:extensions&package=php5-imagick

EDIT: looks like there's going to be many more errors, likely stemming from both an unsuitable version of ImageMagick installed on the system, and using the incorrect repo from above. Is there a proper repo for both ImageMagick and php5-imagick?



> sudo zypper in php5-imagick
Refreshing service 'nu_novell_com'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides php(api) = 20121113 needed by php5-imagick-3.1.2-1.17.x86_64
Solution 1: do not install php5-imagick-3.1.2-1.17.x86_64
Solution 2: break php5-imagick-3.1.2-1.17.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c):

mikewillis
30-Apr-2015, 20:59
I added the repo from here: http://software.opensuse.org/download.html?project=server:php:extensions&package=php5-imagick


That's for SLE 11 not SLE 11 SP3.


. Is there a proper repo for both ImageMagick and php5-imagick?

ImageMagick is included in the SLE 11 SDK SP3 which you can download from https://download.suse.com/Download?buildid=hF8sRGTVC04~ You only need DVD1.


I can't see a package in either SLES 11 SP3 or the SDK that provides ImageMagick for PHP. There is one here http://software.opensuse.org/package/php53-imagick but it's not supported and I haven't tried it.