PDA

View Full Version : PHP version in SLES 12



sistemi_yacme
06-May-2015, 15:27
Hi everybody, which version of PHP is provided within SLES 12? As far as I understood there is no supported way to update to versions newer than 5.3 on SLES 11 SP3, so I am investigating if upgrading to SLES 12 will install PHP 5.4 or newer. I have downloaded SLES 12 isos but I did not find any PHP .rpm in them...

thsundel
06-May-2015, 15:47
Hi everybody, which version of PHP is provided within SLES 12? As far as I understood there is no supported way to update to versions newer than 5.3 on SLES 11 SP3, so I am investigating if upgrading to SLES 12 will install PHP 5.4 or newer. I have downloaded SLES 12 isos but I did not find any PHP .rpm in them...

I believe you need to add the web and scripting modules: https://www.suse.com/documentation/sles-12/book_sle_deployment/data/sec_add-ons_extensions.html

Thomas

smflood
06-May-2015, 17:52
On 06/05/2015 15:54, thsundel wrote:

> I believe you need to add the web and scripting modules:
> https://www.suse.com/documentation/sles-12/book_sle_deployment/data/sec_add-ons_extensions.html

Correct. That will then give you access to PHP 5.5.14.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

sistemi_yacme
07-May-2015, 09:30
On 06/05/2015 15:54, thsundel wrote:

> I believe you need to add the web and scripting modules:
> https://www.suse.com/documentation/sles-12/book_sle_deployment/data/sec_add-ons_extensions.html

Correct. That will then give you access to PHP 5.5.14.


Thank you guys. I will plan an upgrade to SLES 12 then.