PDA

View Full Version : Problems with SMTP Mailserver



gdejonge
15-May-2015, 16:02
Hi all,

I'm new to this community so please help me if i'm not in the correct forum or not asking the right questions. I'm fairly new to SuSe Linux Enterprise Server, but already like it a lot. At the moment I am working on my mail server and encountering some problems. I think I got quite far, but still missing some fine tuning in my configuration. So first the situation:

I'm setting up a simple mail server for my own domain (in this post I use example.com). I want to be able to mail to and receive mail from any mailadress (so also outside my local network or domain). For the configuration, I used the character based Yast module that comes with SLES. I'm configuring the server remote through the terminal.

I did the following steps:

Set up an LDAP server, with host mail, and hostname example.com. Did not configure any secure connections. Just want this simple mailserver to work and then continue learning and implement some security.
Edited my network settings and assigned a static IP, that is 10.0.0.11. Configured DNS servers are the 3 from my ISP.
Configured the mailserver using Cyrus IMAP. Also no security settings here, just want the thing to work and then i'll see whats next.
In usermanagement, I added some LDAP accounts and enabled the mail plugin.


When I configure my IMAP account in a mailclient, I seem able to receive mails but not send them. When I send a mail the client return an error saying: 554 5.7.1 <user@example.com>: Relay access denied .

I just can't seem to find the problem. I was hoping anyone could help me or give me some direction on where to look.

Thank you in advance, if more info is needed just let me know.

jmozdzen
19-May-2015, 16:53
Hi gdejonge,

> I'm new to this community

you immediately picked the right forum, at least to my taste. But please start with stating which SLES version you're running... so many variants around these days ;)

> Set up an LDAP server, with host mail, and hostname example.com. Did not configure any secure connections. Just want this simple mailserver to work

While LDAP servers perfectly fit into this picture, I assume you're talking about the mail transfer agent (MTA) here... Postfix, most likely.

> Relay access denied

What's in your /etc/postfix/main.cf file, regarding "smtpd_recipient_restrictions"? Did you configure your client's IP network as a permitted network, i.e. via "mynetworks"?

The message you receive is a result of anti-spam measures, "open relay" being the key word. Your MTA will only allow forwarding emails for clients within its local networks, or after authentication, or to local destinations.

My guess is that your client machine is outside the IP subnet the server is operating in, hence you need to add that client to the list of permitted machines. The easiest method (for starters, in a test environment) is by extending the "mynetworks" list by the network the client is in.

Regards,
Jens